Download it now!
Bug 31824 - Opening a Password protected documents open as read-only
Summary: Opening a Password protected documents open as read-only
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.3.0 RC1
Hardware: x86 (IA32) Linux (All)
: high major
Assignee: Cédric Bosdonnat
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-21 12:32 UTC by Saaz Rai
Modified: 2011-07-05 08:34 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Password = saaz (9.00 KB, application/msword)
2010-11-21 12:32 UTC, Saaz Rai
Details
Proposed patch (2.37 KB, patch)
2011-01-09 17:38 UTC, Nikita Ofitserov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Saaz Rai 2010-11-21 12:32:09 UTC
Created attachment 40465 [details]
Password = saaz

I am not able to find any bug report for this anywhere, hence reporting here.

Opening a Password protected documents open as read-only.

WRITER:

Steps to reproduce this:

1. Save a LibreOffice Writer file in doc format with password protection.

2. On opening the file it asks for the password.

3. On entering the correct password, the file opens as read-only.

This issue is not present in password protected odt files. 

CALC
Password protected xls and ods opens normally as expected in both OOo 3.2.1 and LibO 3.3 b3.

IMPRESS
There is no issue with odp file format. ODP files opens as expected on entering the correct password in both OOo3.2.1 and LibO3.3 b3.

LibreOffice 3.3 allows to save a ppt file format as password protected but doesn't ask for password while opening the file.
Comment 1 Don't use this account, use tml@iki.fi 2010-11-25 05:13:35 UTC
Cedric?
Comment 2 Saaz Rai 2010-12-23 21:10:42 UTC
This issue still exits in LibO 3.3 RC2.
Comment 3 Nikita Ofitserov 2011-01-09 17:38:11 UTC
Created attachment 41816 [details]
Proposed patch

I think that I've tracked this one down. Attached patch fixes .doc FIB decryption and does few renames there.
Comment 4 Saaz Rai 2011-01-19 20:40:09 UTC
(In reply to comment #3)
> Created an attachment (id=41816) [details]
> Proposed patch
> 
> I think that I've tracked this one down. Attached patch fixes .doc FIB
> decryption and does few renames there.

WRITER: The issue is now resolved in LibO 3.3 RC3. Many Thanks!!!

IMPRESS: As mentioned earlier:
There is no issue with odp file format. ODP files opens as expected on entering
the correct password in both OOo3.2.1 and LibO3.3 b3.

LibreOffice 3.3 allows to save a ppt file format as password protected but
doesn't ask for password while opening the file.
Comment 5 Nikita Ofitserov 2011-01-20 17:04:07 UTC
Why do you think this bug is resolved?
I confirm it with 3.3.0_rc4 on Windows.
Attached patch has not been applied yet.
Comment 6 Saaz Rai 2011-01-20 23:09:11 UTC
(In reply to comment #5)
> Why do you think this bug is resolved?
> I confirm it with 3.3.0_rc4 on Windows.
> Attached patch has not been applied yet.

I created a password protected DOC file using LibO 3.3 RC3/RC4 in Ubuntu installed from PPA. No issue here.

Again created a password protected DOC file using MS Office 2003 in Windows and opened using LibO 3.3 RC4 in same Ubuntu. Issue persists.
Comment 7 Cédric Bosdonnat 2011-02-11 08:01:21 UTC
(In reply to comment #5)
> Why do you think this bug is resolved?
> I confirm it with 3.3.0_rc4 on Windows.
> Attached patch has not been applied yet.

Sorry for being late... I reviewed your patch and pushed it to the master branch. For a next time, could you please add something like "[PATCH]" in the bug title to help spot the patches?

http://cgit.freedesktop.org/libreoffice/writer/commit/?id=bfd207762755511278520c73d7a931552db2518b
Comment 8 Saaz Rai 2011-02-17 07:31:02 UTC
(In reply to comment #7)
> (In reply to comment #5)
> > Why do you think this bug is resolved?
> > I confirm it with 3.3.0_rc4 on Windows.
> > Attached patch has not been applied yet.
> 
> Sorry for being late... I reviewed your patch and pushed it to the master
> branch. For a next time, could you please add something like "[PATCH]" in the
> bug title to help spot the patches?
> 
> http://cgit.freedesktop.org/libreoffice/writer/commit/?id=bfd207762755511278520c73d7a931552db2518b

Many Thanks,

Kindly confirm if the password issue with Impress is also resolved. Else will open another bug report.

Regards,
Saaz Rai
Comment 9 Julien HENRY 2011-07-05 06:45:15 UTC
I still have this issue while opening password protected XLS file created by MS Office. I am using :
LibreOffice 3.4.1 
OOO340m1 (Build:103)

Should I open a new issue or will someone reopen this one?
Comment 10 Cédric Bosdonnat 2011-07-05 08:34:42 UTC
(In reply to comment #9)
> I still have this issue while opening password protected XLS file created by MS
> Office. I am using :
> LibreOffice 3.4.1 
> OOO340m1 (Build:103)
> 
> Should I open a new issue or will someone reopen this one?

XLS is a different issue. Please check for other potential duplicates and file a new bug if needed.