Download it now!
Bug 31838 - Installation: Optional request whether information from existing User Profile should be used
Summary: Installation: Optional request whether information from existing User Profile...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.3.0 Beta3
Hardware: x86 (IA32) Windows (All)
: low enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-22 08:04 UTC by pierre-yves samyn
Modified: 2010-11-22 12:14 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pierre-yves samyn 2010-11-22 08:04:02 UTC
Hello

I have on my post several versions of OOo : 1.1.5, 2.4.2, 3.2.1

The install of LibO took over seamlessly (without question)
the user profile of 3.2.1

This raises several questions:
- Libo should it propose the resumption of an existing profile OOo (but IMHO yes
what about possible conflict of extensions)?
- If so the choice should be offered (if multiple versions)
(IMHO not necessary: resumption of the latest version)
- In any event the recovery must be interactive (may be
denied)

May be related with : https://bugs.freedesktop.org/show_bug.cgi?id=31702

Best regards
Comment 1 pierre-yves samyn 2010-11-22 08:07:30 UTC
Sorry I wrote : "I have on my post several versions of OOo". 

It is a gallicism I should write : "I have on my PC several versions of OOo"...
Comment 2 Rainer Bielefeld Retired 2010-11-22 09:07:33 UTC
[Reproducible] with "LibreOffice 3.3.0Beta3 - WIN XP DE [OOO330m9 (build 3.2.99.3)]"
I doubt that this will cause problems, because LibO does not use OOo 3.x user profile, but creates a new one (under WIN).

I asked for some hints in the WIKI 

I am pretty sure that this behaviour (or at least the Enhancement) might be Installer related and because of that OS related, so

@pierre-yves samy:
Please contribute Information concerning your OS
Comment 3 Thorsten Behrens (CIB) 2010-11-22 09:17:53 UTC
You can opt out of auto-migration via setting the SAL_DISABLE_USERMIGRATION
environment variable. LibO already tries migrating the newest OOo version first
(see officecfg/registry/data/org/openoffice/Setup.xcu's VersionIdentifiers
element for the specific order).

That leaves the question whether the config migration should be interactive -
it was decided that this is something that would confuse the vast majority of
the users on first start, so the default is to migrate the newest OOo config
(and opt-out via the expert option mentioned above).

See http://lists.freedesktop.org/archives/libreoffice/2010-October/000846.html
for the start of the discussion.
Comment 4 Rainer Bielefeld Retired 2010-11-22 10:01:21 UTC
@tbehrens:
I also believe that the current behaviour meets with needs for 99% of users, for resting 1% we can think about some selections in custom installation - with very low priority.
Comment 5 pierre-yves samyn 2010-11-22 12:12:38 UTC
> @pierre-yves samy:
> Please contribute Information concerning your OS

Sorry, I indeed forgot to mention my operating system : Windows XP SP3
Comment 6 pierre-yves samyn 2010-11-22 12:14:38 UTC
> See http://lists.freedesktop.org/archives/libreoffice/2010-October/000846.html
> for the start of the discussion.

thank you for the link