Download it now!
Bug 31896 - Allow to suppress number auto-formatting for copy / paste html contents
Summary: Allow to suppress number auto-formatting for copy / paste html contents
Status: RESOLVED DUPLICATE of bug 32400
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.0 Beta3
Hardware: All All
: low enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-24 06:47 UTC by Peter Morgan
Modified: 2010-12-20 08:40 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Morgan 2010-11-24 06:47:03 UTC
The candidate is here > http://m2.daffodil.uk.com/ERES.html

The issue is to copy the "Table" of interest and does not really include the "headers".

But rather the "data" itself ie the rows..
indeed the first few rows.. as your browser and space allows..


> copy the table
and 
> paste into a NEW sheet 

So.. some bizaree distortion of reality,
the problem is in the auto formatting of paste ..
I have tried every suggestion, under the Sun,
and hint to a resolution within my own oracles and thinking beads,
but I am living in this world of confusion,

Because all I Wish in a WILD dream..
is a simple "raw" copy and paste,
of <tr><td> cells intro cells
a set of characters as strings.
into a new sheet..
no paste special..
no pre formatted sheet..
..no macros NOTHING..
just a new sheet
.. nothing more
or
.. nothing less

no create a new sheet select all and preformat
maybe paste into a text and write a script was a suggestion..
IN the meantime..


eg 
19876-234-23
23-34-567
2010-zero

I do not see a reason why you should have to make an assumption about what I copied.

I do not want
19878 minus 234 minus 23 to be a calculation - I didnt ask that.. its copy text please... << FAIL

23-34-567 - yes our american its the 23 day of the 34 season of 567 combine harvester format == john deere formatting

or
2010-zero = 2010-00-00 >> ITS the new product Name.. a ball bearing that changes everything..

So this auto formatting has to be removed with immediate urgency..

TOP OTHER HINT
Windows character sets don't cut (thing blood)  and paste (thing plasters) into linux et all, even into kate, let alone a sharded window.


is what's in the table.. the text and not the wiggles lines,
even if its right handed for left style,
all the font formatting, provides by legacy.. PUFF ==== GONE
but..
>> 


PS
I thought I spend around 10 minutes on this bug, 
Spent around a few hours already..
Does not hurt anymore..

;-)
Comment 1 Rainer Bielefeld Retired 2010-11-24 09:30:05 UTC
For 'Paste Special Plain Text' it is possible to define column formattings. There is no such feature for pasting html contents, so that auto formatting will do some changes without any sense. For example in row containing "Anilazine" the first column will show 03.05.01 with my "LibreOffice 3.3.0Beta3 - WIN XP DE [OOO330m9 (build 3.2.99.3)]" instead of original "101-05-3". 

May be an option "format all target cells as text" might be a solution?

I am pretty sure that we had discussion concerning this issue in OOo, but a quick search for that did not show any hit for me.

@Peter Morgan:
You are wasting your and our time with such reports. 
If LibgeOffice does not fulfill your needs, please feel free to use some other office suite. If you want to help to improve LibO, you are welcome if you respect some rules. May I ask you to read 
<http://wiki.documentfoundation.org/BugReport> 
before you file further comment or bug reports?

Thank you

Rainer
Comment 2 Rainer Bielefeld Retired 2010-12-20 08:23:47 UTC
The longer I think about that issue the more charming an option "format all target cells as text" seems to me. That should not be too difficult and allows to format due to his needs for the user after copy/paste.
Comment 3 Kohei Yoshida 2010-12-20 08:40:08 UTC
So, I'm pretty sure this is a duplicate of Bug 32400, which I already fixed on master by launching the import option dialog when pasting an html table.

*** This bug has been marked as a duplicate of bug 32400 ***