Download it now!
Bug 31904 - Cannot scroll through document when the focus is in a comment (note)
Summary: Cannot scroll through document when the focus is in a comment (note)
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: All All
: medium major
Assignee: Cédric Bosdonnat
URL:
Whiteboard: target:3.4
Keywords:
: 33581 35454 36392 36559 39776 41327 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-11-24 13:43 UTC by Pierre Baraduc
Modified: 2018-04-15 15:35 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pierre Baraduc 2010-11-24 13:43:44 UTC
Open a new document, add some garbage do make two pages of text.
Add *two* notes (MSOffice comments) to the first page (say, one to the top line, and one in the middle).
Observe that now you can't scroll down to the second page.

This bug also exists in OpenOffice 3.3.
Comment 1 Yifan Jiang 2010-11-24 23:08:50 UTC
Hi Pierre,

This is interesting, but I didn't see the problem on my Linux.

I also noticed if you put the cursor focus in the Comments frame, the Libreoffice will help you stay in the comments area without scrolling up/down anywhere else. But leave the focus from the frame and back to document body, scrolling will work just normally.

If this is not the case would you please attach a sample document (odt) showing the weird behavior. Thanks~
Comment 2 Pierre Baraduc 2010-11-25 01:20:59 UTC
Yes, my faulty analysis.
You just need one comment, with the cursor inside the comment window.

I understand you only need to click back to the main text to be able to scroll again. However, this is IMHO an undesirable behavior for two reasons:

1. a fundamental one: scrolling is there to explore the document, not to edit it. You can scroll through a document whether the insertion point in at the beginning or at the end of the document, and luckily so. Why on earth would this behavior be different when dealing with comments?

2. a practical one: if you're inserting a comment somewhere and need to check either other comments or any nonvisible portion of the text, you have to click back to the main text. But since the next key you'll type will be to continue writing your comment, you'll have to click back to your comment window at the point where you left it. Time and energy not very well spent.

The way it works in M$ Office is probably better: with the insertion cursor in a comment, you can scroll through the document as much as you want. If you press a key it'll scroll back to your comment so that you can see what you're typing. Simple, efficient, and above all, consistent with the scrolling behavior you get when editing the main text.
Comment 3 Yifan Jiang 2010-11-25 01:53:43 UTC
Hi Cedric, I don't remember if OO.o worked the way like desired in C#2. It's more like an enhancement request for me. Would you help to confirm its a

bug / existing feature / enhancement ? ;) 

Thanks~
Comment 4 Pierre Baraduc 2010-11-25 02:06:43 UTC
It's a regression. It works normally in OO 3.2.1.
Comment 5 emas80spam 2011-02-01 06:35:57 UTC
Hi, I suggest to modify the importance to "high" because in my opinion this bug makes the comments totally unusable.
Just try to create some comments, maybe big enought so that you cannot see the point of the text where the comment is linked to...

You have to follow the pointed line between the comment and the text "by hand", if you click onto the comment the line becomes a real full line but you cannot scroll up to the point it refers to and you have just to "guess", it makes confusion.

In OpenOffice 3.2.1 it works pretty well.

I probably will go back to OpenOffice because my colleagues (Microsoft Word) use comments and I really can't work with this bug.
Comment 6 Cédric Bosdonnat 2011-02-03 05:09:03 UTC
I can reproduce this behavior in 3.3 branch, but not in master. It have been fixed in the meantime.
Comment 7 Cédric Bosdonnat 2011-02-03 05:11:42 UTC
*** Bug 33581 has been marked as a duplicate of this bug. ***
Comment 8 Pierre Baraduc 2011-02-04 05:06:32 UTC
I just checked and the bug still exists in LibreOffice 3.3 final.
The fix must have disappeared somewhere...
Comment 9 Cédric Bosdonnat 2011-02-04 05:54:20 UTC
(In reply to comment #8)
> I just checked and the bug still exists in LibreOffice 3.3 final.
> The fix must have disappeared somewhere...

In master branch, means this will be integrated in 3.4 release.
Comment 10 Rainer Bielefeld Retired 2011-03-20 04:42:02 UTC
Also WIN and Linux problem, so -> All

Works fine with "Ooo-Dev 3.4.0 multilingual version English UI WIN XP: [OOo300m103 (Build 9578)]"!
Comment 11 Rainer Bielefeld Retired 2011-03-20 04:45:00 UTC
*** Bug 35454 has been marked as a duplicate of this bug. ***
Comment 12 gleppert 2011-04-21 00:22:42 UTC
In LO 3.3.2 on Ubuntu, I have the same problem. Therefore, adding myself to CC. Glad to see that it will be solved in 3.4. Thanks.
Comment 13 gleppert 2011-04-21 00:27:45 UTC
*** Bug 36392 has been marked as a duplicate of this bug. ***
Comment 14 Rainer Bielefeld Retired 2011-04-24 22:39:38 UTC
Tested: fixed in "LibreOffice 3.4Beta2  – WIN7  Home Premium  (64bit) German UI [DEV300m103 (Build:1)]
Comment 15 Rainer Bielefeld Retired 2011-04-24 22:41:27 UTC
*** Bug 36559 has been marked as a duplicate of this bug. ***
Comment 16 Florent Angly 2011-04-24 22:58:36 UTC
Thanks for the fix. Could I have details on how what fix was implemented?

I ask because some comments can be long enough that they have their own scrollbar. If I am editing such a long comment, what happens if I scroll using the mouse wheel?

I am thinking that the best behaviour would be to scroll whatever section (text or comment) the mouse cursor is in, not necessary the section that is being edited (and has the blinking cursor).
Comment 17 vitriol 2011-09-25 13:01:36 UTC
*** Bug 39776 has been marked as a duplicate of this bug. ***
Comment 18 vitriol 2011-09-29 03:21:14 UTC
*** Bug 41327 has been marked as a duplicate of this bug. ***
Comment 19 Florent Angly 2011-12-24 00:29:38 UTC
To answer my own question, I tested LibreOffice 3.4.4. I can confirm that the bug is fixed and that the new behavior is to scroll whatever section (text or comment) the mouse cursor is in, not necessary the section that is being edited (and has the blinking cursor). Very nice!