Download it now!
Bug 31932 - Document preview image should not use transparent background
Summary: Document preview image should not use transparent background
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.3.0 Beta3
Hardware: All All
: low trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-26 01:20 UTC by Eliot the Cougar
Modified: 2012-09-08 12:36 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
This is how it looks now and how it should look (12.49 KB, image/png)
2010-11-26 01:20 UTC, Eliot the Cougar
Details
[Reproducible] with "LibreOffice 3.3.0Beta3 - WIN XP DE [OOO330m12 (build 3.2.99.3)]" (69.63 KB, application/pdf")
2010-11-30 01:40 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eliot the Cougar 2010-11-26 01:20:54 UTC
Created attachment 40583 [details]
This is how it looks now and how it should look

It should be an easy task... The preview image (./Thumbnails/thumbnail.png) generated by LibreOffice (and Oo.o since long ago) have transparent background where it should be "white"... It doesn't matter if you change "no fill" to "white" in the page options, "white" is always treated as "transparent"...

See the picture in attachment...

PS: I guess it's not an OS-specific bug...
Comment 1 Rainer Bielefeld Retired 2010-11-26 09:41:44 UTC
I can't fin out where this problem happens.

@Eliot:
Please contribute step by step instruction and information concerning your OS!
Comment 2 Eliot the Cougar 2010-11-26 11:48:42 UTC
@Rainer

Well... OS Windows, both XP and Vista, default style that has slightly dark background of the left info-pane in Explorer...

Open Writer, create a blank document, save it... Then open windows explorer and select this document to display its detail on the left pane... See that the document thumbnail has transparent background where it should have white...

I don't know what other details I can give...
The problem is somewhere when LibreOffice generated PNG image for a thumbnail to be displayed as an icon...
Comment 3 Eliot the Cougar 2010-11-26 12:02:44 UTC
Well... Okay... XP only...
Vista uses a white square behind the thumbnail, so "transparency" is not very noticeable... But if you change the window style somehow, things may change and it will be noticeable...

Importance is low anyway...
Comment 4 Rainer Bielefeld Retired 2010-11-30 01:40:30 UTC
Created attachment 40662 [details]
[Reproducible] with "LibreOffice 3.3.0Beta3 - WIN XP DE [OOO330m12 (build 3.2.99.3)]"

Yes, document shows WIN Explorer background color. Normally white would be better, IMHO.
Comment 5 Rainer Bielefeld Retired 2010-11-30 01:42:29 UTC
No Idea how those thumbnails have been created. By LibO or WIN?
Comment 6 Eliot the Cougar 2010-11-30 02:42:59 UTC
(In reply to comment #5)
> No Idea how those thumbnails have been created. By LibO or WIN?

Hmm... I did some tests... It seems that Windows Explorer treats "white" color in the PNG file as transparent no matter what...
I was able to make it behave by replacing #ffffff with #fefefe... It's unnoticeable, but makes Windows Explorer happy...

I'm not sure how png images are treated in Vista/7, it always uses white background for all thumbnails...
Comment 7 Thorsten Behrens (CIB) 2010-11-30 05:17:37 UTC
Ok, this makes it a WONTFIX - we cannot workaround an OS bug in thumbnail generation, which inherently has to work on all platforms.
Comment 8 Björn Michaelsen 2011-12-22 05:51:12 UTC
RESOLVED, FIXED or CLOSED bugs cant be KEYWORD NEEDINFO.