Download it now!
Bug 31976 - Two periods in a field make it not show
Summary: Two periods in a field make it not show
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.3.0 Beta3
Hardware: All All
: medium normal
Assignee: Cédric Bosdonnat
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-29 12:34 UTC by David Burke
Modified: 2010-11-30 11:35 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
demonstration of the problem (23.79 KB, image/png)
2010-11-29 12:35 UTC, David Burke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Burke 2010-11-29 12:34:32 UTC
When there are 2 periods present in a field text, the field does not display. See attached screenshot. Tested in Linux, Windows, and OpenOffice.org 3.2, all display the same behavior. 

I ran into this problem while programmatically replacing the fields. This function still worked, the fields are there, they just don't show visibly.
Comment 1 David Burke 2010-11-29 12:35:08 UTC
Created attachment 40647 [details]
demonstration of the problem
Comment 2 Yifan Jiang 2010-11-29 19:27:22 UTC
Cedric may want to look at this in Writer field?

This is reproduceable in LibreOffice 3.3 beta3/SLED 11 sp1

Meanwhile the subject does not accurately describe what I observed.

These patterns look working fine

..

.3.4

..34

.34.

3..4

34..

The only pattern I reproduced the problem is something like 

(.+\.){2}.*

namely:

3.4.
3.4.whatever
333.444.whatever
Comment 3 Cédric Bosdonnat 2010-11-30 07:33:43 UTC
Lubos, you can try this one.

Code pointer:
http://opengrok.go-oo.org/xref/writer/sw/source/core/fields/docufld.cxx#1446.

I'm not sure if the comment is still valid now: the sTmpName value has no quotes as it should if we read the comment.
Comment 4 Luboš Luňák 2010-11-30 08:20:09 UTC
Focus the 'Then' field and hit the 'Help' button to solve this mystery.

Whoever created this feature apparently didn't give it much thought, but it's documented and changing it would break backwards compatibility, so this is most probably WONTFIX.
Comment 5 Cédric Bosdonnat 2010-11-30 11:35:26 UTC
(In reply to comment #4)
> Focus the 'Then' field and hit the 'Help' button to solve this mystery.
> 
> Whoever created this feature apparently didn't give it much thought, but it's
> documented and changing it would break backwards compatibility, so this is most
> probably WONTFIX.

Yes, seen that... any text containing two periods or more needs to be escaped with quotes "1.1." otherwise it's understood as a database expression.