Download it now!
Bug 32010 - AT enabled: LibO crashes when clicking a Table control body with control design mode off.
Summary: AT enabled: LibO crashes when clicking a Table control body with control desi...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.3.0 Beta3
Hardware: Other All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-30 19:06 UTC by Yifan Jiang
Modified: 2012-09-25 11:00 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
crash stack (27.70 KB, text/x-log)
2010-11-30 19:06 UTC, Yifan Jiang
Details
crash stack with debug info (36.15 KB, text/plain)
2010-12-01 22:49 UTC, Yifan Jiang
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yifan Jiang 2010-11-30 19:06:45 UTC
Created attachment 40687 [details]
crash stack

Platform: SLED 11 sp1 i586
build info: LibreOffice 3.2.99.3

[Steps]

    1. Launch writer and choose View->Toolbars->Form Controls

    2. Click 'More Controls' button in the panel to call out an extra control
    panel

    3. Click the 'Table Control' in the panel and draw a table inside, you
    don't have to link any data inside.

    4. Exit the Design mode by clicking 'Design Mode On/Off' button on the
    form control panel called out in the step 1

    5. Single click inside the table body

[Problem]

    LibreOffice crashes.

[Extra Information]

    - This is a regression against OO.o 3.2.1

    - The crash does not happen in LibO 3.2.99.3 Novell build, so there are
      probably some difference here.
Comment 1 Yifan Jiang 2010-11-30 19:13:47 UTC
Hi Noel, maybe it's related with the VBA patch we did in beta1?
Comment 2 Rainer Bielefeld Retired 2010-11-30 20:53:32 UTC
I did not see a crash or any other problem with "LibreOffice 3.3.0Beta3 - WIN XP DE [OOO330m12 (build 3.2.99.3)]" Did I overlook a detail in the step by step instruction or is WIN not affected?
Comment 3 Yifan Jiang 2010-11-30 22:32:28 UTC
(In reply to comment #2)
> I did not see a crash or any other problem with "LibreOffice 3.3.0Beta3 - WIN
> XP DE [OOO330m12 (build 3.2.99.3)]" Did I overlook a detail in the step by step
> instruction or is WIN not affected?

Thanks for trying this Rainer. Ye...looks Windows build does not appear the problem.
Comment 4 Drew Jensen 2010-12-01 02:01:12 UTC
using Ubuntu 10.10 (64bit Gnome 2.32) and OpenSUSE 11.3 (32bit Gnome 2.3) w/ LibO 3.3. Beta 3 can not reproduce a crash. I checked with totally empty table controls (no columns) and after adding a few columns, again with no actual data source set. Switching design mode on/off - clicking into the control, on headers, and re-arranged column headers with design mode off...no crash, no problem at all.
Comment 5 Noel Power 2010-12-01 02:59:47 UTC
hmm nothing in that stack looks like anything to do with any vba related changes  infact it does look like it might be something to do with accessibility ( or at least triggered by  FmGridControl::GetAccessibleObjectDescription(svt::AccessibleBrowseBoxObjType, long) const () at #10 )

it would be worth I think getting a debug stack ( with line numbers ) that might shed some more light ( hopefully )
Comment 6 Yifan Jiang 2010-12-01 03:20:30 UTC
Thanks for all your confirmation and analysis ;) 

Noel, just remember I enabled 'Assistive Technologies' for another bug review. Disable it, the problem has been gone. Thank you! 

So we got a workaround here, and impact getting more narrow. I'll lower the priority and remove it from the blocker.
Comment 7 Yifan Jiang 2010-12-01 22:49:51 UTC
Created attachment 40724 [details]
crash stack with debug info

update crash stack with debug info.
Comment 8 Björn Michaelsen 2011-12-22 11:49:05 UTC
confirmed by stacktrace.
Comment 9 Björn Michaelsen 2011-12-23 11:35:44 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 10 Rainer Bielefeld Retired 2011-12-31 00:13:04 UTC
@Yifan Jiang, Björn Michaelsen:
The stacktrace is very old. Still a problem?
Comment 11 sasha.libreoffice 2012-01-14 01:15:37 UTC
on Fedora 64 bit not reproduced in LibO 3.3.4 and 3.5.0 beta 1
Comment 12 Julien Nabet 2012-02-09 12:02:18 UTC
I don't reproduce this problem with 3.5 branch on pc Debian x86-64.
No error in console too.

Do you still reproduce it ?
Comment 13 Florian Reisinger 2012-08-14 13:58:54 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 14 Florian Reisinger 2012-08-14 14:00:08 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 15 Florian Reisinger 2012-08-14 14:04:48 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 16 Florian Reisinger 2012-08-14 14:06:54 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 17 Stephan Bergmann 2012-09-25 11:00:10 UTC
At least on Fedora 17 with accessibility enabled via

  gsettings set org.gnome.desktop.interface toolkit-accessibility true

this is reproducible with a recent libreoffice-3-5 (towards LO 3.5.7) build: Load the 807450.odb attached as <https://bugzilla.redhat.com/attachment.cgi?id=573425> to <https://bugzilla.redhat.com/show_bug.cgi?id=807450> "[abrt] [a11y][reproducible] comphelper::OPropertySetAggregationHelper::getFastPropertyValue," open Form1, click e.g. into the square at the top-left of the table (i.e., the empty space to the left of the "Field1" header and above the columns).

However, it is no longer reproducible with neither a recent libreoffice-3-6 (towards LO 3.6.3) nor a recent master (towards LO 3.7) build.  Call stacks leading up to accessibility::AccessibleBrowseBoxBase::AccessibleBrowseBoxBase -> FmGridControl::GetAccessibleObjectDescription have changed substantially there, and there are no more such calls with _eObjType=BBTYPE_BROWSEBOX that take the code path that leads to the UnknownPropertyException.

So it looks like this issue got fixed somewhere along the way from LO 3.5 to 3.6, but it is unclear to me which specific commit addressed it.