Download it now!
Bug 32057 - Placeholder selection is fragile
Summary: Placeholder selection is fragile
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
3.3.0 Beta3
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-02 12:46 UTC by Rūdolfs
Modified: 2016-01-31 01:31 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rūdolfs 2010-12-02 12:46:51 UTC
When selecting the placeholder in formula preview, it does not always select the correct placeholder in edit panel. This error occurs if the placeholder is selected in the preview before it the preview is updated.

How to reproduce:
1. in edit pane, write in {<?>} over {<?>};
2. in graphical representation of formula, select first placeholder (the first <?> is selected in edit pane);
3. press "2", the formula should look like {2} over {<?>};
4. quickly (before the formula is updated) in graphical representation of formula, select second placeholder ( ">} " is selected in edit pane).

Instantaneous formula updating would help remedy this bug.
Comment 1 Jeffrey 2011-06-20 19:59:19 UTC
I agree with Rudolfs. It seems that there is an error with a delay in formula updating. It seems that in the first case, when one enters 2 in the top box of the graphical representation of "{<?>} over {<?>}", the editing text gets exchanged with  "{2} over {<?>}". So the edit panel has shifted two to the right (2 replaces <?>, the difference between length is 2). Therefore, if you rapidly select the bottom box in the graphical representation, it will select ">}" because it is now in the position of where the original <?> began. This can also be verified that when you add another digit to the numerator and rapidly press the bottom box, the highlighted portion will be "{<?", which makes sense in the case of the bug, since the overall editing panel text has moved to the right by 1 extra digit.

Reproduced in LibreOffice 3.4  350m1(Build:1) on OpenSuse.
Comment 2 Björn Michaelsen 2011-12-23 11:33:57 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 3 Viktor Ostashevskyi 2012-05-31 05:19:57 UTC
Reproduced on LibreOffice 3.5.4.2 on Windows XP
Comment 4 José Guilherme Vanz 2013-11-02 22:19:57 UTC
Reproduced on master
Comment 5 QA Administrators 2014-10-23 17:32:00 UTC
Please read this message in its entirety before responding.

Your bug was confirmed at least 1 year ago and has not had any activity on it for over a year. Your bug is still set to NEW which means that it is open and confirmed. It would be nice to have the bug confirmed on a newer version than the version reported in the original report to know that the bug is still present -- sometimes a bug is inadvertently fixed over time and just never closed.

If you have time please do the following:
1) Test to see if the bug is still present on a currently supported version of LibreOffice (preferably 4.2 or newer).
2) If it is present please leave a comment telling us what version of LibreOffice and your operating system.
3) If it is NOT present please set the bug to RESOLVED-WORKSFORME and leave a short comment telling us your version and Operating System

Please DO NOT
1) Update the version field
2) Reply via email (please reply directly on the bug tracker)
3) Set the bug to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 6 QA Administrators 2015-12-20 16:16:24 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (5.0.4 or later)
   https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 

3. Leave a comment with your results. 

4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 

4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-12-20
Comment 7 José Guilherme Vanz 2016-01-31 01:31:54 UTC
This bus is not reproducible in version 5.0.4.2. I'm closing the bug