Download it now!
Bug 32106 - Saving to XLSX format truncates sheet data at 64K rows
Summary: Saving to XLSX format truncates sheet data at 64K rows
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.0 Beta3
Hardware: Other All
: medium normal
Assignee: Katarina Behrens
URL:
Whiteboard:
Keywords:
: 34152 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-12-04 18:21 UTC by Drew Jensen
Modified: 2011-05-09 06:06 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Drew Jensen 2010-12-04 18:21:17 UTC
Test system Ubuntu 10.10, LibO 3.3 Beta 3 (user on ML confirmed w/ Windows)

Open the attached file - ODF format, 3000,000 rows, single column, integer data.

Save As -> OOXML

All rows after the 64K mark are dropped in new file.

Verified that this does not happen with OO.o 3.2.1 on same system.
Comment 1 Drew Jensen 2010-12-04 18:28:05 UTC
Test file can be found at:
http://baseanswers.com/downloads/300000-odf.ods
Comment 2 Kohei Yoshida 2010-12-04 18:28:49 UTC
Yup, known issue.  Katarina is working on this.

Unfortunately the fix for this will be very invasive, so we cannot do it for 3.3.  It requires testing of the existing xls binary import export filters as well.
Comment 3 Drew Jensen 2010-12-04 18:36:46 UTC
Thanks - want me to close this issue then as a duplicate then?
Comment 4 Kohei Yoshida 2010-12-04 22:37:06 UTC
No, let's leave it open.  The original bug is at novell's bugzilla, so it's good to have one here too.
Comment 5 Volker Merschmann 2010-12-05 02:20:12 UTC
CCing me
Thanks Drew for picking this from the mailing-list discussion
Comment 6 Katarina Behrens 2011-03-23 06:18:15 UTC
This should be implemented in 3.4
Comment 7 Katarina Behrens 2011-05-09 06:06:33 UTC
*** Bug 34152 has been marked as a duplicate of this bug. ***