Download it now!
Bug 32141 - Navigator in Writer shows all paragraphs instead of only headings
Summary: Navigator in Writer shows all paragraphs instead of only headings
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium major
Assignee: Cédric Bosdonnat
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-06 09:17 UTC by juhasecke
Modified: 2011-02-15 03:52 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
The Template with the navigator problem (11.93 KB, application/vnd.oasis.opendocument.text-template)
2010-12-10 05:30 UTC, juhasecke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description juhasecke 2010-12-06 09:17:13 UTC
When you popup the navigator it shows all paragraphs of the text instead of only headings. There seems to be no way to alter this.
Comment 1 Thorsten Behrens (CIB) 2010-12-10 02:43:48 UTC
Cannot reproduce, neither on mac nor linux - loading random document, pressing F5 - navigator comes up with the usual top-level entries, nothing expanded. Could you please try with a fresh install, potentially remove your ~/Library/Application Support/LibreOffice dir, and provide a step-by-step explanation what you do?
Comment 2 juhasecke 2010-12-10 03:12:13 UTC
Ok, I deleted ~/Library/Application Support/LibreOffice restarted LO and tried with a plain document. Everything is ok. But when I load my template every paragraph is treated as headline. So the template seems to either be broken or misconfigured. But I am not able to see how a can configure it correctly.
Comment 3 Thorsten Behrens (CIB) 2010-12-10 05:22:42 UTC
juhasecke, could you attach your problematic template to this bug?
Comment 4 juhasecke 2010-12-10 05:30:48 UTC
Created attachment 40986 [details]
The Template with the navigator problem

Hi,

this template might have a long history dating back to previous versions of OpenOffice.org and NeoOffice so it might be broken.
Comment 5 Alex Thurgood 2010-12-10 06:48:55 UTC
Confirming that this template causes the described behaviour - how strange. It might be necessary to look at the underlying XML, it seems to me that the paragraphs are all interpreted as Headings ?


Alex
Comment 6 Thorsten Behrens (CIB) 2010-12-10 07:06:09 UTC
Confirmed, the navigator indeed also shows plain paragraphs. Visible on all platforms.
Comment 7 Cédric Bosdonnat 2010-12-10 07:56:30 UTC
This one is for me it seems.
Comment 8 Cédric Bosdonnat 2011-02-15 03:52:20 UTC
The problem comes from the way you defined the outline levels in the template. You did that by setting the Outline level in the paragraph properties... which isn't the proper way to do this.

Use the Tools > Outline numbering... menu.

Closing as not a bug