Download it now!
Bug 32146 - ACCESSIBILITY: Extension Manager: loss of keyboard access after last button (accessibility)
Summary: ACCESSIBILITY: Extension Manager: loss of keyboard access after last button (...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.5.0 RC1
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: a11y-Windows
  Show dependency treegraph
 
Reported: 2010-12-06 09:50 UTC by Christophe Strobbe
Modified: 2013-08-07 19:47 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christophe Strobbe 2010-12-06 09:50:51 UTC
Bug detected in LibreOffice 3.3 RC1, on Windows XP: 
When tabbing after the last button in the Extension Manager, keyboard access is lost. Steps to reproduce the issue:
1. Open the Extension Manager (keyboard: Alt+T, then E),
2. The keyboard focus is on the Add button; press Tab to move to the other buttons: Check for Updates, Close, Help, Get more extensions online (the last one is a link, but is part of the Tab cycle), 
3. Then press Tab once more: the focus does not go back to the first button; pressing Shift+Tab does not move the focus back to the previous buttons, so it is impossible to continue using the Extension Manager from the keyboard. (Using the Arrow Up and Arrow Down keys to move through the list of extensions still works, but does not provide a solution.)

Note: the issue does not seem to reproduce itself when you are still in the Extension Manager right after adding a new extension: in that case, pressing Tab cycles the focus through the Disable & Remove buttons for the newly installed extension, followed by the buttons mentioned earlier (Add, Check for Updates, Close, Help, Get more extensions online, and then back to Disable, Remove).

Current workaround: exit the Extension Manager by pressing Esc and reopen it, then be careful not to tab past the last button.

This issue affects anyone who cannot use a pointing device, i.e. blind users and motor-impaired users, so it is an accessibility issue.
Comment 1 Rainer Bielefeld Retired 2010-12-06 10:42:32 UTC
[Reproducible] with "LibreOffice 3.3.0 RC1 - WIN XP German UI  [OOO330m17 (build 3.3.0.1)]"
Comment 2 Björn Michaelsen 2011-12-23 11:35:26 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 3 Christophe Strobbe 2012-01-27 08:07:26 UTC
Version info was originally LibO 3.3.0 RC1. I confirm that this bug is still
present in LibreOffice 3.5.0 RC1 although it looks slightly different because some checkboxes have been added to the Extension Manager dialog: when you open the dialog, the focus is on the Add... button (as before); when you start tabbing, the focus moves through Check for updates, Close, Help, the list of extensions, the Installation checkbox, the Shared checkbox, the User checkbox and the Get more extensions online link. After that, tabbing (Tab for forward tabbing or Shift+Tab for backward tabbing) does not lead to a visible focus indication. When pressing the Up and Down arrow keys, it appears that the focus is in the extension list. It is impossible to tab out of the extension list as long as you don't encounter a user-installed extension; when encountering a user-installed extension, focus can move to the Disable and Remove buttons, so it becomes possible to tab out of the extension list.
Changing status from NEEDINFO to NEW.
Comment 4 Christophe Strobbe 2013-08-07 16:24:24 UTC
Corresponding Apache OpenOffice bug: https://issues.apache.org/ooo/show_bug.cgi?id=116729
Comment 5 V Stuart Foote 2013-08-07 19:47:02 UTC
@Christophe,

WFM, the keyboard trap is no longer present in 4.1.1 or master. Nor in the current 4.0.5 rc1 -- so suggest this accessibility issued can be closed.

Keyboard only <Tab> or <Shift><TAB>, and cursor <UP, DOWN, LEFT, RIGHT> navigation moves in consistent and logical fashion.

But as a practical mater, but a different issue, the items listed in the extension panel do not have any accessible text, so the panel is silent when cursoring from item to item.