Bug 32150 - Extensions install even when they are unmarked
Summary: Extensions install even when they are unmarked
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
3.3.0 RC1
Hardware: x86 (IA32) Windows (All)
: medium major
Assignee: Don't use this account, use tml@iki.fi
URL:
Whiteboard:
Keywords:
: 32388 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-12-06 14:17 UTC by clio
Modified: 2011-12-23 13:45 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description clio 2010-12-06 14:17:44 UTC
On Windows the bundled extensions install even when they are unmarked. (LibO 3.3.0 rc1)
Comment 1 Rainer Bielefeld Retired 2010-12-06 21:07:05 UTC
@clio:
May I ask you to read <http://wiki.documentfoundation.org/BugReport>?

Then please:
- add information 
  -- concerning your PC
  -- details concerning unselected extensions (Name)
  -- How did you install: 
    --- your first LibO? 
      ---- Did you uninstall older OOo and / or LibO?
      ---- did you delete old user profiles?
    --- have those Extensions been installed for your older version(s)?
  -- everything else crossing your mind after you read a.m. URL
Comment 2 clio 2010-12-06 22:50:26 UTC
This problem occurs in Win XP SP2 with beta 2 or 3 (don't remember) and with Win XP (?) with RC1.
To reproduce:
1. Clean install, also delete the old profile before installing and the corresponding folder in Program Files if it is still there. When installing, choose "custom install"
2. Unselect Extensions component
Result: The bundled extensions installed anyway

Also, you can try to modify your installation, go to Add/Remove Programs, click "Change" button corresponding to LibreOffic. The extensions component is still unmarked.

See also http://nabble.documentfoundation.org/Non-removable-extensions-td1814379.html - This is also reproducible on Vista.
Comment 3 Thorsten Behrens (CIB) 2010-12-10 02:40:13 UTC
Tor, could you please have a look?
Comment 4 Don't use this account, use tml@iki.fi 2010-12-14 04:28:59 UTC
So we should remove the "extensions" in question from being visible in the installer, and the extension manager.

Haha, just teasing.
Comment 5 Don't use this account, use tml@iki.fi 2010-12-14 05:14:08 UTC
In RC1, the "Extensions" item in the installer does not have any subitems, its description does not say what functionality it actually contains, and it is also claimed to take zero disk space. (And, as this bug report says, even if one de-selects "Extensions", bundled extensions are still installed.)

I suggest we drop this item completely from the installer UI in 3.3, as it certainly is too late to start modifying the installer UI more fundamentally for 3.3 now and adding (back?) sub-items under "Extensions". Hopefully just dropping that non-informative and apparently pointless "Extensions" item is easy.

Additionally, I don't see the point in showing "extensions" that can't be removed, i.e. have the padlock image, in the Extension Manager at all. This just confuses users. Such things are then, in m humble opinion, not extensions.

Note that I said above this would be for 3.3.

For 3.4, I suggest that we move some of the bundled "extensions" to be normal features that are no more visible separately in the installer UI, or located in the installed file set, than any other functionality. Other bundled "extensions" could well be unbundled, if they truly are needed by just a small part of the user base.

Frankly, I find this whole idea that an arbitrary subset of features is marketed and packaged as "extensions" silly, and a historic relic from Sun days, presumably originally motivated by some non-technical reason.

Of course, the above is just my personal opinion, and not even a strong opinion. I don't care much anyway.
Comment 6 Don't use this account, use tml@iki.fi 2010-12-14 07:27:56 UTC
*** Bug 32388 has been marked as a duplicate of this bug. ***
Comment 7 Olivier Hallot 2010-12-14 07:57:21 UTC
Tor
Your comment#5 and observations are just the same as mine. 

+1
Comment 8 clio 2010-12-14 15:49:51 UTC
I think for 3.3 the best choice would be to fix the installer for Windows by adding subitems for different extensions, because this is the only way to uninstall bundled extensions.
Comment 9 clio 2010-12-22 07:30:33 UTC
Seems to be fixed in rc2
tested with:
1) LibO_3.3.0rc2_Win_x86_install_multi.exe+Win XP SP2
2) LibO_3.3.0rc2_Win_x86_all_lang.exe+Windows XP 64-bit sp2 ENU +MUI_RU
Comment 10 Rainer Bielefeld Retired 2010-12-24 00:57:40 UTC
Closing due to Comment 9

@reporter:
Please feel free to reopen this Bug if you find out that the problem will have erappeared in a later LibO version!