Download it now!
Bug 32178 - rdmaker SIGSEGVs during build on s390
Summary: rdmaker SIGSEGVs during build on s390
Status: CLOSED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.3.0 RC1
Hardware: Other Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-07 04:14 UTC by Rene Engelhard
Modified: 2012-04-24 13:09 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rene Engelhard 2010-12-07 04:14:46 UTC
Entering /build/buildd-libreoffice_3.3.0~rc1-1-s390-EgOPfh/libreoffice-3.3.0~rc1/libreoffice-build-3-3-0-1/build/libreoffice-3.3.0.1/stoc/source/proxy_factory

Making:    all_proxyfac.uno.dpslo
Compiling: stoc/unxlngs390.pro/misc/proxyfac.uno_version.c
/bin/bash: line 1:   441 Segmentation fault      LD_LIBRARY_PATH=${LD_LIBRARY_PATH+${LD_LIBRARY_PATH}:}/build/buildd-libreoffice_3.3.0~rc1-1-s390-EgOPfh/libreoffice-3.3.0~rc1/libreoffice-build-3-3-0-1/build/libreoffice-3.3.0.1/solver/330/unxlngs390.pro/lib /build/buildd-libreoffice_3.3.0~rc1-1-s390-EgOPfh/libreoffice-3.3.0~rc1/libreoffice-build-3-3-0-1/build/libreoffice-3.3.0.1/solver/330/unxlngs390.pro/bin/rdbmaker -BUCR -O../../unxlngs390.pro/bin/proxyfac.rdb @/tmp/mkO5uuvL
dmake:  Error code 139, while making '../../unxlngs390.pro/bin/proxyfac.rdb'

-----------------------------------------------------------------------
        Oh dear - something failed during the build - sorry !
  For more help with debugging build errors, please see the section in:
            http://wiki.documentfoundation.org/Development

 it seems that the error is inside 'stoc', please re-run build
 inside this module to isolate the error and/or test your fix:
-----------------------------------------------------------------------

/bin/bash
cd /build/buildd-libreoffice_3.3.0~rc1-1-s390-EgOPfh/libreoffice-3.3.0~rc1/libreoffice-build-3-3-0-1/build/libreoffice-3.3.0.1
source ./LinuxS390Env.Set.sh
cd stoc
build

when the problem is isolated and fixed exit and re-run 'make' from the top-level
sometimes (sadly) it is necessary to rm -Rf unxlngs390.pro in a module.
make[1]: *** [stamp/build] Error 1
make[1]: Leaving directory `/build/buildd-libreoffice_3.3.0~rc1-1-s390-EgOPfh/libreoffice-3.3.0~rc1/libreoffice-build-3-3-0-1'

beta3 worked there.
Comment 1 Rene Engelhard 2010-12-07 04:16:21 UTC
Full buildlog: https://buildd.debian.org/fetch.cgi?&pkg=libreoffice&ver=1%3A3.3.0~rc1-1&arch=s390&stamp=1291722759&file=log

Note this is critical for Debian, as it's a arch-regression to OOo and thus
this is release-critical (and blocks other stuff). Note I didn't set it to blocker, but I consider it a blocker for rc2 (or at least the next release)
Comment 2 Thorsten Behrens (CIB) 2010-12-10 03:13:37 UTC
Caolan, any idea? If not, throw it back at me, though no such system here ...
Comment 3 Caolán McNamara 2010-12-10 03:30:08 UTC
If rene could dig a backtrace out of it with gdb that might be helpful. Or grant access to a s390 that's be good too.

The only other option is to use hercules.

caolanm->rene: I guess getting access to the s390 is out of the question ?
Comment 4 Rene Engelhard 2010-12-31 13:18:47 UTC
> caolanm->rene: I guess getting access to the s390 is out of the question ?

yes, on that machine even "normal" DDs don't have access, it's the debian buildd.

I tried rc2 on a Debian porting machine, though and it worked. Still running but passed this hours ago. Hmm. :)
(the buildd is also building s390 for a long time so also seems to have survived this...)
Comment 5 Caolán McNamara 2011-01-04 00:33:16 UTC
So, looking good so far. Did this complete ?, if not what exact Debian would we have to install under hercules, I assume just head unstable sid ?
Comment 6 Rene Engelhard 2011-01-06 06:14:13 UTC
> So, looking good so far. Did this complete ?,

yes. (including smoketest, on a other build I have a smoketest failure, so it
seems to be a bit flaky anyways: https://buildd.debian.org/fetch.cgi?&pkg=libreoffice&ver=1%3A3.3.0~rc2-3&arch=s390&stamp=1293999550&file=log)

> if not what exact Debian would we have to install under hercules, I assume just head unstable sid ?

yes
Comment 7 Caolán McNamara 2011-12-19 04:27:39 UTC
build 3.4 recently on s390/s390x RHEL-6 and it worked fine