Download it now!
Bug 32217 - Writer freezes when opening certain .odt file
Summary: Writer freezes when opening certain .odt file
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 RC1
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-08 01:09 UTC by Jiří Svoboda
Modified: 2011-12-22 05:51 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Culprit file (25.88 KB, application/vnd.oasis.opendocument.text)
2010-12-08 01:09 UTC, Jiří Svoboda
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jiří Svoboda 2010-12-08 01:09:26 UTC
Created attachment 40903 [details]
Culprit file

Attempting to open a certain file, created with previous versions of ooo, freezes the Writer UI in windows. Works fine in Oracle OO 3.3.0 RC7.

Culprit file attached.

LibreOffice 3.3.0 
OOO330m17 (Build:3)
libreoffice-build 3.3.0.1
Windows XP SP3 32bit
Comment 1 Cédric Bosdonnat 2010-12-09 04:37:20 UTC
I can't reproduce it here neither with a master nor 3.3 build.

Could you provide a gdb trace by following the instructions here: http://wiki.documentfoundation.org/BugReport
Comment 2 Jiří Svoboda 2010-12-09 06:45:34 UTC
I would love to help, but there is no information how to make a gdb trace in Windows. Tried the cygwin GDB without success.
Comment 3 Cédric Bosdonnat 2010-12-10 02:01:16 UTC
I can't reproduce the crash here with a fresh build of master branch on Windows 7. I'll close the bug, feel free to reopen if the bug still appears in later versions.
Comment 4 Thorsten Behrens (CIB) 2010-12-10 03:23:06 UTC
Looked into that, there's a wmf in the document - does not crash here, either, but Rodo, could you have a brief look whether emf+ may interfere here please?
Comment 5 Jiří Svoboda 2010-12-10 05:22:00 UTC
(In reply to comment #4)
> Looked into that, there's a wmf in the document - does not crash here, either,
> but Rodo, could you have a brief look whether emf+ may interfere here please?

Note: I tried to remove the wmf prom the file and LibO had successfully opened the file on my rig.
Comment 6 Björn Michaelsen 2011-12-22 05:37:01 UTC
Remove infoprovider from closed and resolved bugs.
Comment 7 Björn Michaelsen 2011-12-22 05:51:13 UTC
RESOLVED, FIXED or CLOSED bugs cant be KEYWORD NEEDINFO.