Download it now!
Bug 32225 - DocumentProperty PrintDate not working
Summary: DocumentProperty PrintDate not working
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.3.0 RC1
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-08 02:53 UTC by Jürgen Blumenschein
Modified: 2011-12-23 13:45 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jürgen Blumenschein 2010-12-08 02:53:13 UTC
I need the DocumentProperty PrintDate, which I transfer to document management software. Within OpenOffice.org I used following Basic code:

dim oPrintDate As Object
if hasUnoInterfaces(oOfficeDatei,"com.sun.star.document.XDocumentPropertiesSupplier") then
   oPrintDate = oOfficeDatei.DocumentProperties.PrintDate
else
   oPrintDate = oOfficeDatei.getDocumentInfo().PrintDate ' DEPRACTED
endif

Now neither this macro is working nor is the PrintDate visible in the LibreOffice dialog (Datei-Eigenschaften / File-Properties).

At least this happens with Text-Dokuments in the german localisation.
Comment 1 Rainer Bielefeld Retired 2010-12-08 03:33:14 UTC
At least print date in document properties dialog is correct with "LibreOffice 3.3.0 RC1 - WIN XP German UI  [OOO330m17 (build 3.3.0.1". 

Macro does not run in OOo3.1.1 and not in LibO, both with message "Objektvariable nicht belegt".

I believe here we should concentrate on problem "Print date not visible in Document Proberties dialog", for Macro problems please file a new Bug if necessary.

@Jürgen Blumenschein:
May I ask you to read <http://wiki.documentfoundation.org/BugReport>?
Then please 
- Contribute a very simple document with information 
  when you did the last printout from it
- for a new Bug report to be filed after we have checked 
  Document Properties problem:
    -- Contribute more detailed information, "Macro is not working is very vague"
    -- Attach a sample document with a macro demonstrating you problem 
       (for example something like "Print  oPrintDate")?
Comment 2 Rainer Bielefeld Retired 2010-12-18 00:49:18 UTC
Closing Bug due to reporter's inactivity as WFM.
I will finally close the Bug after 10 days if we will not have got required additional information.

@reporter:
Please feel free to reopen this Bug if you find out that the problem still exists in the latest release of LibO and if you can provide requested additional information.