Bug 32257 - Frame with spacing to contents when border line-style is "none"
Summary: Frame with spacing to contents when border line-style is "none"
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 RC1
Hardware: Other All
: medium normal
Assignee: Cédric Bosdonnat
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-09 00:58 UTC by clio
Modified: 2011-07-07 05:23 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments
illustration (12.48 KB, image/png)
2010-12-09 00:58 UTC, clio
Details
ODT file with Frames (File/New/Labels...) (9.33 KB, application/vnd.oasis.opendocument.text)
2010-12-09 06:45 UTC, clio
Details
illustration 2 (13.12 KB, image/png)
2010-12-09 10:57 UTC, clio
Details

Note You need to log in before you can comment on or make changes to this bug.
Description clio 2010-12-09 00:58:39 UTC
Created attachment 40944 [details]
illustration

To reproduce:
1. Open Writer
2. Menu Insert/Frame...
3. Line arrangement "Set All Four Borders", Line-style "none", spacing to contents 1 cm. (see ecreenshot) Click OK.
Result: Spacing to contents reset to none.

The way to enable spacing to contents seems to be to set line color white with width 0,05 pt.
Comment 1 Cédric Bosdonnat 2010-12-09 02:38:53 UTC
(In reply to comment #0)
> Created an attachment (id=40944) [details]
> illustration
> 
> To reproduce:
> 1. Open Writer
> 2. Menu Insert/Frame...
> 3. Line arrangement "Set All Four Borders", Line-style "none", spacing to
> contents 1 cm. (see ecreenshot) Click OK.
> Result: Spacing to contents reset to none.
> 
> The way to enable spacing to contents seems to be to set line color white with
> width 0,05 pt.

What's the need to have spacing to content when there is no border? I you want to have space between the text outside the frame and the text inside the frame, then you need to adjust the Spacing values in the Wrap tab.

All 4 borders with none type is the same than no border at all... I'm closing as INVALID, feel free to reopen if this doesn't answer your concern.
Comment 2 clio 2010-12-09 06:45:36 UTC
Created attachment 40953 [details]
ODT file with Frames (File/New/Labels...)

What about this file? Wrap is not an option in this example. (To create such files go to File/New/Labels menu.) An option would be white line with a 0,05 pt width. But this isn't only about impossibility to do this either way, but rather about that the setting isn't stored. Either the "Spacing to contents" should be disabled when line "-none-" is selected, either the none line should be removed from the list of line-styles (the first way is preferable IMHO). An invisible line color would be good too, but this is RFE, not a bug.
Comment 3 clio 2010-12-09 10:57:59 UTC
Created attachment 40957 [details]
illustration 2

You can reproduce this bug doing also this:
1. Insert Frame in Writer, open the Frame-Borders dialog.
2. Set "Left and Right Borders Only". Result - Top and Bottom margin fields disabled
3. Click on the upper border of the preview box to set upper border for the frame. Result - Top and Bottom margin fields disabled. but the Top margin field should be enabled.
Comment 4 Cédric Bosdonnat 2010-12-10 01:48:11 UTC
Taking that one
Comment 5 Cédric Bosdonnat 2011-07-07 05:23:53 UTC
Fixed by this commit:
http://cgit.freedesktop.org/libreoffice/libs-core/commit/?id=4f9ba9186a0a6fe90e5f3adde874ce34638c9536

target version: 3.5