Download it now!
Bug 32283 - PDF not correctly imported when draged into LibO new empty document
Summary: PDF not correctly imported when draged into LibO new empty document
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-09 18:02 UTC by grigoreflorin1985
Modified: 2017-08-15 18:07 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
test file that give the bug (19.49 KB, application/pdf)
2010-12-09 23:35 UTC, grigoreflorin1985
Details

Note You need to log in before you can comment on or make changes to this bug.
Description grigoreflorin1985 2010-12-09 18:02:26 UTC
It is imported like a blank paragraph and same thing happens with Draw. The open pdf function work perfect with file open but not while dragin the file into openeded Draw,Writer etc
Comment 1 Jan Holesovsky 2010-12-09 23:28:52 UTC
Please provide the document that causes you this trouble.  Thank you!
Comment 2 grigoreflorin1985 2010-12-09 23:35:51 UTC
Created attachment 40983 [details]
test file that give the bug
Comment 3 grigoreflorin1985 2010-12-09 23:37:47 UTC
Tested again in Draw , Spreadsheet and found that it is only an Writer bug the fact that`s loading a null paragraph.

Maybe a fix to move the file to Draw like Spreadsheet do ?

That looks like a fix :)
Comment 4 Björn Michaelsen 2011-12-23 11:34:57 UTC Comment hidden (obsolete)
Comment 5 Björn Michaelsen 2011-12-23 17:01:57 UTC
needinfo keyword redundant by needinfo status.
Comment 6 sasha.libreoffice 2012-01-04 01:51:38 UTC
Reproduced on LibO 3.5.0 beta 1 on Fedora 64 bit
Writer inserts dropped in its window documents (text documents) as sections. It is ok. And when we drop pdf there, writer thinks that it is text document and inserts sections. But able nothing to do with it.
IMHO it would be better if Writer accept pdf as picture when dropped in its window.
Comment 7 A (Andy) 2013-05-03 21:29:20 UTC
I can't open this attached file in Adobe Reader X?

@Sasha: Could you please give more information about the individual steps how to reproduce it?  I am not sure whether I understand this correctly.
Comment 8 sasha.libreoffice 2013-05-04 06:54:48 UTC
Steps to reproduce:
0. Start Writer (empty document appears)
1. Start any filemanager (in my case used Krusader)
2. Find any correct PDF file and drag and drop it into Writer's document
3. In dialog about inserting section click "OK"
Expected: contents of pdf should be somehow shown in document
Actually: empty section in document
Comment 9 A (Andy) 2013-05-04 07:51:07 UTC
@Sasha: Thank you very much for the additional information how to reproduce it.

tested with an additional own working pdf-document -> reproducible with LO 4.0.2.2 (Win7 Home, 64bit)
Comment 10 tommy27 2014-06-29 08:35:33 UTC
still reproducible under Win7x64 with LibO 4.2.4.2 and 4.4.0.0.alpha0+
Build ID: 95272e7e5b7e38753ab07dbd6503b7cfa2974842
TinderBox: Win-x86@42, Branch:master, Time: 2014-06-26_23:01:43
Comment 11 tommy27 2014-06-29 08:44:33 UTC
edited summary notes.
if you drag the pdf into the start screen if loads the pdf in Draw.
Comment 12 QA Administrators 2014-10-23 17:31:47 UTC Comment hidden (obsolete, spam)
Comment 13 sasha.libreoffice 2014-10-24 11:03:19 UTC
reproduced in 4.3.1.2 on WinXP
Comment 14 Konrad Beringer 2014-11-14 15:02:58 UTC
Try to open existing PDP file will imported twice (automatic), therefore the new document will be not clear shown and can’t be used.
Konrad
Comment 15 tommy27 2014-11-14 16:54:55 UTC
@Konrad 
do not change version field. it has to indicate earliest version the bug has been reproduced, not the latest.
Comment 16 QA Administrators 2015-12-20 16:19:24 UTC Comment hidden (obsolete, spam)
Comment 17 QA Administrators 2017-01-03 19:50:37 UTC Comment hidden (obsolete)
Comment 18 Thomas Woltjer 2017-08-15 17:36:41 UTC
No longer a problem.

Version: 6.0.0.0.alpha0+
Build ID: 3b8db1ebc98d4a4ec54fd7be4ebc3aedc97b9f21
CPU threads: 1; OS: Linux 4.9; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.utf8); Calc: group
Comment 19 tommy27 2017-08-15 18:07:03 UTC
nice to hear that.
RESOLVED WORKSFORME