Download it now!
Bug 32344 - Writer insert wrong page break when copying first paragraph column in doc format
Summary: Writer insert wrong page break when copying first paragraph column in doc format
Status: RESOLVED DUPLICATE of bug 118711
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Page-Break DOC-Paragraph DOC-Page
  Show dependency treegraph
 
Reported: 2010-12-13 00:05 UTC by Stefano Fraccaro
Modified: 2020-04-24 06:57 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Document after first "Save as..." (11.00 KB, application/msword)
2010-12-13 00:07 UTC, Stefano Fraccaro
Details
Document after second "Save as..." (11.50 KB, application/msword)
2010-12-13 00:07 UTC, Stefano Fraccaro
Details
test3.doc (13.00 KB, application/msword)
2010-12-13 01:36 UTC, Yifan Jiang
Details
test 2 in LO 6.1 (12.50 KB, application/msword)
2018-10-07 02:07 UTC, Christian Pietzsch
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stefano Fraccaro 2010-12-13 00:05:39 UTC
Helmut Leininger has found this bug. Here are the steps:

1. Create empty document
2. Make page orientation album with 2 columns and margins 1.0, 1.0, 1.0, 1.0 
cm (up, down, left, right)
3. Create table 2*2 and move it to the bottom of the column using enters.
4. Copy first column with ctrl+c
5. Paste to the second column.
6. Save as doc (test.doc)
7. Open the file.
8. Mark first collumn on the page and copy it with Ctrl+C
9. Mark the second column on the page and press ctrl+v
10. Save document and close it (test2.doc)
11. Open it.
Comment 1 Stefano Fraccaro 2010-12-13 00:07:11 UTC
Created attachment 41054 [details]
Document after first "Save as..."
Comment 2 Stefano Fraccaro 2010-12-13 00:07:54 UTC
Created attachment 41055 [details]
Document after second "Save as..."
Comment 3 Stefano Fraccaro 2010-12-13 00:10:00 UTC
After first column in page 1 there is a wrong section break. Because of that the original column 2 in page 1 is empty
Comment 4 Yifan Jiang 2010-12-13 01:36:23 UTC
Hello, druido77, thanks for reporting. I am not sure if I understand the steps quite clear.

(In reply to comment #0)
> Helmut Leininger has found this bug. Here are the steps:
> 
> 1. Create empty document
> 2. Make page orientation album with 2 columns and margins 1.0, 1.0, 1.0, 1.0 
> cm (up, down, left, right)
> 3. Create table 2*2 and move it to the bottom of the column using enters.
> 4. Copy first column with ctrl+c

How did you select the first column. i.e, something like put the cursor on the top the column, and Shift+click the end of the column?

> 5. Paste to the second column.
> 6. Save as doc (test.doc)
> 7. Open the file.
> 8. Mark first collumn on the page and copy it with Ctrl+C
> 9. Mark the second column on the page and press ctrl+v
> 10. Save document and close it (test2.doc)
> 11. Open it.

I tried to do these steps in 3.3 rc1 and the result is a bit different (no data missing here):

left column in the 1st page: has table
right column in the 1st page: empty
left column in the 2nd page: has table
right column in the 2nd page: has table

Please see my attachment test3.doc :)
Comment 5 Yifan Jiang 2010-12-13 01:36:54 UTC
Created attachment 41056 [details]
test3.doc
Comment 6 Yifan Jiang 2010-12-13 01:39:35 UTC
(In reply to comment #5)
> Created an attachment (id=41056) [details]
> test3.doc

And if I understand it correctly, the expected result should be:

left column in the 1st page: has table
right column in the 1st page: has table
left column in the 2nd page: has table
right column in the 2nd page: empty

Is that what you concerned?
Comment 7 Stefano Fraccaro 2010-12-13 01:55:38 UTC
I select the column with mouse movements and do copy/paste operation by pressing ctrl+c and ctrl+v. You can see a demo video at

http://www.stefanofraccaro.org/video_32344.zip

I have followed all steps... I save and reopen ever the same file, but before and after the second "save as..." the document is different.
Comment 8 Stefano Fraccaro 2010-12-13 02:07:32 UTC
(In reply to comment #6)
> > Created an attachment (id=41056) [details] [details]
> > test3.doc
> 

The expected result is a bit different but, also in your case, there is a section break in column 1 of page 1. Why? You have never inserted a page break in this document... but the page break exists
Comment 9 Yifan Jiang 2010-12-13 02:50:33 UTC
Thanks for clarification, confirmed with 3.3 rc1. The topic and C#4 is actually the same issue.
Comment 10 Cédric Bosdonnat 2010-12-13 07:10:12 UTC
I can reproduce it too... Lubos, maybe one for you?
Comment 11 vitruss 2011-04-22 02:49:12 UTC
Is there any chance that this bug can be fixed?
Actualy there is the same issue, when drag and dropping portion of text from one collumn to another.
Comment 12 A (Andy) 2013-04-27 10:53:08 UTC
reproducible with LO 4.0.2.2 (Win7 Home, 64bit)
Comment 13 bfoman (inactive) 2013-07-26 09:28:44 UTC Comment hidden (obsolete)
Comment 14 QA Administrators 2014-10-23 17:31:35 UTC Comment hidden (obsolete)
Comment 15 QA Administrators 2015-12-20 16:13:56 UTC Comment hidden (obsolete)
Comment 16 Stefano Fraccaro 2016-01-07 13:06:00 UTC
I tested again this bug with LibreOffice 5.0.4 x64 on Windows 7. The bug still persist.
Comment 17 Timur 2018-03-13 14:26:35 UTC
Please test again with master https://dev-builds.libreoffice.org/daily/master/.
And attach ODT document saved after step 5.
Comment 18 Christian Pietzsch 2018-10-07 02:06:27 UTC
I tested it in: 
Version: 6.1.0.3
Build ID: 6.1.0-2
CPU threads: 12; OS: Linux 4.18; UI render: default; VCL: gtk2; 
Locale: de-DE (en_US.UTF-8); Calc: group threaded

After saving the document, things are still normal (Column 1 and 2 the same on the first page). After closing and reopening, a page break appears pushing the content of column 2 on page one to column 1 on page 2.
Comment 19 Christian Pietzsch 2018-10-07 02:07:41 UTC
Created attachment 145440 [details]
test 2 in LO 6.1
Comment 20 QA Administrators 2019-10-08 02:28:12 UTC Comment hidden (obsolete, spam)
Comment 21 Justin L 2020-04-24 06:57:41 UTC
Because you are copying the very first paragraph from a .doc* format and pasting it and getting a page break, that sounds like another version of bug 118711

*** This bug has been marked as a duplicate of bug 118711 ***