Bug 32427 - LibreOffice freezes when starting Firefox
Summary: LibreOffice freezes when starting Firefox
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Jan Holesovsky
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-15 13:51 UTC by Jan Holesovsky
Modified: 2011-01-22 08:48 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
The patch. (861 bytes, patch)
2010-12-20 23:14 UTC, Jan Holesovsky
Details
Updated patch. (1.03 KB, patch)
2010-12-29 17:36 UTC, Jan Holesovsky
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Holesovsky 2010-12-15 13:51:41 UTC
In my dev build, on Linux:

- make sure Firefox is not running
- open a web page from LibreOffice (eg. Help -> About LibreOffice... -> Contributor Credits)
- Firefox is launched, but LibreOffice freezes until it is closed again

All is fine when Firefox is already running.  This is particularly annoying in combination with the online help :-(
Comment 1 GerardF 2010-12-15 14:27:32 UTC
(In reply to comment #0)

Not confirmed with Firefox 3.6.13 and Libo RC1 on Windows Vista.
May be specific to Linux.
Comment 2 Cédric Bosdonnat 2010-12-16 00:57:20 UTC
I can't reproduce it here with master build on openSuse 11.2... Couldn't it be a problem with your system installation?
Comment 3 Jean-Baptiste Faure 2010-12-18 13:02:16 UTC
I do not reproduce with LibO 3.3 rc1 on Ubuntu 10.04 (x86_64) and Firefox 3.6.13.
Comment 4 Jan Holesovsky 2010-12-20 23:13:39 UTC
Strange, because the code really does block ;-)  Either way, I'll attach a patch.
Comment 5 Jan Holesovsky 2010-12-20 23:14:20 UTC
Created attachment 41338 [details]
The patch.
Comment 6 Jan Holesovsky 2010-12-20 23:32:38 UTC
[Targeting libreoffice-3-3.]
Comment 7 Jan Holesovsky 2010-12-29 17:36:55 UTC
Created attachment 41513 [details]
Updated patch.

As discussed, this encloses the call into ( ) &, to make it safer.
Comment 8 Jan Holesovsky 2011-01-06 14:35:38 UTC
This was committed to libreoffice-3-3 branch.
Comment 9 sophie 2011-01-22 08:48:45 UTC
Was not able to verify - Closed - Sophie