Bug 32575 - Writer/Web crash
Summary: Writer/Web crash
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 RC1
Hardware: Other All
: high major
Assignee: Cédric Bosdonnat
QA Contact:
URL:
Whiteboard:
Keywords:
: 36775 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-12-22 07:57 UTC by clio
Modified: 2012-02-10 01:05 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
backtrace (15.93 KB, text/x-log)
2010-12-22 07:57 UTC, clio
Details

Note You need to log in before you can comment on or make changes to this bug.
Description clio 2010-12-22 07:57:31 UTC
Created attachment 41372 [details]
backtrace

To reproduce:
1. Open an existing HTM file (File/Open menu).
2. Export this file to odt (File/Export... menu).
3. Open this file by going File/Open... menu in the existing window of Writer/Web.

Result: crash

Backtrace attached.
Tested with:
Windows XP 64-bit sp2 ENU +MUI_RU + LibO 3.3.0 rc1/rc2
Win XP SP2 + LibO 3.3.0 rc2
Linux Ubuntu 10.04 + LibO 3.3.0 rc2

OpenOffice.org 3.3.3 rc 8 - OK, no crash.

Backtrace on Linux Ubuntu 10.04 + LibO 3.3.0 rc2 attached.
Comment 1 Yifan Jiang 2010-12-22 19:25:30 UTC
Reproduced on 3.3 rc2/sled 11 sp1.

For the step3, after export odt, File->reload the opened html will cause the same crash.

In addition, it is quite relevant with odt export, since exporting to txt/sdw does not cause the 'reload crash'.
Comment 2 Yifan Jiang 2010-12-22 19:26:17 UTC
For Cedric review, thanks!
Comment 3 ape 2011-01-13 23:14:54 UTC
Windows XP 64-bit sp2 ENU +MUI_RU + LibO 3.3.0 rc1/rc2/rs3.
Export to SXW-format is the same error. In OOo-3.3.0 so there is no error. I think the reason is the following. At the time of export of OOo-3.3.0 automatically saves the file in own native HTML-format.  The file is exported after saving only.
Comment 4 Cédric Bosdonnat 2011-02-11 08:52:25 UTC
Fixed in master branch (for 3.4):
http://cgit.freedesktop.org/libreoffice/writer/commit/?id=bacb3f4f77949cd047eb3a6506074e3574182b34
Comment 5 Caolán McNamara 2012-02-10 01:05:55 UTC
*** Bug 36775 has been marked as a duplicate of this bug. ***