Download it now!
Bug 32685 (zoomtext-crash) - ZoomText crashes while working in LibO
Summary: ZoomText crashes while working in LibO
Status: RESOLVED NOTOURBUG
Alias: zoomtext-crash
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.3.0 RC2
Hardware: x86-64 (AMD64) Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-27 10:02 UTC by Bas Cancrinus
Modified: 2011-12-22 05:53 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bas Cancrinus 2010-12-27 10:02:54 UTC
Setup:
- Windows 7 Home Premium (all updates installed)
- ZoomText 9.1 (64-bit) Magnifier (update 9.19.0.12 (64))
- Oracle JRE 1.6.0_23 with Java Access Bridge 2.0.1
- LibO is configured as described here: http://wiki.services.openoffice.org/wiki/Accessibility#Windows

Use case:
1. Start ZoomText and make sure it's active.
2. Start LibO Writer or Calc (other apps not reproduced yet).
3. Click around in the UI (e.g. open a file, browse options).
4. Within 5 min. LibO exits immediately without notification.
5. ZoomText is not responding and its UI is gone.

Notes:
- The point where LibO exits in (4) seems to be random. I'm unable te reproduce any run.
- When ZoomText is terminated from the Task Manager after (5), the screen freezes. From that point the system can only be shut down with the power button.
- Similar problems were encountered in OOo 3.1.x and 3.2.x.
Comment 1 Jan Holesovsky 2010-12-28 06:20:09 UTC
Tor: Any idea how to debug this, please?
Comment 2 Don't use this account, use tml@iki.fi 2011-01-03 08:08:27 UTC
Well, obviously the first step would be to reproduce it;) What is ZoomText and from where can one download it? (Does it work better than the built-in corresponding tool in Windnows?) Does it cost anything?
Comment 3 Bas Cancrinus 2011-01-03 13:58:56 UTC
@Tor: ZoomText is the leading commercial full screen magnifier which is used by many low vision users around the globe. It is like an advanced version of the Windows 7 magnifier.

Unfortunately the Windows 7 magnifier doesn't track the LibO UI at all, probably because it interfaces with the Java Access Bridge to provide a11y. ZoomText is the only magnifier I know that does support the JAB, so I have to use it. Without UI tracking a magnifier is useless.

You can download a fully functional 60 days trial from http://www.aisquared.com/zoomtext/more/download_zoomtext_trial
Comment 4 Bas Cancrinus 2011-01-23 12:44:53 UTC
ZoomText tracks the LibO UI now without crashing.

Resolution:
I copied the following three Java Access Bridge DLL files from the installation package (accessbridge-2_0_1-manual_install.zip) to my JRE/bin (C:\Program Files (x86)\Java\jre6\bin\):

- JavaAccessBridge.DLL
- JAWTAccessBridge.DLL
- WindowsAccessBridge.DLL

Notes:
- This step is not documented in the JAB manual installation instructions.
- The manual JAB installation method is mandatory for JRE 6, because the setup wizard only works with earlier JRE versions.
Comment 5 Björn Michaelsen 2011-12-22 05:36:45 UTC
Remove infoprovider from closed and resolved bugs.
Comment 6 Björn Michaelsen 2011-12-22 05:53:10 UTC
RESOLVED, FIXED or CLOSED bugs cant be KEYWORD NEEDINFO.