Download it now!
Bug 32736 - mismanagement of the screen after switching to full screen by macro
Summary: mismanagement of the screen after switching to full screen by macro
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-30 01:10 UTC by pierre-yves samyn
Modified: 2015-04-03 09:17 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot : form "cascading" (10.13 KB, image/png)
2010-12-30 01:10 UTC, pierre-yves samyn
Details
Sample odb (16.24 KB, application/vnd.sun.xml.base)
2010-12-30 01:12 UTC, pierre-yves samyn
Details
sample adapted (16.32 KB, application/vnd.sun.xml.base)
2011-02-04 01:50 UTC, spYre
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pierre-yves samyn 2010-12-30 01:10:02 UTC
Created attachment 41524 [details]
Screenshot : form "cascading"

Hello

LibO 330m18 - XP SP3

Unlike previous versions of OOo, displaying a form in full screen mode by macro causes a mismanagement of the screen (after switching to full screen).

- The form appears twice in cascade (see screenshot)
- The Windows taskbar is always displayed (but is not active)
- The screen is not refreshed ...

Note: The macro is associated with the event "on load"

Best regards
Comment 1 pierre-yves samyn 2010-12-30 01:12:38 UTC
Created attachment 41525 [details]
Sample odb

reproduce the bug : Enable Macros and then open the form
Comment 2 Yifan Jiang 2010-12-30 21:11:37 UTC
Reproduced on LibO 3.3 rc2 Windows XP.

It doesn't happen with the same LibO build on SLED 11 sp1.

However using C-S-j to full screen manually doesn't have this problem in either builds.

Hi Noel, I am not sure if this is proper for your review. Please re-assign if it is not a Basic problem. Thank you!

I also added Tor to the cc list to see if there's some thing changes in Windows build since previous build.
Comment 3 spYre 2011-02-04 01:50:17 UTC
Created attachment 42919 [details]
sample adapted

For information :
bug will not be reproduced when menubar is hidden first.

Best regards
Comment 4 Noel Power 2013-02-05 14:47:44 UTC
I see the same problem on windows 4.0 build ( with just the keybinding cntrl-shift-j ) so I don't believe this is macro related
Comment 5 pierre-yves samyn 2013-02-05 15:21:54 UTC
Hello

(In reply to comment #4)
> I see the same problem on windows 4.0 build ( with just the keybinding
> cntrl-shift-j ) so I don't believe this is macro related

You're right, I confirm with Windows XP Pro & Version 
4.0.0.2 .0.2 (Build ID: 5991f37846fc3763493029c4958b57282c2597e)

So "Basic" is not the appropriate component. What do you suggest?

Regards
Pierre-Yves
Comment 6 QA Administrators 2015-04-01 14:42:02 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   *Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
   https://www.libreoffice.org/download/

   *If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
   *If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   *Update the version field
   *Reply via email (please reply directly on the bug tracker)
   *Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-04-01
Comment 7 pierre-yves samyn 2015-04-03 09:17:41 UTC
Hi

Bug is NOT present on Windows 7/64 &
Version: 4.4.2.2
Build ID: c4c7d32d0d49397cad38d62472b0bc8acff48dd6
Locale : fr_FR

I can no longer test on Windows XP but I change status to WORKSFORME

Regards
Pierre-Yves