Download it now!
Bug 32780 - Character dialog box opens when click on "Tools > Language > For the selection > Plus.."
Summary: Character dialog box opens when click on "Tools > Language > For the selectio...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 RC2
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 36091 37919 58385 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-01-02 08:03 UTC by RavuS
Modified: 2014-08-20 12:05 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description RavuS 2011-01-02 08:03:45 UTC
My default language is French, so the LibreOffice instance is installed with the french pack.
When I write an English sentence within a paragraph and I want to define this sentence as "English", I select the text of the sentence, I click on the menu "Outils" (Tools), then "Langue" (Language), then "pour la selection" ("For the selection" I guess...), then "Plus...", The "Character" configuration box opens instead of the language selection box. I tried with "pour le paragraphe" ("For the paragraph" I guess) and the "Character" configuration box still opened. 
It seems to work only with "Pour tout le texte", but I guess it is normal because it opens the "Paramètres linguistiques" ("Language parameters" I guess) configuration box.
Comment 1 sophie 2011-01-03 04:30:05 UTC
The opening of the character setting dialog box is correct as the language used for the selection or the paragraph is a character setting. You set the language by choosing it in the Character setting list box Language.

For what you want to achieve the shorter way is to right click on the language name in the Status bar and then choose the language from the guessing if the spell checker is installed or from the Plus to set the language.

If you need help to use these feature, please join our list users@fr.libreoffice.org. For the moment, I'm closing this bug, at it is working correctly. Sophie
Comment 2 sophie 2011-01-03 04:31:06 UTC
.
Comment 3 RavuS 2011-01-03 07:40:45 UTC
(In reply to comment #1)
> The opening of the character setting dialog box is correct as the language used
> for the selection or the paragraph is a character setting. You set the language
> by choosing it in the Character setting list box Language.
> 
> For what you want to achieve the shorter way is to right click on the language
> name in the Status bar and then choose the language from the guessing if the
> spell checker is installed or from the Plus to set the language.
> 
> If you need help to use these feature, please join our list
> users@fr.libreoffice.org. For the moment, I'm closing this bug, at it is
> working correctly. Sophie


Thank you and sorry for disturbing with fake bug :-) I will better care off the consistency of future statements of bug I send.

Auban
Comment 4 Johannes Buchner 2014-08-20 11:09:52 UTC
Comment 1 explains that the language can be changed in the "Font" tab. Then, the bug is that this tab is not activated by default, and this behaviour should be changed.

The expectation of the user is to see something language-related, which is not fulfilled at the moment.

Numerous bug reports have been filed:
Bug 37919
Bug 58385
Bug 36091
Comment 5 Johannes Buchner 2014-08-20 11:10:46 UTC
*** Bug 36091 has been marked as a duplicate of this bug. ***
Comment 6 Johannes Buchner 2014-08-20 11:11:13 UTC
*** Bug 37919 has been marked as a duplicate of this bug. ***
Comment 7 Johannes Buchner 2014-08-20 11:11:34 UTC
*** Bug 58385 has been marked as a duplicate of this bug. ***
Comment 8 sophie 2014-08-20 12:05:27 UTC
Hi Johannes, please do not reopen a bug that is closed because this is the expected behavior. I understand your wish for a change, but in this case, you should open a new bug and set it as an enhancement explaining what you want exactly to change. For the moment, language is a font attribute so it's how it should work. Thanks! Sophie