Bug 32796 - Can not launch "Form Controls","Form Design","From Navigation"
Summary: Can not launch "Form Controls","Form Design","From Navigation"
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
(earliest affected)
3.3.0 RC2
Hardware: x86 (IA32) Linux (All)
: high critical
Assignee: Not Assigned
Depends on:
Reported: 2011-01-03 07:02 UTC by tom
Modified: 2011-01-12 08:37 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Note You need to log in before you can comment on or make changes to this bug.
Description tom 2011-01-03 07:02:51 UTC
I use archlinux.I installed LibreOffice 3.3.0. The installation was successful.
I created a my_form in my_database by Form Wizard. I switched to design mode of this my_form.
I didn't find Form Navigator,Form Controls,Form Design.
I tried to choose in menu : view>toolbars>FormControls
Result: no toolbars and no errors
The same result: selection Control in menu of right-click on a component of the my_form.
Not working "Form Controls","Form Design","From Navigation" 

LibreOffice 3.3.0 
OOO330m18 (Build:4) ArchLinux build-3

Can you help?
Comment 1 ammine007 2011-01-05 03:49:35 UTC

The same issue here on a Ubuntu-10-10 Linux machine :

LibreOffice 3.3.0 
OOO330m18 (Build:4)
tag libreoffice-, Ubuntu package 1:3.3.0~rc2-3maverick1

I installed LibreOffice via The ppa.

Good luck !
Comment 2 Stefano Fraccaro 2011-01-05 06:16:23 UTC
I installed LibreOffice via The ppa and notice also this behaviour:

Create form in Design view
Views ->  ToolBars ->  Form Navigation (toolbar appear correctly)
Views ->  ToolBars ->  Form Navigation (toolbar close correctly)
Views ->  ToolBars ->  Form Navigation (toolbar appear correctly)
Views ->  ToolBars ->  Form Navigation (toolbar close correctly)
Views ->  ToolBars ->  Design (do nothing)
Views ->  ToolBars ->  Form Navigation (gives an empty toolbar only after Design)
Comment 3 Don't use this account, use tml@iki.fi 2011-01-05 06:19:52 UTC
Sorry, what is "The ppa"? Does the same happen with the binaries the LO developers provide?
Comment 4 Stefano Fraccaro 2011-01-05 06:34:34 UTC
# add-apt-repository ppa:libreoffice/ppa

Article from:
Comment 5 Stefano Fraccaro 2011-01-05 06:39:44 UTC
This ppa is a Document Foundation official PPA or not?
Comment 6 Don't use this account, use tml@iki.fi 2011-01-05 06:49:59 UTC
As far as I know, it's not.
Comment 7 Stefano Fraccaro 2011-01-05 06:56:38 UTC
thx Tor... unofficial debian packages from download.documentfoundation.com works correctly. It's a bug ONLY in ppa packages.
Comment 8 Alex Thurgood 2011-01-05 08:38:04 UTC

Comment 9 Drew Jensen 2011-01-05 09:40:24 UTC
I had this exact problem with OpenSuse builds created with the SUSEStudio - I posted about that a couple weeks back on the dev mailing list. Today there are people reporting this on the users list from the Ubuntu ppa.

Yesterday when I went into SUSEStudio I noticed that 3 different build configuration using the LibreOffice repository where all marked as broken because some change in dependency in the LibO files. I've updated the files and the dependency error is cleared, so I will be building new files today. I;ll post back if the problem still persists.
Comment 10 Drew Jensen 2011-01-05 15:59:26 UTC
Ok well I suppose it is not just that one ppa - a build of OpenSUSE 11.3 w/ GNOME and LibreOffice 3.3 RC2 does have this problem, which doesn't necessarily make it a LibO issue either I guess.

Sitll, if you like the liveDVD image is available here. 


This does not happen when adding form controls to stand alone documents, it is only when using the ODB container for the form document. (It is also not a HSQL issue as same problem occurs for me using dBase in the earlier build)