Bug 32948 - Address Book Data Source Wizard fails with message "No SDBC driver was found"
Summary: Address Book Data Source Wizard fails with message "No SDBC driver was found"
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.4.0 Beta3
Hardware: x86-64 (AMD64) Linux (All)
: high major
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard: summary:comment58 bibisected35 bibise...
Keywords: regression
: 37633 45157 (view as bug list)
Depends on: 54450
Blocks: mab3.5
  Show dependency treegraph
 
Reported: 2011-01-09 18:14 UTC by David Burleigh
Modified: 2012-10-06 01:12 UTC (History)
11 users (show)

See Also:


Attachments
Screenshot which show address book in Writer (109.64 KB, image/png)
2011-09-14 15:00 UTC, Julien Nabet
Details
Address Data Source choices (38.37 KB, image/png)
2011-10-22 14:24 UTC, Borut Jereb
Details
LO3.5 screenshot (128.30 KB, image/png)
2011-12-14 13:52 UTC, NoOp
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Burleigh 2011-01-09 18:14:35 UTC
No data sources are listed for "Address Book Type" in step 1 of the wizard.

I was hoping that the Thunderbird address book would be among the choices, but there are NO choices, and when you click on the Next button, you get an error message: "The connection to the external data source could not be established. No SDBC driver was found for the given URL."
Comment 1 Drew Jensen 2011-01-09 21:45:51 UTC
@David - Using Ubuntu 11.04 / LibO RC2 binary from the main web site AMD64 
and OpenSUSE 11.3 / LibO RC2 from the suse build repos 32Bit - I see data sources at every spot I can think of where they should be. 

Which distro would you be using?
Comment 2 David Burleigh 2011-01-10 03:49:38 UTC
I am using Ubuntu 10.10. When I choose File/Wizards/Address Data Source, the wizard appears with four steps, the first being Address Book Type. No types are listed, but with the old OpenOffice, several options were listed, including the Thunderbird address book.
Comment 3 Rene Engelhard 2011-01-10 10:12:13 UTC
in case he is using the distro packages - no surprise. It is NO OPTION to use s obsolete, patched seamonkey for providing the Mozilla Adress Book stuff. It can't be built using system-mozilla and internal mozilla, well, see above. Thus it's enabled (let alone for security reasons) disabled in most distros. Besides that it will increase build time in a considerable manner, especially on slow architectures (like ARM, MIPS)

Someone, though, should fix the LDAP "adress book" thing to not require Mozillas
libldap50.so but OpenLDAP (as it's already done for the LDAP configuration backend)
Comment 4 David Burleigh 2011-01-10 10:37:55 UTC
I am using Thunderbird 3.1.7 (amd64 build).
Comment 5 Rene Engelhard 2011-01-10 11:10:55 UTC
> I am using Thunderbird 3.1.7 (amd64 build).

and? doesn't matter. mozab is for access to Mozillas (Thunderbird, Seamonkey)-Adressbook. That doesn't have *anything* to do with what you use but
what your LibO is built with.
Comment 6 David Burleigh 2011-01-10 11:19:12 UTC
Well, that doesn't tell me much, because I don't know anything about LibO. I only filed the bug report because the behavior of the wizard is not as it was with previous OpenOffice versions. If it is not really a bug, that's fine. I'd just like to be able to accomplish the same effect with LibreOffice, i.e., do a mail-merge using my Thunderbird address book as a data source.
Comment 7 David Burleigh 2011-01-18 16:28:11 UTC
After I completely removed LibreOffice RC2 and then installed RC3 from the amd64 debs, the Thunderbird address book appeared among the address data source options...
Comment 8 Cor Nouws 2011-02-08 07:23:11 UTC
reading the latest comment (thanks for reporting) and looking at my own system, I close this bug.
Comment 9 NoOp 2011-05-04 16:58:55 UTC
Reopening. There appears to be a regression as with:
http://dev-builds.libreoffice.org/daily/Linux_x86_Release_Configuration/libreoffice-3-4/2011-05-02_18:50:09/
$ md5sum
libreoffice-3-4~2011-05-02_18:50:09_LibO_3.4.0beta3_Linux_x86_install-deb_en-US.tar.gz
71b7f12401c0a992d88625507deb6c16 
$ cat /opt/libreoffice/basis3.4/program/versionrc
[Version]
buildid=300m103(Build:3)
OOOBaseVersion=3.4
OOOPackageVersion=3.4.0
ProductBuildid=3
ProductMajor=300
ProductMinor=103
ProductSource=DEV300
Unbuntu 10.10

File|Wizards|Address Data Source 
fails to open.
Comment 10 NoOp 2011-05-04 17:04:20 UTC
Added note: the wizard does work on the 64bit build, so this appears broken in the 32bit build(s).
Comment 11 NoOp 2011-05-04 17:07:52 UTC
Sorry, correction: 

Added note: the wizard does _open_ on the 64bit build, so this appears broken in the 32bit build(s). On the 64bit build selecting any of the options gives "The connection to the datasource could not be established. No SDBC driver was found for the given URL." But I suppose that should be filed as a separate bug.
Comment 12 NoOp 2011-05-19 15:59:33 UTC
And still broken:
$ cat versionrc
[Version]
AllLanguages=en-US
BuildVersion=
buildid=300m103(Build:5)
ExtensionUpdateURL=http://updateexte.libreoffice.org/ExtensionUpdateService/check.Update
OOOBaseVersion=3.4
ProductBuildid=5
ProductMajor=300
ProductMinor=103
ProductSource=DEV300
UpdateID=LibreOffice_3_en-US
UpdateURL=
UpdateUserAgent=<PRODUCT> (${buildid}; ${_OS}; ${_ARCH}; BundledLanguages=${AllLanguages})
Vendor=The Document Foundation

(32bit & 64bit - Ubuntu 10.10)

However, attempting to connect to any of the database sources results in:

SQL Status: HY000

The connection to the external data source could not be established. No SDBC driver was found for the given URL.

and 

A connection for the following URL was requested "sdbc:address:evolution:local".
Comment 13 NoOp 2011-05-19 16:02:56 UTC
@Rene (Comment #3):
http://openoffice.org/bugzilla/show_bug.cgi?id=107809
[Bug 107809 - cannot find SeaMonkey 2.0 addressbook data source]
Status: 	VERIFIED FIXED
Comment 14 Alex Thurgood 2011-05-26 08:18:10 UTC
Apparently not fixed as confirmed by bug 37633 with 3.4rc1.

Alex
Comment 15 Alex Thurgood 2011-05-26 08:18:26 UTC
*** Bug 37633 has been marked as a duplicate of this bug. ***
Comment 16 NoOp 2011-05-26 14:29:59 UTC
Still doesn't work in LO 3.4RC2 either:
$ cat /opt/libreoffice3.4/program/versionrc
[Version]
AllLanguages=en-US
BuildVersion=
buildid=340m1(Build:12)
ExtensionUpdateURL=http://updateexte.libreoffice.org/ExtensionUpdateService/check.Update
OOOBaseVersion=3.4
ProductBuildid=12
ProductMajor=340
ProductMinor=1
ProductSource=OOO340
UpdateID=LibreOffice_3_en-US
UpdateURL=
UpdateUserAgent=<PRODUCT> (${buildid}; ${_OS}; ${_ARCH};
BundledLanguages=${AllLanguages})
Vendor=The Document Foundation

But this has been fixed in OOo 3.4.0:
http://openoffice.org/bugzilla/show_bug.cgi?id=107809
$ cat /opt/ooo-dev/basis3.4/program/versionrc
[Version]
buildid=340m0(Build:9583)
OOOBaseVersion=3.4
OOOPackageVersion=3.4.0
ProductBuildid=9583
ProductMajor=340
ProductMinor=0
ProductSource=OOO340
Comment 17 NoOp 2011-05-26 20:11:23 UTC
Added note: File|Wizards|Address Data Source| *does* work in LO 3.4.0RC2 Windows. Tested on WinXP
LibreOffice 3.4.0 
OOO340m1 (Build:12)
Working. 

Failure to connect to data sources (linux) is IMO a blocker. Mailmerge, Base, Envelopes, and Labels rely on the ability to connect to a data source. OOo 3.4 have resolved this issue so the basic build code must be available to resolve in LO as well.
Comment 18 Don't use this account, use tml@iki.fi 2011-05-27 00:30:50 UTC
Can you help in finding the fix from the OOo 3.4.0 code then?
Comment 19 Alex Thurgood 2011-05-27 01:08:39 UTC
(In reply to comment #18)
> Can you help in finding the fix from the OOo 3.4.0 code then?


@Tor

It is probably in m106 - a lot of fixes that were dba related went in there. The question is, have we merged from that yet, and if so, were the fixes for the dba part accepted into master ?


Alex
Comment 20 Petr Mladek 2011-05-27 05:34:53 UTC
It affects functionality used by rather enterprise users. It can't block the 3.4.0 release => lovering the severity a bit.

Though, it is something that we should fix for 3.4.1 or 3.4.2 => I am going to list it in most annoying bugs.
Comment 21 NoOp 2011-05-27 07:50:19 UTC
@Tor:
<http://eis.services.openoffice.org/EIS2/cws.ShowCWS?Id=9696&OpenOnly=false&TasksInline=false&Section=Files>
Taskid: i107809
connectivity 	source/drivers/mozab/bootstrap/MNSFolders.cxx 	2de7a494abdf 	Frank Schoenheit [fs] 	i107809
connectivity 	source/drivers/mozab/bootstrap/MNSFolders.hxx 	2de7a494abdf 	Frank Schoenheit [fs] 	i107809
connectivity 	source/drivers/mozab/bootstrap/MNSProfileDiscover.cxx 	2de7a494abdf 	Frank Schoenheit [fs] 	i107809
connectivity 	source/drivers/mozab/bootstrap/MNSProfileDiscover.hxx 	2de7a494abdf 	Frank Schoenheit [fs] 	i107809
connectivity 	source/drivers/mozab/mozab.xcu 	2de7a494abdf 	Frank Schoenheit [fs] 	i107809
connectivity 	source/drivers/mozab/mozab2.xcu 	2de7a494abdf 	Frank Schoenheit [fs] 	i107809
would be my guess according to:
http://openoffice.org/bugzilla/show_bug.cgi?id=107809
http://development.openoffice.org/releases/3.4beta.html
Comment 22 Alex Thurgood 2011-05-27 08:08:23 UTC
And yet strangely enough, that code wasn't integrated into the LibO git tree despite it being from the OOom93 milestone integrated into the OOo master on 07/10/2010 ??


Alex
Comment 23 NoOp 2011-05-27 08:31:58 UTC
@Alex: no clue. I'm a user only.
Comment 24 Don't use this account, use tml@iki.fi 2011-05-27 08:52:17 UTC
That CWS *is* in our tree, in 3.4. See for instance http://cgit.freedesktop.org/libreoffice/libs-core/commit/?id=a70df88b2c909228eef492da32672149b808eb48 .

There is something else going on.
Comment 25 Rainer Bielefeld Retired 2011-06-10 02:57:30 UTC
RC2 is bit by bit identical with release version, so separate items in the version picker are useless. Changes have been discussed with Michael Meeks.
Comment 26 NoOp 2011-07-02 13:14:04 UTC
Not working:
$ cat /opt/libreoffice3.4/basis3.4/program/versionrc
[Version]
buildid=340m1(Build:103)
OOOBaseVersion=3.4
OOOPackageVersion=3.4.1
ProductBuildid=103
ProductMajor=340
ProductMinor=1
ProductSource=OOO340
Comment 27 NoOp 2011-07-02 15:05:44 UTC
Working in:
$ cat /opt/libreoffice/program/versionrc
[Version]
AllLanguages=en-US
buildid=330m19(Build:301)
ExtensionUpdateURL=http://updateexte.libreoffice.org/ExtensionUpdateService/check.Update
OOOBaseVersion=3.3
ProductBuildid=301
ProductMajor=330
ProductMinor=19
ProductSource=OOO330
UpdateID=LibreOffice_3_en-US
UpdateURL=
UpdateUserAgent=<PRODUCT> (${buildid}; ${_OS}; ${_ARCH}; BundledLanguages=${AllLanguages})

with the exception of the Mozilla/Netscape connector (OOo-dev 3.4 works with SeaMonkey).
Comment 28 NoOp 2011-07-26 15:50:54 UTC
Not working in:
[Version]
AllLanguages=en-US
BuildVersion=
buildid=340m1(Build:202)
ExtensionUpdateURL=http://updateexte.libreoffice.org/ExtensionUpdateService/check.Update
OOOBaseVersion=3.4
ProductBuildid=202
ProductMajor=340
ProductMinor=1
ProductSource=OOO340
UpdateID=LibreOffice_3_en-US
UpdateURL=
UpdateUserAgent=<PRODUCT> (${buildid}; ${_OS}; ${_ARCH}; BundledLanguages=${AllLanguages})
Vendor=The Document Foundation

(Linux 32bit)
Comment 29 Cor Nouws 2011-08-05 10:55:31 UTC
.
Comment 30 Julien Nabet 2011-09-14 14:59:07 UTC
On LO master repo (so future 3.5), it seems to work.
No warning or debug message (I use debug mode) when I open wizard.
I attached a screenshot.

Hope I haven't completely misunderstood the bug.
Comment 31 Julien Nabet 2011-09-14 15:00:39 UTC
Created attachment 51219 [details]
Screenshot which show address book in Writer
Comment 32 Julien Nabet 2011-09-14 15:02:56 UTC
(In reply to comment #30)
> On LO master repo (so future 3.5), it seems to work.
> No warning or debug message (I use debug mode) when I open wizard.
> I attached a screenshot.
> 
> Hope I haven't completely misunderstood the bug.
I just forgot to say :
- I'm on debian x86 and I compiled with gcc (Debian 4.6.1-4) 4.6.1
- I just updated and compiled my repository (which points on master) today
Comment 33 Julien Nabet 2011-09-15 23:28:13 UTC
Just to say it works on Windows 7, 3.4.3, OOO340m1 (Build:302).
Either I understood nothing at all concerning this bug or we can consider it now as resolved.
Comment 34 promeneur 2011-10-07 01:56:28 UTC
Mandriva 2010.2 32 bit
libreoffice 3.4.2 OOO340m1 build 302

i confirm the bug

in lo base
i created a db file for my kab (kde addressbook)
the kab.odb seems filled (1,6 ko)

in lo writer
in file > model > address book source
in "data source" field it appears in the list
i can select it
but
when i select it have the error message about no sdbc driver

i can't access to the address book
Comment 35 Alex Thurgood 2011-10-07 02:43:45 UTC
(In reply to comment #34)
> Mandriva 2010.2 32 bit
> libreoffice 3.4.2 OOO340m1 build 302
> 
> i confirm the bug
> 

Well thank you, but it has been reported as fixed on master, and so therefore may or may not be backported for 3.4.4 (not my decision).

I will try this again on one of my own recent Linux 32bit master builds and see if I confirm Julien's findings.


Alex
Comment 36 Alex Thurgood 2011-10-07 06:02:07 UTC
(In reply to comment #35)

> 
> Well thank you, but it has been reported as fixed on master, and so therefore
> may or may not be backported for 3.4.4 (not my decision).
> 
> I will try this again on one of my own recent Linux 32bit master builds and see
> if I confirm Julien's findings.
> 
> 


Replying to myself :
On my own week-old 32bit linux Ubuntu build from master, I can see various choices for existing database connections, among which Thunderbird and Seamonkey address books. The ODB file can be created just fine, however, the wizard does not pick up the user's TB/SM profile, and thus can not actually make the connection to the mozab underlying database file.

Even if I save the ODB file, re-open and then try and reset the properties of the ODB connection to point to the mab file, this still fails to work. So as far as I'm concerned, my tests were inconclusive. I can't tell whether it is a problem in the connectivity code or somewhere else, because there is not much point in listing the available types of database if LibO can not actually connect to them.


Alex
Comment 37 Borut Jereb 2011-10-22 14:24:50 UTC
Created attachment 52636 [details]
Address Data Source choices
Comment 38 Borut Jereb 2011-10-22 14:25:57 UTC
Ubuntu 11.10
libreoffice 3.4.3

When I want to use 
File --> Wizards --> Address Data Source
I have no possibilities to choose an usual database except the choice to open External Data Source. After choosing the only possibilities (External Data Source) I get the error: 

The error report is:

SQL Status: HY000

The connection to the external data source could not be established. No SDBC driver was found for the given URL.

On the other hand I have some databases in my libreoffice repository.
Comment 39 Alex Thurgood 2011-10-23 00:14:15 UTC
(In reply to comment #38)

Hi,


> Ubuntu 11.10
> libreoffice 3.4.3
> 
> When I want to use 
> File --> Wizards --> Address Data Source
> I have no possibilities to choose an usual database except the choice to open
> External Data Source. After choosing the only possibilities (External Data
> Source) I get the error: 
> 
> The error report is:
> 
> SQL Status: HY000
> 
> The connection to the external data source could not be established. No SDBC
> driver was found for the given URL.
> 
> On the other hand I have some databases in my libreoffice repository.

I can confirm this too on 32bit Ubuntu Oneiric 11.10 with distrib supplied LO 3.4.3, so the fix is still not in for that version.

Alex
Comment 40 Cor Nouws 2011-11-18 14:29:04 UTC
No problem in 3.4.3 and 3.4.4 and a masterbuild for 3.5

So probably a bug for the "32bit Ubuntu Oneiric 11.10 with distrib supplied LO
3.4.3" ??
Comment 41 Alex Thurgood 2011-11-20 01:55:16 UTC
Confirming bug also in distrib supplied :

LibreOffice 3.4.4 
OOO340m1 (Build:402)

Ubuntu 11.10 32bit


So would this be one for Bjoern ?


Alex
Comment 42 David Sterratt 2011-12-14 02:00:11 UTC
(In reply to comment #40)
> No problem in 3.4.3 and 3.4.4 and a masterbuild for 3.5

This is still definitely a problem for me on Ubuntu 11.10 i686 with the latest official libreoffice binaries. Steps to reproduce:

1. Purge ubuntu libreoffice packages with dpkg --purge --force-all "libreoffice*"
2. Install 3.5.0beta0 binaries from libreoffice.org.
3. rm -Rf ~/.libreoffice
4. Open /opt/libreoffice3.5/program/soffice 
5. Open "File->Wizards->Address Data Sources..."
6. There are four sources presented (Mozilla/Netscape, Thunderbird, LDAP and Other external data source)
7. Select any of these. A dialogue appears saying "The connection to the external data source could not be established. No SBDC driver was found for the given URL"
8. Click on "More" in this box. The error shown is "SQL Status: HY000. The connection to the external data source could not be established. No SDBC driver was found for the given URL." 
9. Click on "Information". The description is "A connection for the following URL was requested "sdbc:address:evolution:local".

From the comments above it looks as though I'm going to have to use OpenOffice to use my evolution  address book to print out year's Christmas card labels...
Comment 43 David Sterratt 2011-12-14 03:03:51 UTC
I've tried OpenOffice.org and it doesn't work either. When running from the command line I got an error "Can find no compliant libebook client libraries". Googling this lead me to the following file (in OOo): 

https://svn.apache.org/repos/asf/incubator/ooo/trunk/main/connectivity/source/drivers/evoab2/EApi.cxx

and its equivalent in LibreOffice:

http://cgit.freedesktop.org/libreoffice/core/tree/connectivity/source/drivers/evoab2/EApi.cxx

The error occurs in EApiInit(). The reason for this is that it can't find a version of libebook on my system that matches one of the following, defined at the top of the file:

static const char *eBookLibNames[] = {
    "libebook-1.2.so.10", // bumped again
    "libebook-1.2.so.9",  // evolution-2.8
    "libebook-1.2.so.5",  // evolution-2.4 and 2.6+
    "libebook-1.2.so.3",  // evolution-2.2
    "libebook.so.8"       // evolution-2.0
};

I have libebook-1.2.so.12 installed in my system, which doesn't match any of the above. I suppose we could just try adding libebook-1.2.so.12 to the list to see what happens.

When (if) I've a moment, I'll try recompiling libreoffice, but I don't know how long it will take on my laptop...
Comment 44 NoOp 2011-12-14 12:53:57 UTC
I have:
$ locate libebook
/usr/lib/libebook-1.2.so.9
/usr/lib/libebook-1.2.so.9.3.1

$ ls -al /usr/lib/libebook-1.2.so.9
lrwxrwxrwx 1 root root 21 2011-01-20 19:49 /usr/lib/libebook-1.2.so.9 -> libebook-1.2.so.9.3.1

and have the issue in 3.4.3. Address selections are available, but clicking on any of them results in:
SQL Status: HY000

The connection to the external data source could not be established. No SDBC driver was found for the given URL.

A connection for the following URL was requested "sdbc:address:evolution:local
Comment 45 NoOp 2011-12-14 13:08:55 UTC
Correction:

and have the issue in 3.4.3.

should read:

and have the issue in 3.4.4
Comment 46 NoOp 2011-12-14 13:52:35 UTC
Created attachment 54439 [details]
LO3.5 screenshot

Same issue with:
LibreOffice 3.5.0 
Build ID: ef91e38-b1d4df6-090bcba-45cf606-05891e7

Screenshot attached.
Comment 47 David Sterratt 2011-12-15 02:34:09 UTC
@NoOp: that's what I saw on 3.5.0beta0 too. Interesting that it's not just a problem with the library version being wrong.

I've compiled libreoffice with  
"libebook-1.2.so.12"
added to eBookLibNames. Now I only get the option of the "External data sources" and when I click on that I get the same error as you, with the Information that "A connection for the following URL was requested "sdbc:address:evolution:local"."

I think the problem may the recent changes in the libebook library. See the list of deprecated symbols at:
http://developer.gnome.org/libebook/3.2/

The file 
http://cgit.freedesktop.org/libreoffice/core/tree/connectivity/source/drivers/evoab2/EApi.h
seems to use a lot of these deprecated symbols.

I've love to have the time-expertise to hack around, but I don't. I'm going to have to move to good old-fashioned handwriting for my Christmas card envelopes.
Comment 48 David Sterratt 2011-12-15 02:35:36 UTC
The OpenOffice version of this bug:
https://issues.apache.org/ooo/show_bug.cgi?id=116901
Comment 49 David Sterratt 2011-12-15 03:21:19 UTC
The OpenOffice version of this bug:
https://issues.apache.org/ooo/show_bug.cgi?id=116901
Comment 50 Alex Thurgood 2011-12-15 04:37:18 UTC
Confirming on my 3.5 build from master Linux Ubuntu 32bit, that only 1 entry is present when the wizard is started "Other external data source".

If I click Next after having chosen this possibility, I get an error messsage of the type : "The connection could not be established. No SDBC driver could be found."

So confirming other peoples findings too.

Build ID: 
87ca88c-d46295c-6e20485-4c1bcb5-libreoffice-3-5-branch point

This really needs sorting out.

Alex
Comment 51 NoOp 2011-12-15 12:49:00 UTC
@David re comment #47: 

"I've love to have the time-expertise to hack around, but I don't. I'm going to
have to move to good old-fashioned handwriting for my Christmas card envelopes."

Try this workaround: In Writer select the data sources (F4). Right-click in the data source (where Bibliography is) and select 'Registered databases'. Click 'New' and browse to where your existing .odb is located. Select the .odb & click OK. Verfify that it works by selecting the database and viewing Tables. If so, from there you should be able to File|New|Label|Labels|Database and select the database that you just added. Note: I can't get File|New|Label to work from Writer, I have to go back to the main menu and select it from there. But I reckon that's another bug report...
Comment 52 Jean-Baptiste Faure 2012-01-23 22:00:54 UTC
*** Bug 45157 has been marked as a duplicate of this bug. ***
Comment 53 Alex Thurgood 2012-01-27 06:45:47 UTC
In my latest build from master, on Ubuntu Oneiric, I have several entries, including Evolution, Evolution (LDAP), other DB, but NO Thunderbird (which is most annoying, but not really surprising since I disabled building mozab within my build because it doesn't build within the LO code on Ubuntu (sigh).

However, the basic functionality of the Address Database Source Wizard does work. For example, I could set up and define a mysql database as an Address Datasource, just as I could with the Evolution address book.

So, FWIW, this works for me (apart from TB Address book integration) on Linux 32bit Ubuntu Oneiric with my build from master.


Alex
Comment 54 Rainer Bielefeld Retired 2012-04-02 08:31:48 UTC
Reduced severity.

As it seems NoOp reproduced with LibO vanilla build 3.4.0beta3, so together with other confirming comments I believe we can this one take as NEW, also due to other builds.

3.4 lifecycle is terminated, so shift to “Bug 37361 LibreOffice 3.5 most annoying bugs”

@All:
Is my addition to summary line correct?

@Alex:
Can you please keep at it and check whether the "fix" is enduring?

@Lionel:
Any ideas? This one seems to be really tricky, I see several conflicting observations.
Comment 55 Lionel Elie Mamane 2012-06-06 06:48:07 UTC
Summary:

 - May be related to 32 bits / 64 bits; works on 64 bits, fails on 32 bits.
 - May be related to version of libebook installed and deprecated / removed symbols; see comment 47.

Any future testers, please *always* say whether you use 32 bits or 64 bits, and what libebook-*.so* you have on your system. Thanks for that.
Comment 56 robert 2012-06-09 02:29:15 UTC
Tried to connect KDE-Adressbook.
OpenSuSE 11.4, 32bit, LO 3.3.4 and LO 3.5.4.2 → connection works, no content is shown (may be another problem).
OpenSuSE 12.1, 64bit, LO 3.5.4.2 → no SDBC-Driver for URL. When I search for more Information the URL "sdbc:address:kab" was not found. I think it could not be found, because the right URL has to be "sdbc:kab". Thats the URL I see, when I open Extras → Options →LibreOffice Base → Connections.

Robert
Comment 57 Lionel Elie Mamane 2012-09-02 05:00:14 UTC
(In reply to comment #56)

> When I search for more Information the URL "sdbc:address:kab" was not found.
> I think it could not be found, because the right URL has to be "sdbc:kab". 
> Thats the URL I see, when I open
> Extras → Options →LibreOffice Base → Connections.

I think "sdbc:address:kab" is the right one.

I don't see either in my (the default) "Extras → Options →LibreOffice Base → Connections".
Comment 58 Lionel Elie Mamane 2012-09-02 07:34:36 UTC
(In reply to comment #56)
> Tried to connect KDE-Adressbook.
> OpenSuSE 11.4, 32bit, LO 3.3.4 and LO 3.5.4.2 → connection works

OK, as we have reports that:

 - it works on 32 bits
 - does not work on 32 bits

I'm going to assume this is *not* related to 32/64 bits.


More fundamentally, I have the impression we are mixing several different bugs here:

1) Do the right options appear in the "Address Book Data Source" wizard?

2) Do these options work as expected?


Each missing, and each not-working option could be a *different* bug. One of these multiple bugs could be linked to 32/64 bits.

Especially, the libebook discussion should be relevant *only* to "does Evolution appear in the list / work", and not to any other entry.


Wrt to 1):

1.1) evolution missing: duh... Not enabled in our builds :-|

In my testing (my libreoffice-3-6 development tree and LibreOffice 3.6.1.1 official amd64 .debs on Debian amd64 with package libebook-1.2-12 version 3.2.2-3, file /usr/lib/libebook-1.2.so.12), I have:

Mozilla / Netscape
Thunderbird/Icedove
LDAP
Other

The first two don't work, saying that no address book directory is available. As this is very well possible (I don't use any of these programs), this does not necessarily indicate a bug.

LDAP: seems to work, don't have an actual LDAP server to completely test.

Other: seems to work, did not go all the way to a connection


I don't have KDE address book listed: duh, I don't have KDE installed.

I don't have evolution address book listed: I don't use Evolution, so maybe not a bug. Maybe still a bug.


So I'm sending this back to QA:

1) Please open a new bug for each separate issue, and include me in CC

2) Make it a blocker of this bug

3) include exact reproduction instructions on what is needed
   on a fresh system to create said Address Book
   before LibreOffice is supposed to be able to use it:

   a) install what program
      (please not "all of KDE" or something like that)
   b) do what in that program to create a new address book and
      a few entries in it, ...

   Also include exact settings (if any) needed in LibreOffice
   (e.g. LDAP connection string, BaseDN, ...)

   If needs connection to a server, try to find
   a publicly available server.
   E.g. for LDAP, the Debian LDAP directory may do (I don't know).


If the issue is "all entries missing" (or "all except Other"), that's probably a single issue. Don't open a bug per missing entry. But if *some* are missing, probably multiple issues (exception: Evolution, Groupwise and Evolution LDAP are served by the same driver, so if all three are missing,l it is a single issue).

Same for "some/all not working".
Comment 59 Alex Thurgood 2012-09-03 19:39:48 UTC
(In reply to comment #58)




> In my testing (my libreoffice-3-6 development tree and LibreOffice 3.6.1.1
> official amd64 .debs on Debian amd64 with package libebook-1.2-12 version
> 3.2.2-3, file /usr/lib/libebook-1.2.so.12), I have:
> 
> Mozilla / Netscape
> Thunderbird/Icedove
> LDAP
> Other



> The first two don't work, saying that no address book directory is available.
> As this is very well possible (I don't use any of these programs), this does
> not necessarily indicate a bug.
> 

For me, I can set up and connect to a TB addressbook via the method you describe, ie. via the wizard, on master build from 30/08 64bit, so Thunderbird as an address datasource WFM.

Alex
Comment 60 Michael Meeks 2012-10-05 10:29:47 UTC
Any more joy in finding / splitting out the component parts of this multi-issue bug ? if not perhaps closing it would provoke filing separate bugs for any remaining issues ?
Comment 61 NoOp 2012-10-05 20:31:17 UTC
Ubuntu 12.04 (no distro versions of LO - all are direct LO .deb's)

LibreOffice 3.5.7.1
Build ID: 3fa2330-e49ffd2-90d118b-705e248-051e21c
Works for me, for the most part[1]
o Mozilla/Netscape
o Thunderbird/Icedove
o LDAP address data
o Other external data source
 - JDBC
 - Oracle JDBC
 - KDE Address Book
 - LDAP Address Book
 - SeaMonkey Address Book
 - Thunderbird/Icedove Address Book
 - Spreadsheet
 - dBASE
 - Text
 - MySQL (JDBC)
 - My SQL (Native)
 - My SQL (ODBC)
 - ODBC
 - PostgreSQL

Version 3.6.2.2 (Build ID: da8c1e6)
Works for me, for the most part[1]
o Evolution
o Groupwise
o Evolution LDAP
o Mozilla/Netscape
o Thunderbird/Icedove
o LDAP address data
o Other external data source
 - dBASE
 - JDBC
 - Groupwise
 - Evolution LDAP
 - KDE Address Book
 - LDAP Address Book
 - SeaMonkey Address Book
 - Thunderbird/Icedove Address Book
 - Spreadsheet
 - dBASE (again - don't know why it's listed twice)
 - Text
 - MySQL (JDBC)
 - My SQL (Native)
 - My SQL (ODBC)
 - ODBC
 - PostgreSQL
@Lionel: Evolution does indeed work just fine for me.

I no longer get "No SDBC driver was found".

[1] There is an issue with the Mozilla/Netscape/SeaMonkey/Thunderbird connections. I have both SeaMonkey (my primary) and Thunderbird. Both are direct Mozilla installs (non-distro) & the profiles reside in normal:
~/.mozilla/seamonkey
~/.thunderbird
However, LO defaults to the SeaMonkey address book when Thunderbird/Icedove is selected. But of course that is for bug report other than this one.

Regarding mixes of LO distro issues: It would simplify things greatly if those issues remain in the distro's reporting system (e.g., launchpad etc). The Ubuntu launchpad issue is:
<https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/93546>
[Address data sources missing] Note this bug report was originally reported by me a few years ago on Ubuntu's OOo. Unfortunatly, that bug report has been intermixed with this one so much that I gave up on it some time ago.
Comment 62 Lionel Elie Mamane 2012-10-06 01:12:28 UTC
(In reply to comment #60)
> Any more joy in finding / splitting out the component parts of this
> multi-issue bug ?

You are right, there was enough time for that to happen, now closing.