Download it now!
Bug 33068 - LibreOffice hangs for ~15 seconds after startup of a component
Summary: LibreOffice hangs for ~15 seconds after startup of a component
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: x86-64 (AMD64) Linux (All)
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-13 09:03 UTC by Vincent Beers
Modified: 2012-03-17 04:48 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vincent Beers 2011-01-13 09:03:06 UTC
After having started up LibreOffice and opening one of its components (like Writer), LibreOffice will hang for a while before it becomes usable.

This is what I do:
- Start up LibreOffice.
- Pick any component from the splash screen.
** LibreOffice will hang and take up 100% CPU for about 15 seconds before it becomes responsive again.
- Now enter some text/values.
** LibreOffice will once again hang for about 10 seconds. Only after this does it become stable and can I use LibreOffice properly.

I'm using the x86_64 .deb files that you offer on the website. I also use RC3, but the problem has been with me since around Beta3.

Sorry if this bug is a duplicate, I couldn't find any similar ones that were filed.
Comment 1 Jiehong 2011-08-09 20:53:28 UTC
I have the same issue on Archlinux x86_64 and LibreOffice 3.4.2

Someone have found that LibreOffice tries to connect to a samba server and if that wins server does exist or doesn't work (most of the time) then LibreOffice waits for a time out of the packets on the port… causing the waiting time at opening.

Here is the original comment I have found: https://bugs.archlinux.org/task/22693

Maybe someone could put that part of the code in a threads so we can use LibreOffice right away even if the answer from the wins server isn't arrived yet.
But I really wonder why LibreOffice looks for wins server at a component start-up…
Comment 2 Jiehong 2011-09-01 20:52:43 UTC
After the update, this bug is the same but not the application tends to hang before displaying the document… but we still hang for ~15 seconds while nothing happens with the window openned…

LibreOffice version 3.4.3, Archlinux, x84_64
Comment 3 Björn Michaelsen 2011-12-23 11:51:19 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 4 Vincent Beers 2011-12-23 11:58:18 UTC
I have not had this problem for a while now, so as far as I'm concerned it can be considered fixed. Maybe Jiehong could also test this out just to make sure.
Comment 5 Jiehong 2011-12-23 12:42:14 UTC
For me, the problem is still there but it is a little bit different.

Now, writer is launching fine but as soon as I write something 3 or 4 letters appear and then it's hanging out for 15 seconds. Afterwards, the other letters I typped are displayed and it's working great till I close LibreOffice and open it again later (even in a same session).

I thought it was related to an extension so I have disable every extensions but the problem remained the same.

As a last hope, I've disable Java… and is worked great!

As I was using openjdk6, I thought I should just upgrade it to jre7-openjdk but it's hanging out forever then. I'll stick to openjdk7 for now then.

However, I would like to know what needs java in libreoffice just to disable it…
Comment 6 Jiehong 2011-12-23 12:48:55 UTC
typo: I'll stick to openjdk6

P.-S: the problem appears in impress and calc too (haven't tried the other ones)
Comment 7 Stefan Knorr (astron) 2012-02-19 14:16:58 UTC
Hi Vincent, Jiehong,
Do you have the LanguageTool extension installed?
(Check via: Tools > Extension Manager, look for LanguageTool entry.)

In this case, it's a known bug without a solution currently (only workaround is uninstalling LanguageTool).
Workaround for English, Hungarian and Russian: LibreOffice 3.5 offers builtin grammar checkers for those three languages.
Comment 8 Vincent Beers 2012-02-20 00:57:48 UTC
I don't have it installed. I don't know if I used to have it, but if I did, it would explain why I'm no longer having this issue.

It's all up to Jiehong (or a new person who can verify). :)
Comment 9 Jiehong 2012-03-16 14:34:04 UTC
Ok, then with the 3.5.1 version it's working fine (with java 7 too). I don't use languagetool anymore.

As Vincent said, it may be due to LanguageTool.

Bug considered as fixed then.
Comment 10 Stefan Knorr (astron) 2012-03-17 04:48:10 UTC
@Jiehong: thank you for the information!

Resolving as WORKSFORME instead, since we don't know _exactly_ what was the problem/solution.