Download it now!
Bug 33073 - this is for LibO 3.3.0 RC3. Copying Sheets in spreadsheet not working.
Summary: this is for LibO 3.3.0 RC3. Copying Sheets in spreadsheet not working.
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86 (IA32) Windows (All)
: medium major
Assignee: Not Assigned
URL: http://www.openoffice.org/issues/show...
Whiteboard: target:3.3
Keywords:
: 33111 33169 33305 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-01-13 12:10 UTC by John Ervin
Modified: 2011-01-20 15:56 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Spreadsheet exhibiting the problem (LO 3.3.0 RC3) (7.62 KB, application/vnd.oasis.opendocument.spreadsheet)
2011-01-13 12:10 UTC, John Ervin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description John Ervin 2011-01-13 12:10:04 UTC
Created attachment 41987 [details]
Spreadsheet exhibiting the problem (LO 3.3.0 RC3)

I have a multiple sheet spreadsheet.  I want to copy one of the sheets.  It creates a page but it looks weird w/o cells (all grey, no lines).  Columns are listed across the but not rows down the side.

I created a simple multiple page spreadsheet and the problem happened here also. 

I'm trying to copy sheet #1 to sheet #2 position (between former sheet #1 & #2).  I have been doing this for years so it's nothing so simple as forgetting to check the copy box.

I didn't check this yet on my Ubuntu system to see if the problem also exists on that implementation.
Comment 1 Kohei Yoshida 2011-01-13 12:21:24 UTC
Yes, known issue.  It's coming from this.

http://www.openoffice.org/issues/show_bug.cgi?id=116439
Comment 2 John Ervin 2011-01-13 16:27:53 UTC
(In reply to comment #1)
> Yes, known issue.  It's coming from this.
> 
> http://www.openoffice.org/issues/show_bug.cgi?id=116439

Yep, that sounds like it, but how did it creep in between RC2 and RC3
Comment 3 Kohei Yoshida 2011-01-13 17:54:15 UTC
(In reply to comment #2)
> (In reply to comment #1)
> > Yes, known issue.  It's coming from this.
> > 
> > http://www.openoffice.org/issues/show_bug.cgi?id=116439
> 
> Yep, that sounds like it, but how did it creep in between RC2 and RC3

Because it was a "fix" for one performance issue.  But we decided to revert that change in the end for the next release (and probably thereafter).
Comment 4 Kohei Yoshida 2011-01-14 09:21:10 UTC
*** Bug 33111 has been marked as a duplicate of this bug. ***
Comment 5 Kohei Yoshida 2011-01-14 09:22:34 UTC
OK.  I got 3 approvals and got the offending change reverted.  This should be fixed in the next build.
Comment 6 Kohei Yoshida 2011-01-19 13:06:04 UTC
*** Bug 33169 has been marked as a duplicate of this bug. ***
Comment 7 John Ervin 2011-01-19 18:49:00 UTC
I see that this record is marked Fixed, any idea when it will make it's way into a released version?  an RC4 or final release?  Just curious.
Comment 8 Kohei Yoshida 2011-01-20 10:43:00 UTC
It should be in RC4.
Comment 9 GerardF 2011-01-20 13:38:39 UTC
(In reply to comment #8)
> It should be in RC4.

It is. :)
Comment 10 Kohei Yoshida 2011-01-20 15:56:54 UTC
*** Bug 33305 has been marked as a duplicate of this bug. ***