Bug 33154 - Interaction (Execute) is generally buggy
Summary: Interaction (Execute) is generally buggy
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
(earliest affected)
3.3.0 RC3
Hardware: All All
: medium normal
Assignee: Not Assigned
Depends on:
Blocks: Slide-Show
  Show dependency treegraph
Reported: 2011-01-15 08:02 UTC by bertvandepoel
Modified: 2019-12-07 11:08 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Note You need to log in before you can comment on or make changes to this bug.
Description bertvandepoel 2011-01-15 08:02:48 UTC
The "Interaction" -> "Execute app" option in Impress is very buggy.

1. It does not know what do to when you supply a link to an actual app (on the command line it says it does not have a default app to launch that kind of file)
2. When entering a filepath in the textbox it won't launch, claiming on the CL that it can't be found
3. When selecting the same file as before from the file selector, it will launch the file normally
4. When selecting a script file, it will not execute the script but open it with the default application for that file, usually that's a texteditor.
5. The only way that it seems to be able to launch an application is when you make a script file with the file path, and do some MIME magic so that the default application to run it is something like bash, then it will run perfectly and as expected.

To elaborate on 5, what I did was the following:
I made a file called test.script
I edited it using gedit and added my link (in this case "/usr/bin/xaos")
Then I changed the default app to launch it with from gedit to bash from the file properties.
Afterwards I selected the interaction option on a textarea in my presentation, selected the execute app option, and used the file selector to select test.script
That was the only way I could get it to work.

I must say it was very disappointing it was not as easy to work with as macro's and seemed to be quite buggy/broken. I guess no one has given it any attention for quite a long time.

I discussed this in the IRC channel, and according to people there, it needs a secure re-write.
Comment 1 sophie 2011-01-15 08:10:13 UTC
Confirmed and reproduced while discussing on IRC. Thorsten could you have a look please. Thanks - Sophie
Comment 2 sophie 2011-01-15 08:22:30 UTC
For information, I found this 2 bugs on IZ:
that may give info about security - Sophie
Comment 3 retired 2013-05-24 17:40:32 UTC
This is a very old bug. I played with the feature briefly and so far it behaves correctly for me on OS X 10.8.3 with LO

I defined an app to be opened when clicking on a text field. That worked fine.

Can anybody confirm this is still valid?

@Thorsten are you still at this or should this bug be made available again?
Comment 4 Jean-Baptiste Faure 2013-11-30 14:16:26 UTC
I have just tried with version under Ubuntu 13.10 64 bits. The result is that the interaction opens the file in gedit if the program is a script, idem if the program is .desktop. If the program is an executable (build with gcc) nothing happens.
But if I insert the name of a pdf file, then the file is opened by its default application. It is consistent with the tooltip (file://...) which appears when the mouse passes over the area supposed to be linked to the program.

Best regards. JBF
Comment 5 QA Administrators 2015-04-19 03:22:31 UTC Comment hidden (obsolete)
Comment 6 QA Administrators 2016-09-20 09:24:53 UTC Comment hidden (obsolete)
Comment 7 QA Administrators 2019-12-03 13:55:06 UTC Comment hidden (obsolete)
Comment 8 Jean-Baptiste Faure 2019-12-07 11:08:18 UTC
Nothing changed since comment #4

Best regards. JBF