Download it now!
Bug 33224 - EDITING: Character style (Asian) sets size when other attributes are specified
Summary: EDITING: Character style (Asian) sets size when other attributes are specified
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 RC3
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Styles-Character
  Show dependency treegraph
 
Reported: 2011-01-17 22:21 UTC by wilo108
Modified: 2018-09-20 12:04 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description wilo108 2011-01-17 22:21:08 UTC
when trying to specify an Asian 'Typeface' value for a character style, the 'Size' is also specified.

Steps to reproduce:

1) create a new character style
2) specify the 'Typeface' under 'Asian Text Font' as 'Bold'
3) apply the style to text of different sizes.  all will be set to the size at the cursor when the 'Typeface' was specified.

This works fine with 'Western Text Font', and can be fixed manually by unzipping the odt, and removing all 'font-size-asian' attributes from char styles in styles.xml.  I have a python script that does this.  However, any attempt to modify or set the 'Typeface' results in this attribute being written back in.
Comment 1 Björn Michaelsen 2011-12-23 11:52:48 UTC Comment hidden (obsolete)
Comment 2 Florian Reisinger 2012-08-14 14:04:22 UTC Comment hidden (obsolete)
Comment 3 Florian Reisinger 2012-08-14 14:05:12 UTC Comment hidden (obsolete)
Comment 4 Florian Reisinger 2012-08-14 14:09:39 UTC Comment hidden (obsolete)
Comment 5 Florian Reisinger 2012-08-14 14:11:39 UTC Comment hidden (obsolete)
Comment 6 sasha.libreoffice 2012-08-22 09:55:11 UTC
It looks like reproducible in 3.6.0rc on Fedora 64 bit
text from baidu.com used for testing is 新 闻
Comment 7 Florian Reisinger 2012-08-22 16:49:15 UTC
Hi, is there any reason, why the status is UNCONFIRMED??

I set the status to NEW, please change if you have a different opinion...
Comment 8 Owen Genat (retired) 2014-02-02 01:08:03 UTC
Summary amended for clarity. The problem likely relates to changing any setting (except font size) for a character style e.g., repeatable here using v4.1.4.2 when changing not only the Family on the Font tab, but also Font Effects such as colour, underlining, strikethrough, etc. 

Bug 56745 appears to be the corresponding report for Western text (although it is possibly a Windows-only issue relating to the underlying default font size being an integer).
Comment 9 Joel Madero 2015-05-02 15:44:21 UTC Comment hidden (obsolete)
Comment 10 QA Administrators 2016-09-20 09:38:01 UTC Comment hidden (obsolete)
Comment 11 Thomas Lendo 2018-09-18 06:36:09 UTC
I can't reproduce the issue of unwanted font size in character style dialog with

Version: 6.2.0.0.alpha0+ (x64)
Build ID: 18c5089df091bddeb8c2dc339776671964389040
CPU threads: 8; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-09-12_23:24:12
Locale: de-AT (de_AT); Calc: CL

But another one should test it before closing this bug as WORKSFORME.
Comment 12 Harald Koester 2018-09-20 12:04:59 UTC
Checked with versions 6.0.6 and 6.1.1. (64 bit, Win 10)

I used the asian characters of comment 6 with different sizes. If I applied these characters with the new character style, in version 6.0.6 the sizes of the character always change to 10.5 pt. With version 6.1.1 the sizes do not change (10pt, 14 pt, 20 pt). Hence version 6.1.1 works as expected. Set to WORKSFORME.