Bug 33349 - Archaic Berling Antiqua Claims to have alternative name of "Times New Roman"
Summary: Archaic Berling Antiqua Claims to have alternative name of "Times New Roman"
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.3.0 RC4
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-21 12:34 UTC by Michael F
Modified: 2011-01-30 09:44 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
odt base document (14.78 KB, application/vnd.oasis.opendocument.text)
2011-01-21 12:34 UTC, Michael F
Details
font rendering in KDE & Gnome for libreoffice and system. (116.77 KB, image/jpeg)
2011-01-22 08:16 UTC, Michael F
Details
correct WindowsXP rendering of font (285.52 KB, image/bmp)
2011-01-22 11:34 UTC, Michael F
Details
Rendering with Times new roman installed from WinXP (64.94 KB, image/jpeg)
2011-01-22 15:35 UTC, Michael F
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael F 2011-01-21 12:34:11 UTC
Created attachment 42287 [details]
odt base document

The rendering of the 'Times New Roman' font is quite different when viewing the same odt or PDF document produced from the base document in Windows and Ubuntu Linux .
Comment 1 Don't use this account, use tml@iki.fi 2011-01-22 06:05:08 UTC
Could you attach a screenshot?

My first guess is that you are simply seeing the fact that even if both fonts are found when looking for "Times New Roman", they presumably are different actual fonts with different glyph shapes and (even wildly) different metrics and kerning etc? Or do you have the same actual font files used both on your Windows and Ubuntu machines, and are you sure that that is the font that gets used for this font name in all the cases?
Comment 2 Michael F 2011-01-22 08:16:25 UTC
Created attachment 42309 [details]
font rendering in KDE & Gnome for libreoffice and system.

Re: bug report

There was no libreoffice-kde package in the libreoffice PPA set for Ubuntu.
((http://ppa.launchpad.net/libreoffice/ppa/ubuntu lucid main))

The image below shows the rendering differences between libreoffice and system use using both KDE and Gnome (window manager is kdm)

On the left is the libreoffice rendering in both images. Kwrite in KDE and Gedit in Gnome respectively of the two sessions.

KDE Font manager shows:
/usr/share/fonts/truetype/msttcorefonts/Times_New_Roman.ttf
  /usr/share/fonts/truetype/msttcorefonts/Times_New_Roman_Bold.ttf
  /usr/share/fonts/truetype/msttcorefonts/Times_New_Roman_Bold_Italic.ttf
  /usr/share/fonts/truetype/msttcorefonts/Times_New_Roman_Italic.ttf

locate shows the following font (times new roman)
  mikyul@mikyul-desktop:~$ locate Times_New_Roman
  /home/mikyul/.kde/share/apps/RecentDocuments/Times_New_Roman.ttf.desktop
  /home/mikyul/.kde/share/apps/RecentDocuments/Times_New_Roman.ttf[2].desktop
  /home/mikyul/.kde/share/apps/RecentDocuments/Times_New_Roman_Bold.ttf.desktop
  /home/mikyul/.kde/share/apps/RecentDocuments/Times_New_Roman_Bold_Italic.ttf.desktop
  /home/mikyul/.kde/share/apps/RecentDocuments/Times_New_Roman_Italic.ttf.desktop
  /usr/share/fonts/truetype/msttcorefonts/Times_New_Roman.ttf
  /usr/share/fonts/truetype/msttcorefonts/Times_New_Roman_Bold.ttf
  /usr/share/fonts/truetype/msttcorefonts/Times_New_Roman_Bold_Italic.ttf
  /usr/share/fonts/truetype/msttcorefonts/Times_New_Roman_Italic.ttf
  /var/lib/defoma/gs.d/dirs/fonts/Times_New_Roman.ttf
  /var/lib/defoma/gs.d/dirs/fonts/Times_New_Roman_Bold.ttf
  /var/lib/defoma/gs.d/dirs/fonts/Times_New_Roman_Bold_Italic.ttf
  /var/lib/defoma/gs.d/dirs/fonts/Times_New_Roman_Italic.ttf
  /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType/Times_New_Roman.ttf
  /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType/Times_New_Roman_Bold.ttf
  /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType/Times_New_Roman_Bold_Italic.ttf
  /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType/Times_New_Roman_Italic.ttf
Comment 3 Don't use this account, use tml@iki.fi 2011-01-22 09:43:59 UTC
And how does it look on Windows, which you mentioned first? Or did you actually mean KDE vs. GNOME?

Anyway, it is not LibreOffice's problem if different platforms provide what are actually different fonts using the same name. Also note that when the font displayed as "Times New Roman" doesn't necessarily have to be in a file with those words in the name.

And as for random LibreOffice packages provided in "PPAs" or other places, you should complain to those who provide them.
Comment 4 Michael F 2011-01-22 11:34:50 UTC
Created attachment 42315 [details]
correct WindowsXP rendering of font

(In reply to comment #3)
> And how does it look on Windows, which you mentioned first? Or did you actually
> mean KDE vs. GNOME?
> 
> Anyway, it is not LibreOffice's problem if different platforms provide what are
> actually different fonts using the same name. Also note that when the font
> displayed as "Times New Roman" doesn't necessarily have to be in a file with
> those words in the name.
> 
> And as for random LibreOffice packages provided in "PPAs" or other places, you
> should complain to those who provide them.

Holy Cow dude this is not an assault! I just wondered how the problem might be fixed!

This reply is from windowsxp. As For windows it renders correctly in the system files and libreoffice. See attachment. I do all my production from Linux. I just noticed the difference and don't know how to fix it if it my problem or your. I don't know why installing it from ppa or deb or rpm or .exe would make any difference. Sheese!
Comment 5 Michael F 2011-01-22 12:12:32 UTC
Intended to help solve problem not cause one. Will remove libreoffice.
Comment 6 Michael F 2011-01-22 12:40:37 UTC
(In reply to comment #5)
> Intended to help solve problem not cause one. Will remove libreoffice.

Removed PPa instalation and installed from:
     LibO_3.3.0rc4_Linux_x86-64_helppack-deb_en-US.tar.gz
     LibO_3.3.0rc4_Linux_x86-64_install-deb_en-US.tar.gz

problem with font rendering still persists
Comment 7 Don't use this account, use tml@iki.fi 2011-01-22 14:49:55 UTC
Do you agree that in your Linux screenshots, it's the kwrite and gedit ones that use what looks like very close to the Times New Roman on Windows? Look at the word "Libreoffice", especially at the serif at the end of the L's bar, and the ffi ligature. Can you try to find out which actual font it is that gets used by kwrite and gedit, and by LibreOffice?

(Still, even if the glyphs in kwrite and gedit look very close, if LibreOffice was convinced to use the same font, unless its metrics are exactly compatible with the Times New Roman on Windows, you won't get the exact same layout.)
Comment 8 Michael F 2011-01-22 15:35:43 UTC
Created attachment 42322 [details]
Rendering with Times new roman installed from WinXP

I removed the msttfcorefonts version of Times_New_Roman and installed/imported the Times New roman font from my Windows XP Pro installation with the KDE Font manager

I ran 
     sudo update
and these are the only fonts shown.
  ( no /usr/share/fonts/truetype/msttcorefonts/Times_New_Roman...
locate Times_New
  /var/lib/defoma/gs.d/dirs/fonts/Times_New_Roman.ttf
  /var/lib/defoma/gs.d/dirs/fonts/Times_New_Roman_Bold.ttf
  /var/lib/defoma/gs.d/dirs/fonts/Times_New_Roman_Bold_Italic.ttf
  /var/lib/defoma/gs.d/dirs/fonts/Times_New_Roman_Italic.ttf
  /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType/Times_New_Roman.ttf
  /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType/Times_New_Roman_Bold.ttf
  /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType       /Times_New_Roman_Bold_Italic.ttf
  /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType/Times_New_Roman_Italic.ttf

As you can see in the new image attachment the rendering for Kwrite/Gedit are similar and very similar to the Windows Version. The Libreoffice appears different particularly the numbers. I do not know where the font is that KDE or Gedit is using or Libreoffice for that matter. 

FWIW: The openoffice install used to have this problem. It dissappeared with 3.1 or 3.2. It returned with removing OOffice and installing Libreoffice. ????
Comment 9 Michael F 2011-01-23 12:51:56 UTC
Modified the ~/.libreoffice/3/user/psprint/pspfontcache file. 
CHANGED THIS: 
  File:berlingi.ttf
  2;1
  Berling Antiqua;Times New Roman
  -1;BerlingAntiqua-  Italic;2;5;5;2;65535;853;250;103;0;1311;1103;1311;1103;0;0;0;8;Normal

TO: ((deleted the "Times New Roman" reference))
  File:berlingi.ttf
  2;1
  Berling Antiqua;
  -1;BerlingAntiqua-Italic;2;5;5;2;65535;853;250;103;0;1311;1103;1311;1103;0;0;0;8;Normal

Saved the file, closed and reopened Libreoffice. Now renders Times New Roman correctly.
Comment 10 Don't use this account, use tml@iki.fi 2011-01-23 14:31:58 UTC
That might have fixed it for you on that particular machine (until you clean out your LibreOffice settings directory ~/.libreoffice, which you should be able to do at any time without any serious effects (except losing your personal settings, obviously)).

But it sure isn't a real fix for the problem, in the source code. Re-opening.

Now, it might be that the actual problem is not in LibreOffice source code, but in some external library. But in that case this bug should not be resolved as FIXED, but as NOTOURBUG.
Comment 11 Michael F 2011-01-24 06:09:18 UTC
(In reply to comment #10)
> That might have fixed it for you on that particular machine (until you clean
> out your LibreOffice settings directory ~/.libreoffice, which you should be
> able to do at any time without any serious effects (except losing your personal
> settings, obviously)).
> 
> But it sure isn't a real fix for the problem, in the source code. Re-opening.
> 
> Now, it might be that the actual problem is not in LibreOffice source code, but
> in some external library. But in that case this bug should not be resolved as
> FIXED, but as NOTOURBUG.

Quite right. Deleting the .libreoffice directory and regenerating it brought back the problem.

So now what?
Comment 12 Don't use this account, use tml@iki.fi 2011-01-24 06:17:17 UTC
Now you just wait for some developer to notice this bug being in his/her field of expertise and have a look.
Comment 13 Michael F 2011-01-24 06:46:11 UTC
(In reply to comment #12)
> Now you just wait for some developer to notice this bug being in his/her field
> of expertise and have a look.

(In reply to comment #12)
> Now you just wait for some developer to notice this bug being in his/her field
> of expertise and have a look.

Ah! Much to learn.
Comment 14 Noel Power 2011-01-24 07:51:04 UTC
(In reply to comment #12)
> Now you just wait for some developer to notice this bug being in his/her field
> of expertise and have a look.

hoping caolan ( expert font manipulator ) fits the bill
Comment 15 Caolán McNamara 2011-01-24 08:02:44 UTC
So, add the output of ...

fc-list -v > /tmp/full-font-list

to this issue.

Comment #9 looks very interesting, and that's the bit I'd like to resolve. It suggests that berlingi.ttf is for come reason considered as a times new roman alias. "Berling Antiqua;Times New Roman" 

I'd need to get my hands on berlingi.ttf I believe, is that a freely distributable font or somewhere we can get it from who has the rights to distribute it, e.g. bundled with some app.
Comment 16 Michael F 2011-01-24 08:35:12 UTC
(In reply to comment #15)
> So, add the output of ...
> 
> fc-list -v > /tmp/full-font-list
> 
> to this issue.
> 
> Comment #9 looks very interesting, and that's the bit I'd like to resolve. It
> suggests that berlingi.ttf is for come reason considered as a times new roman
> alias. "Berling Antiqua;Times New Roman" 
> 
> I'd need to get my hands on berlingi.ttf I believe, is that a freely
> distributable font or somewhere we can get it from who has the rights to
> distribute it, e.g. bundled with som

Found this regarding Berling Antiqua
     http://www.desktoppublishingforum.com/bb/archive/index.php/t-6851.html
Comment 17 Michael F 2011-01-24 08:48:29 UTC
(In reply to comment #16)
> (In reply to comment #15)
> > So, add the output of ...
> > 
> > fc-list -v > /tmp/full-font-list
> > 
> > to this issue.
> > 
> > Comment #9 looks very interesting, and that's the bit I'd like to resolve. It
> > suggests that berlingi.ttf is for come reason considered as a times new roman
> > alias. "Berling Antiqua;Times New Roman" 
> > 
> > I'd need to get my hands on berlingi.ttf I believe, is that a freely
> > distributable font or somewhere we can get it from who has the rights to
> > distribute it, e.g. bundled with som
> 
> Found this regarding Berling Antiqua
>      http://www.desktoppublishingforum.com/bb/archive/index.php/t-6851.html

Found source of the problem. Berling Antiqua font imported from Windows98 install.
Comment 18 Caolán McNamara 2011-01-24 12:23:06 UTC
Pity you removed it, if you still have it somewhere else and restore it, could you give the output of fc-list -v > /tmp/fontlist.txt and/or sha1sum berlingi.ttf to get its signature. I did find a local berlingi.ttf here, but it didn't reproduce the same output in pspfontcache, which is a mightly odd looking line IMO.
Comment 19 Michael F 2011-01-24 16:40:20 UTC
(In reply to comment #18)
> Pity you removed it, if you still have it somewhere else and restore it, could
> you give the output of fc-list -v > /tmp/fontlist.txt and/or sha1sum
> berlingi.ttf to get its signature. I did find a local berlingi.ttf here, but it
> didn't reproduce the same output in pspfontcache, which is a mightly odd
> looking line IMO.

Re-installed Berling Antiqua from win98 collection
deleted ~/.libreoffice/ 
restarted Libreoffice-writer
Problem returned 
  sudo updatedb && locate fontlist.txt 
finds nothing on Ubuntu

  locate berlingi.ttf 
finds:
  ~/.kde/share/apps/RecentDocuments/berlingi.ttf.desktop

~$ sha1sum ~/.kde/share/apps/RecentDocuments/berlingi.ttf.desktop
619f933a78e27f3bf9064beab4a9cc32f174e36c  /home/mikyul/.kde/share/apps/RecentDocuments/berlingi.ttf.desktop
Comment 20 Caolán McNamara 2011-01-25 00:56:34 UTC
You're rather obsessed with updatedb :-)

Type this into a terminal, e.g. konsole or gnome-terminal

fc-list -v > /tmp/fontlist.txt

and attach the /tmp/fontlist.txt that will hopefully be created
Comment 21 Michael F 2011-01-25 06:44:46 UTC
(In reply to comment #20)
> You're rather obsessed with updatedb :-)
> 
> Type this into a terminal, e.g. konsole or gnome-terminal
> 
> fc-list -v > /tmp/fontlist.txt
> 
> and attach the /tmp/fontlist.txt that will hopefully be created

File to large at over 2,240KB
uploaded to http://www.9thandmaincoc.org/business/fontlist.txt
Comment 22 Caolán McNamara 2011-01-25 06:59:49 UTC
Relevant snippet is...

Pattern has 19 elts (size 32)
        family: "Berling Antiqua"(s) "Times New Roman"(s)
        familylang: "en"(s)
        style: "Regular"(s) "Normal"(s) "obyčejné"(s) "Standard"(s) "Κανονικά"(s) "Normaali"(s) "Normál"(s) "Normale"(s) "Standaard"(s) "Normalny"(s) "Обычный"(s) "Normálne"(s) "Navadno"(s) "thường"(s) "Arrunta"(s)
        stylelang: "en"(s) "ca"(s) "cs"(s) "de"(s) "el"(s) "fi"(s) "hu"(s) "it"(s) "nl"(s) "pl"(s) "ru"(s) "sk"(s) "sl"(s) "vi"(s) "eu"(s)
        fullname: "Berling Antiqua"(s) "Times New Roman"(s)
        fullnamelang: "en"(s)
        slant: 0(i)(s)
        weight: 80(i)(s)
        width: 100(i)(s)
        foundry: "monotype"(s)
        file: "/usr/local/share/fonts/b/berling.ttf"(s)

Looks like the font "/usr/local/share/fonts/b/berling.ttf" truly does have "Times New Roman" as a name/alias inside it.
Comment 23 Michael F 2011-01-25 07:04:13 UTC
(In reply to comment #22)
> Relevant snippet is...
> 
> Pattern has 19 elts (size 32)
>         family: "Berling Antiqua"(s) "Times New Roman"(s)
>         familylang: "en"(s)
>         style: "Regular"(s) "Normal"(s) "obyčejné"(s) "Standard"(s)
> "Κανονικά"(s) "Normaali"(s) "Normál"(s) "Normale"(s) "Standaard"(s)
> "Normalny"(s) "Обычный"(s) "Normálne"(s) "Navadno"(s) "thường"(s) "Arrunta"(s)
>         stylelang: "en"(s) "ca"(s) "cs"(s) "de"(s) "el"(s) "fi"(s) "hu"(s)
> "it"(s) "nl"(s) "pl"(s) "ru"(s) "sk"(s) "sl"(s) "vi"(s) "eu"(s)
>         fullname: "Berling Antiqua"(s) "Times New Roman"(s)
>         fullnamelang: "en"(s)
>         slant: 0(i)(s)
>         weight: 80(i)(s)
>         width: 100(i)(s)
>         foundry: "monotype"(s)
>         file: "/usr/local/share/fonts/b/berling.ttf"(s)
> 
> Looks like the font "/usr/local/share/fonts/b/berling.ttf" truly does have
> "Times New Roman" as a name/alias inside it.
removing font
Comment 24 Michael F 2011-01-25 07:41:44 UTC
(In reply to comment #23)
> (In reply to comment #22)
> > Relevant snippet is...
> > 
> > Pattern has 19 elts (size 32)
> >         family: "Berling Antiqua"(s) "Times New Roman"(s)
> >         familylang: "en"(s)
> >         style: "Regular"(s) "Normal"(s) "obyčejné"(s) "Standard"(s)
> > "Κανονικά"(s) "Normaali"(s) "Normál"(s) "Normale"(s) "Standaard"(s)
> > "Normalny"(s) "Обычный"(s) "Normálne"(s) "Navadno"(s) "thường"(s) "Arrunta"(s)
> >         stylelang: "en"(s) "ca"(s) "cs"(s) "de"(s) "el"(s) "fi"(s) "hu"(s)
> > "it"(s) "nl"(s) "pl"(s) "ru"(s) "sk"(s) "sl"(s) "vi"(s) "eu"(s)
> >         fullname: "Berling Antiqua"(s) "Times New Roman"(s)
> >         fullnamelang: "en"(s)
> >         slant: 0(i)(s)
> >         weight: 80(i)(s)
> >         width: 100(i)(s)
> >         foundry: "monotype"(s)
> >         file: "/usr/local/share/fonts/b/berling.ttf"(s)
> > 
> > Looks like the font "/usr/local/share/fonts/b/berling.ttf" truly does have
> > "Times New Roman" as a name/alias inside it.
> removing font
Actually will modify the font entry. 
     Thanks! 
I have much to learn.
Comment 25 Caolán McNamara 2011-01-29 08:27:54 UTC
.ttf really does have "Times New Roman" in it as an alternative name. Must have been based off it in the distant past as a copy and paste job or something
Comment 26 Caolán McNamara 2011-01-29 08:29:28 UTC
Might poke at some sort of black-list or sommat for this one
Comment 27 Caolán McNamara 2011-01-30 09:44:13 UTC
Fixed by detecting when a font claims to have a name of "Berling Antiqua" and an alternative name of "Times New Roman" and ignoring the TNR one in that case.

This font fools fontconfig into handing it out as a preferred TNR replacement if TNR is not installed, logged a bug against the RH fontconfig component.

libs-gui: 6ce730bef2b7ab768c6a9daf80fdd23445b7adc7