Download it now!
Bug 33624 - PDF EXPORT "Create PDF Form" breaks display in forms when displayed with AcrobatReaderX
Summary: PDF EXPORT "Create PDF Form" breaks display in forms when displayed with Acro...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.1 release
Hardware: x86-64 (AMD64) Windows (All)
: high normal
Assignee: Cédric Bosdonnat
URL:
Whiteboard: (target:3.5.0)
Keywords:
: 35760 40549 40868 42970 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-01-27 15:20 UTC by baubiologie
Modified: 2013-03-11 05:10 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
PDF Export from OOo32 on the left, than from LibO33 on the right and opened in AcrobatReader X (8.15 KB, image/jpeg)
2011-01-27 15:20 UTC, baubiologie
Details
ODT file with simple text formular (9.62 KB, application/vnd.oasis.opendocument.text)
2011-03-27 11:45 UTC, baubiologie
Details
PDF File from the ODF File (2.86 KB, application/download)
2011-03-27 11:47 UTC, baubiologie
Details

Note You need to log in before you can comment on or make changes to this bug.
Description baubiologie 2011-01-27 15:20:22 UTC
Created attachment 42618 [details]
PDF Export from OOo32 on the left, than from LibO33 on the right and opened in AcrobatReader X

I have an important file with forms, created in Openoffice.org. It works well when exported from Openoffice.org 3.2 with PDF, and than screened and printed with AcrobatReaderX (and 9).

When I open this document in Libreoffice 3.3 (and LibreOffice Portable), and export this same file with PDF, in AcrobatReaderX the text is only visible by the half in the form field. It has a to big border on the top. Even when I try to center vertically the text in the formfield.

In FoxitReader the form shows very well, either the PDF from LibreOffice and Openoffice.org.
Comment 1 talhab 2011-02-23 08:57:19 UTC
We have this problem too and would be very good if this problem is fixed soon since we use a lot of PDF forms in our company. The problem occurs not only at Acrobat X it is at earlier versions too.
Comment 2 baubiologie 2011-03-27 11:45:11 UTC
Created attachment 44921 [details]
ODT file with simple text formular

Example file, created with fresh install of LibO 3.3.2 without any changement. One Text Formular created without any special option (default options).
Comment 3 baubiologie 2011-03-27 11:47:22 UTC
Created attachment 44922 [details]
PDF File from the ODF File

The correspondant PDF file created with the ODT file, with standard PDF Export options (default options after fresh install)
Comment 4 baubiologie 2011-03-27 11:49:46 UTC
Opening the PDF file created with LibO 3.3.2 within AcrobatReader X shows two problems:
- It takes very long time to open the PDF file
- The text has a too big border upside, as in the original ODT file. In FoxitReader, the PDF file opens well, like wanted in ODT.
Comment 5 Samuel V. 2011-05-18 11:01:59 UTC
*** Bug 35760 has been marked as a duplicate of this bug. ***
Comment 6 Samuel V. 2011-05-18 11:04:39 UTC
Hi guys,
is someone working on this bug? It would be really nice to have a solution in
the next release. I need this feature of exporting a form into a .pdf. But at
this time it's useless. Please fix it.
Comment 7 rocky44r 2011-09-01 07:43:33 UTC
*** Bug 40549 has been marked as a duplicate of this bug. ***
Comment 8 rocky44r 2011-09-01 07:50:23 UTC
i am also expieriencing this problem... could someone please fix this? its a real blocker, because this worked on OpenOffice...

Thank you all for your great work :)
Comment 9 vitriol 2011-09-01 10:01:04 UTC
This bug was fixed in OpenOffice.org:

http://openoffice.org/bugzilla/show_bug.cgi?id=117131
Comment 10 Rainer Bielefeld Retired 2011-09-21 00:10:50 UTC
I also see that problem.

It's a WRITER problem, when I copy / paste a form field (that show the effect) from WRITER to CALC and export as PDF Form from CALC text in field will be shown correctly in ARX.

Text in fields looks fine in ARX if option "Create PDF Form" is disabled.

This is a very annoying problem, I had to stop using PDF form documents because of it after I changed to LibO.

Result looks a little better for exports from OOo 3.1.1, but also not perfect.

@Cédric:
Please feel free to reassign (or reset Assignee to default) if it’s not your area or if provided information is not sufficient. Please set Status to ASSIGNED if you accept this Bug.
Comment 11 Rainer Bielefeld Retired 2011-10-05 07:03:23 UTC
*** Bug 40868 has been marked as a duplicate of this bug. ***
Comment 12 Georg 2011-10-05 10:12:17 UTC
Hi,

we're just making an evaluation for about 4.500 users and it would be a great benefit to have this bug fixed soon (perhaps with a patch).

Because of using many formulars in this company it is more than only a feature. It's a reason wheter or not to use LibrOffice in the future.

Is there anyone who can tell me, when this will be fixed?

Regards
Comment 13 Rainer Bielefeld Retired 2011-12-14 21:46:05 UTC
*** Bug 42970 has been marked as a duplicate of this bug. ***
Comment 14 Rainer Bielefeld Retired 2011-12-14 21:47:59 UTC
No longer a problem with WRITER of parallel Dev-Installation of  "LibreOffice 3.5.0 Beta1 - WIN7 Home Premium (64bit) German UI [Build-ID: 7362ca8-b5a8e65-af86909-d471f98-61464c4] Windows_Release_Configuration  11-Dec-2011 06:51"
Comment 15 Rainer Bielefeld Retired 2011-12-14 21:48:43 UTC
so WFM
Comment 16 Samuel V. 2013-03-10 23:47:53 UTC
WFM
so I think someone can mark this bug as FIXED if neccessary
Comment 17 Rainer Bielefeld Retired 2013-03-11 05:10:16 UTC
@Samuel (In reply to comment #16):
No, we only mark bugs with known Fix as fixed.