Bug 33813 - FILEOPEN: Animation behaviour not carried over from ODP saved in other appliction
Summary: FILEOPEN: Animation behaviour not carried over from ODP saved in other applic...
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-01 08:55 UTC by Jaxson Lee
Modified: 2013-04-24 22:44 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
ODP created and saved by MS Office 2007 with simple animation (44.62 KB, application/vnd.oasis.opendocument.presentation)
2011-02-01 08:55 UTC, Jaxson Lee
Details
AnimOff2007.odp edited in Impress as described (37.70 KB, application/vnd.oasis.opendocument.presentation)
2011-02-01 08:56 UTC, Jaxson Lee
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jaxson Lee 2011-02-01 08:55:20 UTC
Created attachment 42811 [details]
ODP created and saved by MS Office 2007 with simple animation

The attached document AnimOff07.odp was saved in .ODP format in MS Office 2007. It consists of two images, both of which have custom animation. After starting the slide show, a mouse click should trigger the left image moves right, and the right image moves left so they overlap in the middle. However, when opened in Impress, they don't animate at all!

I've edited it so they do animate as expected, by selecting Right and Left respectively in the Motion Paths tab of the Modify Effect section of the Custom Animation sidebar - the result of that is attached as AnimLibOFix.odp. I had a look at the XML to see what was different, and came across this:

- <anim:par smil:begin="0.0s" smil:fill="hold">
- <anim:par smil:accelerate="50" smil:decelerate="50" presentation:node-type="on-click" presentation:preset-id="63" presentation:preset-sub-type="0" presentation:preset-class="motion-path" smil:begin="0.0s" smil:fill="hold">
  <anim:animateMotion svg:path="M 0 0 L 0.25 0 E" svg:origin="layout" smil:targetElement="id64" smil:attributeName="x" smil:dur="2.0s" smil:fill="hold" /> 
  </anim:par>

(Office2007 original version)

<anim:par smil:begin="0s">
 <anim:par smil:begin="0s" smil:fill="hold" smil:accelerate="50" smil:decelerate="50" presentation:node-type="on-click" presentation:preset-class="motion-path" presentation:preset-id="ooo-motionpath-right">
  <anim:animateMotion smil:dur="2s" smil:fill="hold" smil:targetElement="id1" svg:path="M 0 0 L 0.25 0" /> 
  </anim:par>
(LibO edited version)

The difference seems to be in the presentation:preset-id. I don't know whose at fault here, but LibO's "ooo-motionpath-right" sounds just as application specific as MS's "63". Doesn't the specification prescribe standard preset of commonly used animation effects? Moving an object in a straight line across a page would seem to be pretty basic?
Comment 1 Jaxson Lee 2011-02-01 08:56:08 UTC
Created attachment 42812 [details]
AnimOff2007.odp edited in Impress as described
Comment 2 Björn Michaelsen 2011-12-23 11:52:53 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 3 sasha.libreoffice 2012-03-24 01:16:03 UTC
Thanks for bugreport
Reproduced in 3.3.4, 3.4.3 and 3.5.1 on Fedora 64 bit and Windows 32 bit
PowerPoint 2007 opens first attachment and plays animation correctly

Site http://www.probatron.org:8080/officeotron/officeotron.html
tells about first attachment this:
Processing manifest entry: content.xml
     It has root element named <document-content> in the namespace urn:oasis:names:tc:opendocument:xmlns:office:1.0
     Forcing validation against ISO/IEC 26300
          (content.xml:2 col:2,856) element "par" from namespace "urn:oasis:names:tc:opendocument:xmlns:animation:1.0" not allowed in this context
          (content.xml:2 col:3,276) attribute "dur" from namespace "urn:oasis:names:tc:opendocument:xmlns:smil-compatible:1.0" not allowed at this point; ignored
          (content.xml:2 col:3,695) attribute "dur" from namespace "urn:oasis:names:tc:opendocument:xmlns:smil-compatible:1.0" not allowed at this point; ignored
     The document is invalid

if ISO/IEC 26300 not set for validation, then this file contains no errors
Comment 4 A (Andy) 2013-04-23 20:48:15 UTC
reproducible with LO 4.0.2.2 (Win7 Home, 64bit)

@Thorsten: What do you think, is this a LO or MSO bug?
Comment 5 Thorsten Behrens (allotropia) 2013-04-24 22:44:16 UTC
(In reply to comment #0)
> The difference seems to be in the presentation:preset-id. I don't know whose
> at fault here, but LibO's "ooo-motionpath-right" sounds just as application
> specific as MS's "63". Doesn't the specification prescribe standard preset
> of commonly used animation effects? Moving an object in a straight line
> across a page would seem to be pretty basic?
>
The one determining difference is the first child element of the

 <anim:seq presentation:node-type="main-sequence">

element - for the MSO2k7 file, this is

 <anim:par smil:begin="indefinite">

, for the LibO file, it is

 <anim:par smil:begin="next">

(modifying the MSO file by replacing "indefinite" with "next" makes it
work here).

According to

 http://www.w3.org/TR/2005/REC-SMIL2-20050107/smil-timing.html#edef-seq

, disallowed values for children of seq containers are

 syncbase-value | event-value | media-marker-value |
 wallclock-sync-value | repeat-value | accesskey-value | "indefinite"

, such that the attached file AnimOff07.odp is in fact in violation of
the spec.