Bug Hunting Session
Bug 33844 - Portable: Can not be launched if LibO or OpenOffice.org is running (per Comment 3)
Summary: Portable: Can not be launched if LibO or OpenOffice.org is running (per Comme...
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: All Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-02 08:25 UTC by Christopher Schultz
Modified: 2017-08-15 12:00 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher Schultz 2011-02-02 08:25:39 UTC
STR

1. Launch OpenOffice.org and leave it running
2. Launch OpenOfficePortable

Result: "Another instance of LibreOffice is already running. Please close other instances of LibreOffice before launching LibreOffice Portable."

Expected: Successful launch.

Perhaps OpenOffice.org and LibreOffice are still using the same technique to determine if they are already running?

It would be really nice if both packages would run side-by-side.
Comment 1 Rainer Bielefeld Retired 2011-02-02 11:10:12 UTC
NOT reproducible] with "LibreOffice 3.3.0 RC4 - WIN7  Home Premium (64bit) German UI  [OOO330m19 (build 6 / tag 3.3.0.4)]" and LibO Portable 3.3. I always started the second LibO Program from WIN Start Bar after I already had started the other one.

@Christopher Schultz
Please:
- describe what your report has to do with LibO
- contribute
  -- information concerning your OS and precise version information
     for all SomeOffice applications you used for your test.
  -- a step by step instruction containing every mouse click and every key 
     press you did for your test (instead of an expressionless "launch"
Comment 2 Christopher Schultz 2011-02-02 15:50:48 UTC
I'm running OpenOffice.org 3.2.1 OOO320m18 (Build:9502) on Windows 7 Professional 32-bit, installed normally from the standard installer.

I'm running LibreOfficePortable 3.3.0 OOO330m19 (Build:6) tag libreoffice-3.3.0.4. As this is the "portable" version, it is not "installed" per se. Rather, it is running out of a plain-old directory, as installed by the "portable installer".

I started OOo by double-clicking a random document from my desktop. If you need a sample text, spreadsheet, or other document, I'd be happy to provide one. I suspect any document will do.

I attempted to start LibreOfficePortable by double-clicking "LibreOfficePortable.exe" from the folder in which it resides.

I'd be happy to provide any additional information you require.

Please note the use of OpenOffice.org *and* LibO together: LibO complains that it's already running when it's actually OOo that's running. Performing these steps in the opposite order (run LiO Portable first, then run OOo) does not cause any error.
Comment 3 Rainer Bielefeld Retired 2011-02-02 23:25:44 UTC
[Reproducible] with "LibreOffice 3.3.0 RC4 - WIN7  Home Premium (64bit) German UI  [OOO330m19 (build 6 / tag 3.3.0.4)]", 

It's possible to
1. Launch Portable Calc by double click on .exe
2. Launch some other Office program (OOo3.4-dev, LibO 3.3, OOo 3.1.1)
3. Terminate Portable LibO
4. Restart Portable LibO by double click on .exe

It's NOT possible to
1. ./.
2. Launch some other Office program (OOo3.4-dev, LibO 3.3, OOo 3.1.1)
3. ./.
4. Launch Portable LibO

Strange!
Comment 4 Björn Michaelsen 2011-12-23 11:52:56 UTC Comment hidden (obsolete)
Comment 5 Rainer Bielefeld Retired 2012-07-09 14:54:01 UTC
This limitation still exists with Portable LibreOffice 3.5.4.2 
Build-ID: 165a79a-7059095-e13bb37-fef39a4-9503d18

Might be intended, but for what should that be useful, can be surmounted easily by first starting Portable and then LibO / OOo / AOOo. 

IMHO useless limitation!
Comment 6 QA Administrators 2015-01-05 17:52:32 UTC Comment hidden (obsolete)
Comment 7 QA Administrators 2016-01-17 20:05:26 UTC Comment hidden (obsolete)
Comment 8 QA Administrators 2017-03-06 14:41:47 UTC Comment hidden (obsolete)
Comment 9 Timur 2017-08-15 12:00:28 UTC
"Portable" is probably LO from https://portableapps.com/apps/office/libreoffice_portable
Reproducible with 5.2.7. as described in Comment 3.
But, that should be Portable Apps issue, so NotOurBug. 

Workaround 1: start Portable first, and then installed LO
Workaround 2: use Separate Install GUI tool from https://flosmind.wordpress.com/si-gui/ which downloads and extracts different LO versions, without installing, so it's also portable but convenient for multiple versions.