Bug 33850 - frame anchored form crashes base
Summary: frame anchored form crashes base
Status: RESOLVED DUPLICATE of bug 35584
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
(earliest affected)
3.3.0 release
Hardware: All All
: medium normal
Assignee: Not Assigned
Keywords: regression
Depends on:
Reported: 2011-02-02 12:44 UTC by godblesslinux
Modified: 2011-08-20 07:15 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:

Base document to reproduce the form crash. (12.00 KB, application/vnd.sun.xml.base)
2011-02-03 05:05 UTC, godblesslinux
Crash report log when attempting to anchor control to frame in Base form (64.01 KB, text/plain)
2011-02-03 05:46 UTC, Alex Thurgood
Other crash report (62.58 KB, text/plain)
2011-02-03 05:58 UTC, Alex Thurgood

Note You need to log in before you can comment on or make changes to this bug.
Description godblesslinux 2011-02-02 12:44:18 UTC
LibreOffice crashes when trying to anchor a form control to a frame in a base form document.

The reason for this anchoring setup is to emulate tab functionality in base forms by nesting form objects on frames in page sections which can then be simultaneously hid and shown through macro coding.

Unfortunately, LibreOffice 3.3 crashes every time a form object is anchored to a frame.  From my reproductions, this bug seems to exists regardless of the form object type, database file, or operating system.

I discovered this method of "tabbed" form setup on the OpenOffice forums online, so I don't believe that I am the only one trying to accomplish this.  We would surely appreciate if this could be fixed.

Comment 1 godblesslinux 2011-02-02 12:56:46 UTC
To Reproduce:

Create new empty Base document.  Go to forms.  Press "Create Form in Design View".  Press the "Formatted Field" button on the toolbar and create the object in the document.  Insert a large frame, anchor it to page, and send it to back.  Move the field control over the frame.  Right-click and select "Anchor to Frame".

LibreOffice crashes.
Comment 2 Muthu 2011-02-03 03:12:41 UTC
Would it possible for you to attach the file please? So, that just opening it and right-clicking it causes the crash (or something similar)...This would reduce a lot of steps involved and not many of us are well versed with base.

Would it also be possible to provide the traces, please? Especially with the debug symbols.

Thank you!

Ref: http://wiki.documentfoundation.org/BugReport
Comment 3 godblesslinux 2011-02-03 05:05:46 UTC
Created attachment 42899 [details]
Base document to reproduce the form crash.

To reproduce the crash:

Open this document and go to "Forms".  From there, follow instructions on the form labels.
Comment 4 godblesslinux 2011-02-03 05:08:55 UTC
I ran the program in debug mode and produced the following:

Program received signal SIGSEGV, Segmentation fault.
0x00007fffcdddf57c in AppendDrawObj () from /usr/lib/libreoffice/program/../basis-link/program/libswlx.so

0x00007fffcdddf57c in AppendDrawObj () from /usr/lib/libreoffice/program/../basis-link/program/libswlx.so
Cannot access memory at address 0x7fffffffb4c8
Comment 5 Alex Thurgood 2011-02-03 05:44:13 UTC
Hi all,

I opened the file provided in NeoOffice 3.1.2, made the change, i.e. anchored to frame, and saved both form and ODB. NeoOffice did not crash.

Then I tried to open the same saved ODB file in LibreOffice 3.3.0 and it crashed without even getting to the main db window. I am enclosing the Apple generated crash report.

Comment 6 Alex Thurgood 2011-02-03 05:46:00 UTC
Created attachment 42900 [details]
Crash report log when attempting to anchor control to frame in Base form

As the report here indicates, tested on Mac OSX 10.6.6, with LibreOffice 3.3.0 final.
Comment 7 Alex Thurgood 2011-02-03 05:50:32 UTC
This works in OOo 3.2.1, i.e. you can attach the control to the frame and save normally, as with NeoOffice 3.1.2, so this is definitely a regression.

Comment 8 Alex Thurgood 2011-02-03 05:58:32 UTC
Created attachment 42901 [details]
Other crash report

This is a further crash report after repeating exactly the steps indicated by the original poster. Mac OSX 10.6.6. LibO 3.3.0 final
Comment 9 Zoltán Reizinger 2011-02-15 10:15:18 UTC
This is a known bug from OOo 3.3RC4 http://qa.openoffice.org/issues/show_bug.cgi?id=115557
Comment 10 Jean-Baptiste Faure 2011-08-20 07:11:10 UTC
Same bug as fdo#35584 which is fixed in LibreOffice 3.4.x

*** This bug has been marked as a duplicate of bug 35584 ***
Comment 11 Jean-Baptiste Faure 2011-08-20 07:15:15 UTC