Bug 33854 - Opening a MS Word docx and table columns change width (OOwriter does the same)
Summary: Opening a MS Word docx and table columns change width (OOwriter does the same)
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: All Linux (All)
: medium major
Assignee: Luboš Luňák
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-02 15:32 UTC by Tom Browder
Modified: 2013-08-15 09:33 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
MS Word docx with a wide table (15.51 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2011-02-02 15:32 UTC, Tom Browder
Details
Pdf file produced by MS Word so the original table column widths can be seen (88.00 KB, application/pdf)
2011-02-02 15:33 UTC, Tom Browder
Details
PHPWord generated document (9.43 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2012-02-22 01:42 UTC, Mark Seddon
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tom Browder 2011-02-02 15:32:23 UTC
Created attachment 42876 [details]
MS Word docx with a wide table

I have a Word docx created with MS Office 2007, landscape, legal paper size.

I'm using latest version of LO. When I open the file with either Libre
Office or Open Office the table columns lose all width information.

I'm using Ubuntu 10.10, 64-bit.

To me this is a show-stopper from getting folks to use LO.  It is also a surprise because I have had great results with OO in the past.

I have attached the docx file and the pdf generated from it with MS Word.
Comment 1 Tom Browder 2011-02-02 15:33:41 UTC
Created attachment 42877 [details]
Pdf file produced by MS Word so the original table column widths can be seen
Comment 2 Muthu 2011-02-03 03:16:07 UTC
one for cedric?
Comment 3 Cédric Bosdonnat 2011-02-03 03:54:39 UTC
(In reply to comment #2)
> one for cedric?

Lubos, can you handle this one? I have my plate of bugs ATM :)
Comment 4 Luboš Luňák 2011-02-09 08:31:19 UTC
Only import seems to be broken, it reads NS_ooxml::LN_CT_TblGridBase_gridCol but doesn't seem to use it.
Comment 5 Anonymous Helper 2011-04-05 10:53:49 UTC
Lubos, any progress? This is still not solved in the current version of LibreOffice. Try making some tables in Office 2010, save as .doc or .docx. Export to PDF. Now open the file in OpenOffice/LibreOffice. Export to PDF. Tables are fucked. Lines look bad and height of rows is not preserved.

This is really pretty severe. LibreOffice should work with tables produced by other word processors.
Comment 6 Erich 2011-05-09 05:07:12 UTC
can confirm with Win7-64
Comment 7 Erich 2011-05-09 05:16:39 UTC
sorry, forgot to mention:
LibreOffice 3.3.2 
OOO330m19 (Build:202)
tag libreoffice-3.3.2.2 

check with Vista 32 and Beta 4 still shows the same behaviour
LO 3.4.0
DEV300m103 (Build:4)
Comment 8 Erich 2011-05-11 14:55:19 UTC
same behaviour with DEV300m103 (Build:5) and Win7-64
Comment 9 asp 2011-11-23 09:55:33 UTC
Reports on this are also coming in on launchpad: https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/881485
Comment 10 Mark Seddon 2012-02-22 01:42:00 UTC
Created attachment 57442 [details]
PHPWord generated document

PHPWord generated document containing multiple tables. When this file is opened in Word / Google Docs the column widths are set but in Libreoffice the widths are ignored.
Comment 11 Mark Seddon 2012-02-22 01:42:59 UTC
This is still true in Libreoffice 3.5.0 on Mac OS X 10.6.8.
Comment 12 asp 2012-03-06 14:09:32 UTC
The test doc appears to be working for me now in Ubuntu 12.04 with LibreOffice 3.5.0 Build ID: 350m1(Build:13).
Comment 13 Damien Chambe 2012-10-13 13:39:23 UTC
Tested on Ubuntu 12.04 with Libreoffice 3.6.1.2 (Build ID: e29a214)

Table width is rendered correctly with this version. 

But the font is "Time 11.1" in the PDF, it is converted to "Times New Roman 12" in writer. So the text is to long for a few cell, and go to next line.
If I force all text to 11.1, the document matches exactly the PDF.
Comment 14 Felix Bachofner 2013-05-08 20:02:23 UTC
I am witnessing this same problem in 4.0.2.2 on Windows XP and 3.6x on LinuxMint 14
Comment 15 bfoman (inactive) 2013-08-14 21:13:04 UTC
Checked with:
Version: 4.2.0.0.alpha0+
Build ID: 087a610fcd5c0c354a9ed6bfccd3451b667d62a3
TinderBox: Win-x86@6-debug, Branch:master, Time: 2013-08-04_21:41:24
Windows 8.1 Enterprise Preview 64 bit

Table looks the same in LibreOffice as in Word 2013.
Comment 16 retired 2013-08-15 09:33:01 UTC
WORKSFORME on OS X 10.8.4, LO 4.1.1.1 and Ubuntu 13.04 LO 4.1.0.3.

Please re-open if you disagree.