Download it now!
Bug 34185 - RFE: HTML compatibility option "Do not modify metadata when saving"
Summary: RFE: HTML compatibility option "Do not modify metadata when saving"
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-11 08:57 UTC by Stas Fomin
Modified: 2012-08-31 10:04 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stas Fomin 2011-02-11 08:57:20 UTC
LibreOffice will be very useful
in collaborative text editing
if
* document in plain HTML format will be saved in the versioned storage (Subversion/CVS/… repository) and
* with automatic merging of changes made by different people.

But now every merge operation produces at least one conflict: it's a conflict
in <meta> tags:
<meta name="GENERATOR"> - some people use Linux, some people use Windows
<meta name="CHANGED"> - changed on every document save operation, so automatic
merge is not possible.

Furthermore, when CVS or Subversion client discovers
conflicts, it adds conflict markers like '<<<<< 1.1 .... ====== ..... >>>>>
1.2' in the conflict areas, so document could not be opened more as valid HTML,
because the HTML header is the conflict area.

I know there is a check-box named "Apply user data" in document properties (File/Properties), and
if I uncheck it before saving, <meta name="CHANGED"> isn't overwritten on every
save and my personal data isn't written into the document, but:
1) <meta name="GENERATOR"> is _still_ overwritten on every save;
2) I need to uncheck "Apply user data" every time opening the document.

I also know that there is an option "Remove personal data on save" in security
settings, but it also doesn't help: <meta name="CHANGED"> is cleared, but <meta
name="CREATED"> is always overwritten by current time (WTF???!!), and <meta
name="GENERATOR"> is also still overwritten.
So this also produces conflicts.

I suggest you to add an HTML compatibility option "Do not modify metadata when
saving" or something like that. This will be very useful for people
who want organize a convenient versioned storage for text documents.
Comment 1 Björn Michaelsen 2011-12-23 11:44:57 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 2 Stas Fomin 2012-01-17 01:25:16 UTC
Checked 3.5.0beta1
No changes.

* Still add 
----------
        <META NAME="CHANGED" CONTENT="20120117;13152567">
----------
to HTML.
* Still there are no settings to disable this. 

My RFE is still active.
Comment 3 Florian Reisinger 2012-08-14 13:58:29 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 4 Florian Reisinger 2012-08-14 13:59:45 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 5 Florian Reisinger 2012-08-14 14:04:22 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 6 Florian Reisinger 2012-08-14 14:06:34 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian