Download it now!
Bug 34274 - Copy and paste object from Impress/Diagram to Writer Draw Object have wrong size
Summary: Copy and paste object from Impress/Diagram to Writer Draw Object have wrong size
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: All All
: low normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-14 12:28 UTC by Arnaud Versini
Modified: 2015-03-05 05:39 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
ellipse created in Draw (9.33 KB, image/png)
2012-01-21 12:21 UTC, Christina Rossmanith
Details
ellipse pasted into Writer (14.35 KB, image/png)
2012-01-21 12:22 UTC, Christina Rossmanith
Details
picture with grouped ellipses (9.07 KB, application/vnd.oasis.opendocument.graphics)
2012-01-23 01:14 UTC, sasha.libreoffice
Details
grouped ellipses pasted in Writer (90.72 KB, image/png)
2015-03-05 05:39 UTC, Jean-Baptiste Faure
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Arnaud Versini 2011-02-14 12:28:57 UTC
Reproducible :

- Create a diagram
- Draw 2 rectangles with large border
- Copy these two rectangles
- Paste in writer using Paste Special with Draw 8's format.

The object containing the 2 boxes is not big enough and is masking part of their borders.
Comment 1 Jeffrey 2011-06-22 19:11:16 UTC
Reproducible in LibreOffice 3.4  340m1(Build:12) on Opensuse KDE.
Comment 2 Björn Michaelsen 2011-12-23 11:43:16 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 3 Arnaud Versini 2011-12-23 12:03:54 UTC
Not exactly the same issue but the size is still incorrect in 3.5Beta 1. Only half of the border are still visible after this operation on 3.5 beta 1, the totality of the rectangle border on the object border on 3.4 are not visible. PDF export have no problem on both versions

There is also some problems with a fill color on some corners.
Comment 4 Jean-Baptiste Faure 2011-12-26 08:14:15 UTC
Hi Arnaud,

I am not sure to understand well what you mean. Could you attach screen copies showing the problem ?
From my side I do not see difference between the drawing in Impress and its copy in Writer. Tested with LO 3.5.0 beta2+ (LibreOffice 3.5.0beta2+ Version ID : 8f03437-7f15fca-1fc8c06-ca8e46d-b96fade).

Best regards. JBF
Comment 5 sasha.libreoffice 2012-01-04 02:49:30 UTC
Reproducible on LibO 3.5.0 beta 1
steps to reproduce:
0 start LibreDraw with empty document
1 draw there ellipse
2 right click it and select "line" in context menu
3 change width to 0.5 cm
4 press ctrl-C
5 start LibreWriter with empty document
6 press Ctrl-Shift-V or Edit->paste special
7 select there Draw 8 and press Ok.

This bug resembles Bug 37428. And there described how repair such pictures
Comment 6 Christina Rossmanith 2012-01-21 12:21:44 UTC
Created attachment 55927 [details]
ellipse created in Draw
Comment 7 Christina Rossmanith 2012-01-21 12:22:41 UTC
Created attachment 55928 [details]
ellipse pasted into Writer
Comment 8 Jean-Baptiste Faure 2012-01-21 17:02:49 UTC
Did you try to group the objects before to copy them ?

Best regards. JBF
Comment 9 sasha.libreoffice 2012-01-23 01:14:09 UTC
Created attachment 56019 [details]
picture with grouped ellipses

Yes, grouped ellipses produce the same problem
Comment 10 A (Andy) 2013-05-04 21:45:20 UTC
reproducible with LO 4.0.2.2 (Win7 Home, 64bit)

If I use Ctrl + V instead of PASTE SPECIAL then everything is fine, but with PASTE SPECIAL the drawing is cropped.

As per the comment from Arnaud I also exported the document as a pdf (FILE -> EXPORT AS PDF) and the pdf shows exactly the same as in the odt document.  
But I experienced a very strange result, if I try to print the document with the drawing inserted by PASTE SPECIAL.  In this case the printout is really buggy, because I get an empty page without any drawing.  This buggy behavior is increased if I insert in addition the drawing with Ctrl + V into the same document, because then this Ctrl + V drawing will be totally displaced.
Comment 11 QA Administrators 2015-03-04 02:19:21 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1.2 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-03-03
Comment 12 Jean-Baptiste Faure 2015-03-05 05:39:12 UTC
Created attachment 113903 [details]
grouped ellipses pasted in Writer

Not reproducible for me with LibreOffice 4.4.2.0.0+ built at home under Ubuntu 14.10 x86-64.
I copied the grouped ellipse of the attachment 56019 [details] in Draw and did a paste special in a new text document using Draw8 format. 

Setting status to WorksForMe. Please, feel free to reopen if you disagree.

Best regards. JBF