Bug 34350 - calc crash: too small of an interval range
Summary: calc crash: too small of an interval range
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
3.3.1 release
Hardware: Other All
: highest normal
Assignee: Kohei Yoshida
URL:
Whiteboard: target:3.4
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-16 10:25 UTC by Kevin Hunter
Modified: 2021-09-11 00:07 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
attribute "chart:interval-major="0.000000001" in XML apparently not appreciated by LO (31.23 KB, application/vnd.oasis.opendocument.spreadsheet)
2011-02-16 10:25 UTC, Kevin Hunter
Details
Same file with no 'chart:interval-major=...' attribute. (31.22 KB, application/vnd.oasis.opendocument.spreadsheet)
2011-02-16 10:26 UTC, Kevin Hunter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Hunter 2011-02-16 10:25:36 UTC
Created attachment 43441 [details]
attribute "chart:interval-major="0.000000001" in XML apparently not appreciated by LO

LO appears to not appreciate fairly small interval ranges.  First clue is that LO fails to produce an image for the spreadsheet component, and then when trying to edit a chart with such an interval (i.e. double click on the image), LO crashes.

The only difference between the two attached files is a 'chart:interval-major="0.000000001"' attribute in the "Object 1/content.xml".  Though the thumbnail is not created in the "calc_survives.ods" file, you can at least double click the chart without a crash.
Comment 1 Kevin Hunter 2011-02-16 10:26:48 UTC
Created attachment 43442 [details]
Same file with no 'chart:interval-major=...' attribute.
Comment 2 Kevin Hunter 2011-02-16 10:29:25 UTC
Setting Kohei as the assignee.
Comment 3 Kohei Yoshida 2011-02-16 12:03:57 UTC
Crasher is almost always higher priority.
Comment 4 Kohei Yoshida 2011-03-02 13:16:19 UTC
Simple fix.  The code was trying to resize an array with a negative value.

http://cgit.freedesktop.org/libreoffice/calc/commit/?id=1e3b1a7a8c939a0ae08a14d5efdd65b17355dae9

Fixed on master.
Comment 5 Rainer Bielefeld Retired 2011-03-03 22:11:24 UTC
[Reproducible] with "LibreOffice 3.3.1  – WIN7  Home Premium  (64bit) English UI [OOO330m19 (build 8 / tag 3.3.1.2)]".

@ Kevin Hunter:
Please change Version to earliest version with what you observed the problem.
Comment 6 Rainer Bielefeld Retired 2011-03-03 22:15:25 UTC
BTW. LibO also crashes when I copy / Paste chart from "kill_calc.ods" to a blank new writer document (<cntrl>+<c> / <cntrl>+<v>. I am pretty sure that that crash is caused by the same problem, but as a precaution someone should check whether the fix also heals that WRITER crash
Comment 7 Linda Rose 2018-12-21 07:02:08 UTC Comment hidden (spam)
Comment 8 karanmath 2019-06-29 05:13:11 UTC Comment hidden (spam)
Comment 9 helenson 2019-09-06 10:14:12 UTC Comment hidden (spam)
Comment 10 trickjenn 2020-04-14 02:30:40 UTC Comment hidden (spam)
Comment 11 Taniya Wilson 2020-09-04 07:28:22 UTC Comment hidden (spam)
Comment 12 Taniya Wilson 2020-09-04 07:28:46 UTC Comment hidden (spam)
Comment 13 Taniya Wilson 2020-09-04 07:29:04 UTC Comment hidden (spam)
Comment 14 nickwin 2020-11-10 04:55:39 UTC Comment hidden (spam)
Comment 15 pourvan 2020-11-26 05:20:46 UTC Comment hidden (spam)
Comment 16 michsam 2021-01-09 06:47:53 UTC Comment hidden (spam)
Comment 17 jefmar 2021-02-20 10:04:29 UTC Comment hidden (spam)
Comment 18 montcar 2021-03-29 05:06:33 UTC Comment hidden (spam)
Comment 19 Cubic Interiors 2021-06-29 07:18:06 UTC Comment hidden (spam)
Comment 20 Ranveer 2021-08-21 17:33:56 UTC Comment hidden (spam)
Comment 21 dowekok224 2021-09-08 09:28:20 UTC Comment hidden (spam)