Bug Hunting Session
Bug 34525 - fontwork problem: font URW Chancery L renders not correct when bold
Summary: fontwork problem: font URW Chancery L renders not correct when bold
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-21 03:54 UTC by sasha.libreoffice
Modified: 2016-01-04 21:17 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
on first page 2 Fontworks: unbold and bold, and same text without Fontwork. On second page screenshot of first page. (95.90 KB, application/vnd.oasis.opendocument.text)
2011-02-21 03:54 UTC, sasha.libreoffice
Details
screenshot on Windows (see first page) (167.30 KB, image/jpeg)
2012-01-30 02:10 UTC, sasha.libreoffice
Details
screenshot on Fedora 64 bit (see first page bottom) (183.33 KB, image/jpeg)
2012-01-30 02:14 UTC, sasha.libreoffice
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sasha.libreoffice 2011-02-21 03:54:04 UTC
Created attachment 43594 [details]
on first page 2 Fontworks: unbold and bold, and same text without Fontwork. On second page screenshot of first page. 

On Linux I have created Fontwork (Wordart) using font URW Chancery L. I used letters ABCDF. When they are not bold all is right. But when they bold they look strange.

Experiments show, that strange look not all letters in text, but some. Situation differs when change slant (yellow handle in bottom of text).

On windows no problem. On Linux OpenOffice the same problem.

In attached file on first page 2 Fontworks: unbold and bold, and same text without Fontwork.
On second page screenshot of first page.
Comment 1 sasha.libreoffice 2011-02-24 06:52:04 UTC
on LibreOffice 3.3.1 problem still exist
Comment 2 Björn Michaelsen 2011-12-23 11:50:05 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 3 sasha.libreoffice 2011-12-30 00:32:23 UTC
reproduced on LibO 3.5.0 beta 1
Comment 4 Florian Reisinger 2012-01-21 04:12:39 UTC
With LibO 3.5 RC 1 it is working for me. (Win 7 x64
PS: Screenshot @ page 3
Comment 5 sasha.libreoffice 2012-01-23 01:01:41 UTC
But it is Linux specific bug. We need test it only on Linux.
Return status to Unconfirmed
Comment 6 Jean-Baptiste Faure 2012-01-29 21:03:32 UTC
(In reply to comment #5)
> But it is Linux specific bug. We need test it only on Linux.
> Return status to Unconfirmed

Ok, so in order to be able to compare, could you attach a screen copy of actual behavior on your linux box and a screen copy on MS-Windows (as a reference).
In other words : a screen copy for what is expected and a screen copy for what you get.

From my side I do not see a problem with your bugdoc in LO 3.5.0 rc2+ under Ubuntu 11.10. Page 1 seems identical to page 2.

Best regards. JBF
Comment 7 sasha.libreoffice 2012-01-30 02:10:44 UTC
Created attachment 56315 [details]
screenshot on Windows (see first page)
Comment 8 sasha.libreoffice 2012-01-30 02:14:49 UTC
Created attachment 56316 [details]
screenshot on Fedora 64 bit (see first page bottom)
Comment 9 Valek Filippov 2012-07-07 12:42:52 UTC
Font used in Windows is not 'URW Chancery L'.

There is only "Medium Italic" variant of "URW Chancery", hence everything else would be generated from that one.
To properly compare you need to copy windows version of the font into linux.
Comment 10 sasha.libreoffice 2012-07-13 12:47:47 UTC
May be it means that problem is in font and not in office. Alas, I have no Windows today for experiments.
Comment 11 Valek Filippov 2012-07-14 11:54:53 UTC
I don't think it's a font problem (other than that embolden algo doesn't work nice with such outlines).
Comment 12 Florian Reisinger 2012-08-14 14:02:32 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 13 Florian Reisinger 2012-08-14 14:03:30 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 14 Florian Reisinger 2012-08-14 14:08:04 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 15 Florian Reisinger 2012-08-14 14:10:10 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 16 sasha.libreoffice 2012-08-15 06:19:12 UTC
in 3.6.0 problem still exist
Comment 17 Julien Nabet 2013-11-15 23:38:54 UTC
On pc Debian x86-64 with master sources updated today, I somehow reproduce the problem.
I mean I don't have the same result as Windows but have thinner/lighter lines on left page.

I also noticed this on console:
warn:unotools.misc:18295:1:unotools/source/misc/mediadescriptor.cxx:744: caught Exception "an error occurred during file opening" while opening <file:///home/julien/compile-libreoffice/bugs/.libreoffice/3/user/template/Sasha.ott>

Now, considering Valek's comment and the fact I know very little about fonts, I don't know if it confirms or not the problem.
Comment 18 Joel Madero 2014-11-03 04:49:03 UTC
never confirmed by QA team - should be UNCONFIRMED.
Comment 19 Adolfo Jayme 2014-11-30 23:14:11 UTC
Marking as NEW.
Comment 20 Valek Filippov 2014-12-01 00:21:03 UTC
(In reply to Adolfo Jayme from comment #19)
> Marking as NEW.

Can I ask what is NEW with that one? ;)

There is NO bold version of the URW Chancery L.

If anybody wants to see (near) identical results on different systems, all of the involved systems should have the same set of fonts.

This is not a bug, just wrong expectations of the bug submitter.
Comment 21 QA Administrators 2015-12-20 16:11:42 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (5.0.4 or later)
   https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 

3. Leave a comment with your results. 

4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 

4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-12-20
Comment 22 Jean-Baptiste Faure 2016-01-04 21:17:13 UTC
According to comment #20, closing as NotABug.

Best regards. JBF