Bug 34573 - FORMATTING paragraphs params behave wrong in list
Summary: FORMATTING paragraphs params behave wrong in list
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Styles-Paragraph
  Show dependency treegraph
 
Reported: 2011-02-22 07:31 UTC by sasha.libreoffice
Modified: 2019-09-10 11:07 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
demonstration problem with first line in paragraph (12.70 KB, application/vnd.oasis.opendocument.text)
2011-02-22 07:31 UTC, sasha.libreoffice
Details
explanaiton problem with paragraphs (47.53 KB, application/vnd.oasis.opendocument.text)
2011-02-28 02:55 UTC, sasha.libreoffice
Details
improved explanation of paragraph problem (35.01 KB, application/vnd.oasis.opendocument.text)
2011-03-01 01:29 UTC, sasha.libreoffice
Details
improved explanation COMPARED OO LO (142.68 KB, image/png)
2019-09-10 11:06 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sasha.libreoffice 2011-02-22 07:31:33 UTC
Created attachment 43666 [details]
demonstration problem with first line in paragraph

When paragraph is in list, numbered or not, it behaves strange. In dialog "Paragraph" in tab "Indents&Spacing" I have set Before text 7.0 cm and First line -4.0cm. First line should protrude on 4 cm. But it does not. All lines trimmed equal. When I save this file and then open, all looks ok. Firs line protrudes. But when I slightly change this parameters, then problem appears anew.
When changing indent of firs line by mouse, one can find positions where this bug not appears.
Comment 1 sasha.libreoffice 2011-02-28 02:55:02 UTC Comment hidden (obsolete)
Comment 2 Cédric Bosdonnat 2011-02-28 06:36:25 UTC
This is not a bug, but a feature. By sliding this handle you apply the same indent to all the selected paragraphs.
Comment 3 sasha.libreoffice 2011-02-28 07:38:49 UTC
Problem not in that intent the same. In text from firs attachment presents remarkable protrude in first paragraph. After moving slider protrude suddenly disapears. Other paragraphs is nonimportant.

Where disapears my outdent from firs line of first paragraph?
Comment 4 sasha.libreoffice 2011-03-01 01:29:39 UTC
Created attachment 43955 [details]
improved explanation of paragraph problem

Sorry for explanation that hard to understand. I have attached better explanation.
Comment 5 Cédric Bosdonnat 2011-03-01 02:08:36 UTC
Ok, taking it. MOving the slider is doing weird stuffs with the tabstop after the numbering.
Comment 6 sasha.libreoffice 2012-05-02 07:27:27 UTC Comment hidden (obsolete)
Comment 7 QA Administrators 2015-04-01 14:42:12 UTC Comment hidden (obsolete)
Comment 8 tommy27 2016-04-16 07:25:03 UTC Comment hidden (obsolete)
Comment 9 QA Administrators 2017-05-22 13:26:24 UTC Comment hidden (obsolete)
Comment 10 Zineta 2017-11-10 12:31:33 UTC
With  LO 5.2.7  and   Version: 6.0.0.0.alpha1+ (x64) still remains.
Just after loading of document we see strange behaviour of the first line i paragraph.
Then we move slider on 1cm right (just on one cm):
And first line jumps to right.
Comment 11 Christian Pietzsch 2018-10-07 15:31:59 UTC
I can still reproduce it in the original document in: 

Version: 6.1.0.3
Build ID: 6.1.0-2
CPU threads: 12; OS: Linux 4.18; UI render: default; VCL: gtk2; 
Locale: de-DE (en_US.UTF-8); Calc: group threaded

In the second attached document, the first line is aligned with the others from the start. 

After all it doesn't seem like a bug to me. It's just the way LO handles tab stops when there are non defined. Numbering is right where first line is defined in the paragraph option. The tab stop after the numbering is what is messing things up.
Comment 12 Timur 2019-09-10 11:06:34 UTC
Created attachment 154075 [details]
improved explanation COMPARED OO LO

First from OO, there was an inconsistent behavior on some change, but not anymore. 
Already explained that tab is the cause. MSO behaves similarly. 
Not clear what is *expected* here.
I'll agree and close the bug. 
If you object, please write expected behavior.