Bug Hunting Session
Bug 34652 - Using automatic file name extension in Libreoffice native dialog, Presentation minimizer does not export proper file name.
Summary: Using automatic file name extension in Libreoffice native dialog, Presentatio...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.3.1 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-24 01:32 UTC by Yifan Jiang
Modified: 2015-03-11 20:34 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yifan Jiang 2011-02-24 01:32:56 UTC
Platform: ALL
build info: LibreOffice 3.3.1 rc1

[Steps]

        1. Choose to 'Use libreoffice dialogs' in Tools->Libreoffice->General

        2. Open a presentation file

        3. Select from menu Tools->Minimize Presentation->Finish

        4. In the Save as dialog:

                - Check 'Automatic file name extension'

                - Select 'ODF Presentation' file type

                - Give file name as 'testmini'

        5. Click 'Save'    
[Problem]

        The resulting file will be testmini.p
        
[Extra Information]

        Actually all of the file type will not extend the file name properly,
        for example:

                - 'ODF Drawing' -. testmini.g
                - 'Microsoft PowerPoint 97/2000/XP' - testmini.t
                ...
Comment 1 Thomas Arnhold 2013-02-08 12:22:26 UTC
Can confirm this with Version 4.0.0.3 (Build ID: 7545bee9c2a0782548772a21bc84a9dcc583b89) on Windows 7.
Comment 2 Cor Nouws 2013-06-09 12:49:05 UTC
(In reply to comment #1)
> Can confirm this with Version 4.0.0.3 (Build ID:
> 7545bee9c2a0782548772a21bc84a9dcc583b89) on Windows 7.

pls let the version field mention the olders version in which the bug exists. thanks :)
Cor
Comment 3 A (Andy) 2015-03-07 19:56:10 UTC
For me not reproducible with LO 4.4.1.2, Win 8.1

Is this reproducible for others or was it maybe already resolved in the meantime?
Comment 4 Jean-Baptiste Faure 2015-03-11 20:34:12 UTC
Not reproducible for me too with LibreOffice 4.4.3.0.0+ built at home under Ubuntu 14.10 x86-64.

Closing as WorksForMe. Please, feel free to reopen if you still encounter the same bug.

Best regards. JBF