Bug Hunting Session
Bug 34673 - Web plugin doesn't register itself for Microsoft file formats
Summary: Web plugin doesn't register itself for Microsoft file formats
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.3.1 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-24 09:42 UTC by Chris Cunningham
Modified: 2015-07-30 22:57 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
add registration of MS Office MIME types to Web plugin (1.24 KB, application/octet-stream)
2011-02-24 09:42 UTC, Chris Cunningham
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Cunningham 2011-02-24 09:42:16 UTC
Created attachment 43762 [details]
add registration of MS Office MIME types to Web plugin

Presently the Web plugin (which allows LibreOffice to display documents in browser windows) registers itself for StarOffice and OpenDocument MIME types but not for the Microsoft ones. This is inconvenient and inconsistent. Simple patch attatched which fixes this.
Comment 1 Cédric Bosdonnat 2011-02-25 05:07:50 UTC
shouldn't that depend on some config item? For more consistence I would make this code depend on the options provided in the Load/Save > Microsoft Office options page.

See this code to know how to read those options:
http://opengrok.libreoffice.org/xref/components/cui/source/options/optfltr.cxx#186
Comment 2 Björn Michaelsen 2011-12-23 11:51:45 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 3 retired 2014-05-04 11:56:24 UTC
How can this be moved forward? There's a patch. Was never merged it seems. Cédric provided some pointers, no update ever happened. Should this be set to invalid or how can this be moved forward? Is it even still valid?
Comment 4 Robinson Tryon (qubit) 2014-07-03 21:01:40 UTC
NPAPI support is dying, so this bug may become moot.

See bug 45071 for more details about status of plugins/ODF on the web (and possible avenues for future development).
Comment 5 Maxim Monastirsky 2015-07-30 22:57:50 UTC
Since 4.4 we don't have this browser plugin anymore.