Bug Hunting Session
Bug 34688 - Home and End sometimes toggle edit mode
Summary: Home and End sometimes toggle edit mode
Status: RESOLVED DUPLICATE of bug 74375
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.1 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-24 19:01 UTC by Dakov
Modified: 2016-01-08 23:08 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dakov 2011-02-24 19:01:58 UTC
If you create a new spreadsheet, go to a cell and start typing - then decide to change the first letter of what you wrote you of course tap Home to move the cursor there. But suddenly Home works like return and closes the edit mode - AND it even moves AWAY from the cell to the home of the row.

A program must be predictable and consistent to make the it easy to use and make the user feel at home and have confidence in it.

Changing the behaviour of the keys like that is confusing and waste the user's time. It's almost feel like you can't trust LibreOffice since it reacts differently in different situations instead of being predictable and logical.
Comment 1 Zeki Bildirici 2014-01-18 22:31:33 UTC
Hi,

Same behaviour in MS Excel(2007) 

It works only when mouse is clicked inside the cell.

I don't know why it is set so. If experts may have idea, then they are welcome to comment.

@Joren, what do you think about the status of this bug? 

Best regards,
Zeki
Comment 2 Jorendc 2014-01-19 14:08:35 UTC
(In reply to comment #1)

> @Joren, what do you think about the status of this bug? 

:) not sure about this one. I don't use Calc that much, and I especially don't use Home and End (MacBook Pro doesn't have those keys :p).

@Joel: power-user, any opinions about this one?
Comment 3 Cor Nouws 2016-01-08 23:08:19 UTC
the other issue is newer, but has clearer description. Hence marking this as dupe.

*** This bug has been marked as a duplicate of bug 74375 ***