Bug Hunting Session
Bug 34701 - Libreoffice doesn't interact well with awesome wm (and probably other tilers)
Summary: Libreoffice doesn't interact well with awesome wm (and probably other tilers)
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.1.4.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-25 00:56 UTC by ngoonee
Modified: 2015-07-20 02:20 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ngoonee 2011-02-25 00:56:51 UTC
If you have a dual screen with different awesome tags on each screen and libreoffice is open on the 2nd screen, scrolling or clicking on toolbars will cause the first screen to jump to the same tag as on the 2nd screen.

This bug was reported against openoffice as well. http://openoffice.org/bugzilla/show_bug.cgi?id=96684

The reason the bug occurs is because awesome receives a _NET_CURRENT_DESKTOP open office client message.

The above bug-report claims latest development openoffice fixes it. I'm not sure how this reflects on libreoffice, whether the fix was incorporated or not.
Comment 1 Cédric Bosdonnat 2011-02-25 03:01:45 UTC
It should be integrated soon, but isn't integrated yet.
Comment 2 Björn Michaelsen 2011-12-23 11:46:16 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 3 Troy Heber 2012-03-20 09:08:59 UTC
I can confirm this bug still exists in LibreOffice 3.5.1.2 Build ID: 350m1(Build:102) from Debian Experimental Mar 20th 2012.
Comment 4 libgradev 2012-07-25 09:36:58 UTC
I can confirm this bug still exists in LibreOffice 3.5.5.3 Build ID:
350m1(Build:3) on Archlinux.

3 monitor setup - causes only the main monitor to switch to the same tag if Libreoffice is acted upon (scroll or menu click) on another monitor.
Comment 5 ngoonee 2013-05-23 03:02:55 UTC
Still occurs in libreoffice 4.0.3. For me its changed slightly in that instead of switching to the matching tag it just switches off ALL tags on monitor 1. This could be linked to my constantly-changing awesome config though. Nonetheless, no reason libreoffice should do the WM's job (poorly).

https://issues.apache.org/ooo/show_bug.cgi?id=96684 indicates this is fixed for them, including where the fix was applied.

Please apply the same fix for libreoffice.
Comment 6 libgradev 2014-01-07 16:34:46 UTC
Still happening with 4.1.4.2...

Now every time a menu is clicked on all other monitors switch to no tag (blank desktop).

As ngoonee states the fix is available at the OpenOffice link he provides...

Surely LibreOffice shouldn't be interacting with the WM in this way?! The only practical way I have of running LibreOffice is to use Winswitch at the moment to isolate it...
Comment 7 Alex 2014-06-17 19:12:33 UTC
Still a problem in LibreOffice 4.2.3, many years after it was reported and fixed in OpenOffice...
Comment 8 QA Administrators 2015-07-18 17:43:57 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 3. Leave a comment with your results. 4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-07-18
Comment 9 ngoonee 2015-07-20 02:20:06 UTC
I am the original reporter for this bug, and have not followed up on it for some time. Currently testing both in awesomewm and i3 I am not able to reproduce the bug. I do not remember when this behaviour changed, and what triggered it.

Here's the current versions on Arch Linux:-
libreoffice - 4.3.7 (not the most recent version as I'm a few behind)
all other software - fully updated as per Arch Linux on this date