Download it now!
Bug 34720 - FILEOPEN SVG shows pixel picture at wrong place and additional black rectangle ant place of pixel picture
Summary: FILEOPEN SVG shows pixel picture at wrong place and additional black rectangl...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.3.1 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 47445 (view as bug list)
Depends on:
Blocks: SVG-Open
  Show dependency treegraph
 
Reported: 2011-02-25 06:56 UTC by sasha.libreoffice
Modified: 2018-06-20 17:03 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
incorrect opens and inserts (40.64 KB, image/svg+xml)
2011-02-25 06:56 UTC, sasha.libreoffice
Details
a simple svg graphic that is imported wrongly in Draw (135.90 KB, image/svg+xml)
2011-02-26 07:54 UTC, Martin Kepplinger
Details
Results (812.86 KB, application/x-download)
2011-12-11 01:49 UTC, Rainer Bielefeld Retired
Details
sv1.svg in Chrome (249.42 KB, image/png)
2018-06-18 09:24 UTC, Roman Kuznetsov
Details
sv1.svg in LO Draw 6.1 beta 2 (187.35 KB, image/png)
2018-06-18 09:25 UTC, Roman Kuznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sasha.libreoffice 2011-02-25 06:56:36 UTC
Created attachment 43804 [details]
incorrect opens and inserts

In attachment is svg file with spiral and textured rectangle.
Firefox opens it ok. Libreoffice if File->Open this file, then incorrect placement of texture of rectangle. If Insert->Picture->From file in writer, then spiral allso incorrect.
Comment 1 tester8 2011-02-26 04:20:26 UTC
Reproduced with LO 3.3.1 RC2 Ubuntu 10.04 x86.
Comment 2 Martin Kepplinger 2011-02-26 07:54:22 UTC
Created attachment 43856 [details]
a simple svg graphic that is imported wrongly in Draw

another example for wrong svg import!
Comment 3 sasha.libreoffice 2011-02-28 01:48:58 UTC
I have tested second attachment (relations) on Windows XP 32 bit.
Mozilla and Corel Darw X4 opens ok.
Libreoffice 3.3.1.2 Writer and Draw, when drag-and-drop or Insert->Picture, then picture can seen, but text in incorrect places.
When Insert->Object->Ole from file, then opens only blank square.

On Liux Mandriva 64 bit LibreOffice behaves the same as in Windows.
What is interesting, AbiWord opens this file as object corrcetly, but works extramally slow and saves picture as PNG inside of odt.
Comment 4 Cédric Bosdonnat 2011-02-28 05:07:10 UTC
Thorsten, one for you it seems.
Comment 5 Rainer Bielefeld Retired 2011-12-11 00:16:37 UTC
Comment on attachment 43856 [details]
a simple svg graphic that is imported wrongly in Draw

Problems shown are completely different to the ones in original report. I will file a separate Bug report.
Comment 6 Rainer Bielefeld Retired 2011-12-11 01:45:50 UTC
We can't handle such "I see lots of problems" reports.

There is big progress in Master with reporter's sample and 'Insert -> Picture from file', but Drawing opened from file still is completely damaged (see Summary!)
Comment 7 Rainer Bielefeld Retired 2011-12-11 01:49:36 UTC
Created attachment 54316 [details]
Results

See Comment 6!

Thosrsten:
Please feel free to reassign (or reset Assignee to default) if it’s not your area or if provided information is not sufficient. Please set Status to ASSIGNED if you accept this Bug.
Comment 8 bfoman (inactive) 2013-08-15 14:57:00 UTC
(In reply to comment #0)
> In attachment is svg file with spiral and textured rectangle.
> Firefox opens it ok. Libreoffice if File->Open this file, then incorrect
> placement of texture of rectangle. If Insert->Picture->From file in writer,
> then spiral allso incorrect.

Checked with:
Version: 4.2.0.0.alpha0+
Build ID: 087a610fcd5c0c354a9ed6bfccd3451b667d62a3
TinderBox: Win-x86@6-debug, Branch:master, Time: 2013-08-04_21:41:24
Windows 8.1 Enterprise Preview 64 bit

File->Open:
General Error.
General input/output error.

Insert->Picture->From file in writer:
looks the same as in Firefox 23.
Comment 9 Thorsten Behrens (CIB) 2013-09-12 16:14:56 UTC
Apologies for not having gotten around fixing this bug yet; unfortunately in future I'll have even less time at my disposal for this, so I'm freeing up ownership for other volunteers to take over.
Comment 10 A (Andy) 2015-04-05 20:39:47 UTC
Reproducible with LO 4.4.1.2, Win 8.1

The textured rectangle of the attached svg file is not shown correctly.
Comment 11 Xisco Faulí 2015-11-10 15:16:04 UTC
http://opengrok.libreoffice.org/xref/core/filter/source/svg/svgreader.cxx#1488 is a good place to start to investigate this issue
Comment 12 Xisco Faulí 2015-11-10 16:06:58 UTC
*** Bug 47445 has been marked as a duplicate of this bug. ***
Comment 13 Robinson Tryon (qubit) 2015-12-09 18:52:44 UTC Comment hidden (obsolete)
Comment 14 QA Administrators 2017-01-03 19:41:15 UTC Comment hidden (obsolete)
Comment 15 Roman Kuznetsov 2018-06-18 09:24:53 UTC
Created attachment 142842 [details]
sv1.svg in Chrome
Comment 16 Roman Kuznetsov 2018-06-18 09:25:49 UTC
Created attachment 142843 [details]
sv1.svg in LO Draw 6.1 beta 2

looks very good
Comment 17 Roman Kuznetsov 2018-06-18 09:27:01 UTC
In LibreOffice Draw 6.1 beta 2 svg look very good

Status -> WFM