Bug 34800 - EDITING: Comments added to footer are placed at the right top of the page.
Summary: EDITING: Comments added to footer are placed at the right top of the page.
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.1 release
Hardware: All All
: high normal
Assignee: Jorendc
QA Contact: Florian Reisinger
URL:
Whiteboard: target:4.1.0 target:4.0.3 target:3.6.6
Keywords:
: 44663 53194 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-02-27 10:24 UTC by Karl Zeiler
Modified: 2013-04-12 20:17 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Description how to reproduce the problem (19.88 KB, application/vnd.oasis.opendocument.text)
2011-02-27 10:31 UTC, Karl Zeiler
Details
LibO 3.4.5 RC2: Comments text body and footnote (41.38 KB, image/png)
2012-01-11 06:11 UTC, manj_k
Details
LibO 3.4.4: Comments footer, footnote, text body (39.83 KB, image/png)
2012-01-11 06:38 UTC, manj_k
Details
leanest test case possible (2 comments -> reproduce the problem) (9.30 KB, application/vnd.oasis.opendocument.text)
2013-03-06 13:07 UTC, Jorendc
Details
Final test file to make sure all comments are calculated well (10.50 KB, application/vnd.oasis.opendocument.text)
2013-03-06 18:36 UTC, Jorendc
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Karl Zeiler 2011-02-27 10:24:46 UTC
(1) Open a writer document with footnotes.
(2) Add comments to the main text. All comments appear correctly at the right bottom of the page.
(3) Add now comments to the footnotes. All these comments are placed at the right top of the page.

If the main text is without any comments, the comments of footnotes are be correctly placed at the right bottom of the page.
Please compare the attached test file.

My system: LibO 3.1.1 and OOo 3.3.0 under Windows XP Home/Pro/7 HP.
Comment 1 Karl Zeiler 2011-02-27 10:31:24 UTC
Created attachment 43895 [details]
Description how to reproduce the problem
Comment 2 Karl Zeiler 2011-03-11 08:21:24 UTC
Comments added to frames (with text or picture or table)demonstrate the same behaviour.
Comment 3 Rainer Bielefeld Retired 2011-03-11 11:20:51 UTC
[Reproducible] with sample document and "LibreOffice 3.3.1  – WIN7  Home Premium  (64bit) German UI [OOO330m19 (build 8 / tag 3.3.1.2)]". After text comments will have been deleted, footnote comments will "jump down" to the bottom of the page.

It's not a footnote, but a footer problem!

The problem can be reproduced easily from the scratch
1. open new WRITER document
2. Menu 'Format > Page > Footer > Footer ON  <OK>
3. Insert some text to page oody (3 paragraphs lorem ipsum, for example
4. Click into Footer
5. Menu 'Insert > Comment'
   Comment appears at the bottom of the page
6. Type text "Footer" into Comment
7. Click into last text line (lorem ipsum)
8. Menu 'Insert > Comment'
   Expected: New Comment appears right from last text line, old footer comment
             stays where it is
   Actual: New comment appears as expected but old "footer" comment now will be 
           above the new text comment.

No problem with OOo 3.1.1,I will test more current OOo version soon.

@Cédric:
Your area? Please feel free to reassign if not!
Comment 4 Cédric Bosdonnat 2011-12-19 08:57:54 UTC
I can't reproduce the problem here with 3.4.2 and master builds on Linux.
Marking as worksforme, but feel free to reopen if needed.
Comment 5 manj_k 2012-01-11 06:09:31 UTC
The described bug is still reproducible (on WinXP 32b · UI en-US)
with, e.g.:

LibO 3.4.5 RC2
[LibreOffice 3.4.5 · OOO340m1 (Build:502)]

LibO 3.5.0 Beta2
[LOdev 3.5.0beta2 · Build ID: 8589e48-760cc4d-f39cf3d-1b2857e-60db978]

libreoffice-3-5~2012-01-10_01.15.10... 
[LOdev 3.5.0beta2+ · Build ID: cbb7814-880f96d-d06f752]
Comment 6 manj_k 2012-01-11 06:11:17 UTC
Created attachment 55432 [details]
LibO 3.4.5 RC2: Comments text body and footnote
Comment 7 manj_k 2012-01-11 06:12:14 UTC
*** Bug 44663 has been marked as a duplicate of this bug. ***
Comment 8 manj_k 2012-01-11 06:38:27 UTC
Created attachment 55433 [details]
LibO 3.4.4: Comments footer, footnote, text body
Comment 9 Florian Reisinger 2013-01-27 08:45:11 UTC
Changing severity. CONFIRMED @ Win7 with
Version 4.0.0.2 .0.2 (Build ID: 5991f37846fc3763493029c4958b57282c2597e)
NOT CONFIRMED: Version 4.1.0.0.alpha0+ (Build ID: 2b17d6c14d226b1973c87ff161586c39899e403)
TinderBox: Win-x86@6, Branch:master, Time: 2013-01-26_00:10:54

@Cedric Bosdonnat: Are you still working on this bug?

A "port" (or whatever this is called) for 4.0 would be great...
Comment 10 Florian Reisinger 2013-01-27 08:47:35 UTC
Sorry misunderstanding of mine... REOPEND and setting status to new NOT working on
Version 4.1.0.0.alpha0+ (Build ID: 2b17d6c14d226b1973c87ff161586c39899e403)...
I am very sorry...
Comment 11 Florian Reisinger 2013-01-27 08:47:58 UTC
Status to NEW....
Comment 12 thackert 2013-02-17 16:48:37 UTC
Hello Karl, @ll,
I can confirm this bug w/ Germanophone LO Version 4.0.0.3 (Build ID: 7545bee9c2a0782548772a21bc84a9dcc583b89) as well as with my parallel installed LO Version 4.0.1.0+ (Build ID: 4e1643f910ffbd5509f73bfb68628a5428480d1)
TinderBox: Linux-x86_64_11-Release-Configuration, Branch:libreoffice-4-0, Time: 2013-02-15_21:14:50 (also with Germanophone lang- and helppack installed ... ;) ) under Debian Testing AMD64, so I changed the Platform to "All - All" ... :( Really annoying bug ... :( I hope, it will be fixed in one of the next builds ... ;)

I have used Karl's attached document, the one from AOO's (https://issues.apache.org/ooo/attachment.cgi?id=77338 from https://issues.apache.org/ooo/show_bug.cgi?id=119088) as well as a newly created one, where I nearly followed Karl's description. But all files show the same problem ... :(

HTH
Thomas.
Comment 13 Jorendc 2013-02-19 18:22:04 UTC
Hi,

Please do not add this kind of bugs on the Most Annoying Bugs list. I can confirm this behavior is 'annoying', but not more then that. It is not a big regression or a bug that result in a crash/data loss, therefore it isn't appropriate to place it on the MAB list. If everyone will do it that way, we just can delete that list, because it'll be useless.

Following [1] I mark this as 'normal high'.

Please also read (quite outdated but still applicable): https://wiki.documentfoundation.org/Most_Annoying_Bugs

Kind regards,
Joren

[1] https://wiki.documentfoundation.org/images/0/06/Prioritizing_Bugs_Flowchart.jpg
Comment 14 Jorendc 2013-02-21 09:45:37 UTC
@Cédric: I'll try to have a look at it. I hope/think you don't mind, because you're very crunching other bugs.

I can't promise anything I can solve it, but I'll give it a try.

Kind regards,
Joren
Comment 15 Jorendc 2013-03-06 13:07:30 UTC
Created attachment 76015 [details]
leanest test case possible (2 comments -> reproduce the problem)
Comment 16 Jorendc 2013-03-06 17:41:22 UTC
Patch waiting for review: https://gerrit.libreoffice.org/#/c/2572/
Comment 17 Jorendc 2013-03-06 18:36:08 UTC
Created attachment 76038 [details]
Final test file to make sure all comments are calculated well

I also found out that placing comments in the Footer result in the same behavior. Therefore I'll tweak my patch a little bit more.

This attachment I used as final test to make sure my change wouldn't scramble all comments.
Comment 18 Jorendc 2013-03-06 19:14:48 UTC
*** Bug 53194 has been marked as a duplicate of this bug. ***
Comment 19 Commit Notification 2013-03-12 23:51:56 UTC
Joren De Cuyper committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=868f3485126827f6baf7179d1c2c3c20812cac9b

fdo#34800 Comments added to footer are placed at the right top of the page.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 20 Jorendc 2013-03-13 11:37:40 UTC
Fixed by http://cgit.freedesktop.org/libreoffice/core/commit/?id=868f3485126827f6baf7179d1c2c3c20812cac9b

I'm going to wait/test a bit longer to backport it to 4.0 branch so it is also tested by others.

Kind regards,
Joren
Comment 21 Commit Notification 2013-03-15 21:58:49 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=859e94294bdfd8595c88dd7f14da09ead8b32a45

fdo#34800 sw: small cleanup



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 22 Cor Nouws 2013-03-16 08:38:17 UTC
@ hé Joren!
Tested in Build ID: 4b4bcb1af57ee376a1185d3559202857d9777b
with attachment from comment #12 and all comments are OK.
thanks, super :-)
Comment 23 Florian Reisinger 2013-03-16 09:50:46 UTC
Thanks for the fx ;)
Comment 24 Commit Notification 2013-03-18 09:10:32 UTC
Joren De Cuyper committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1e2eecabfe0e1c192cae300430d4b0579c3be845&h=libreoffice-4-0

fdo#34800 Comments added to footer are placed at the right top of the page.


It will be available in LibreOffice 4.0.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 25 Commit Notification 2013-03-18 10:27:31 UTC
Joren De Cuyper committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=271e47b20da7581b2cf1518dd3274c1348bf7083&h=libreoffice-3-6

fdo#34800 Comments added to footer are placed at the right top of the page.


It will be available in LibreOffice 3.6.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 26 Karl Zeiler 2013-04-12 17:21:08 UTC
Special thanks to Joren.

This bug is fixed almost perfectly. But in a test with LibreOffice 3.6.6.2 (Build ID: f969faf), I still detected one problem: Opening my test file, you will see the comment "Abb. 1" is placed not correctly. That's why I opened the issue again.

Have a look to my test file above mentioned in comment 12 (Thomas):
https://issues.apache.org/ooo/attachment.cgi?id=77338

Is it possible to make the second (little) patch available in LibreOffice 3.6.7 ?
Comment 27 Jorendc 2013-04-12 20:17:41 UTC
Thanks for your additional document. 

During fixing this issue I also discovered this issue, and created "Bug 62421 - Comments added to frames or image caption are placed unconditional at the top" that needs another handling of comments. I also have to say I'm not that advanced due the fact you need to introduce a kind of 'viewframe' in it. I can't fix that one, so I hope someone else will have a look at it.

Therefore I mark this bug again as RESOLVED FIXED, because this bug is about the footer and footnote.

Kind regards,
Joren