Bug 34876 - FILEOPEN: Writer crashes consistently opening attached SDL and HIPAA.docx
Summary: FILEOPEN: Writer crashes consistently opening attached SDL and HIPAA.docx
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.1 release
Hardware: x86 (IA32) All
: medium critical
Assignee: Not Assigned
URL: https://bugs.launchpad.net/ubuntu/+so...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-01 10:03 UTC by Christopher M. Penalver
Modified: 2011-08-30 23:46 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
SDL and HIPPA.docx (334.63 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2011-03-01 10:03 UTC, Christopher M. Penalver
Details
MS Word 2002 pdf (576.54 KB, application/pdf)
2011-07-01 14:27 UTC, NoOp
Details
LO 3.4.1 pdf (585.51 KB, application/pdf)
2011-07-01 14:28 UTC, NoOp
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher M. Penalver 2011-03-01 10:03:06 UTC
Created attachment 43973 [details]
SDL and HIPPA.docx

1) lsb_release -rd
Description: Ubuntu Natty (development branch)
Release: 11.04

2) apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.3.1-1ubuntu4
  Candidate: 1:3.3.1-1ubuntu4
  Version table:
 *** 1:3.3.1-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages
        100 /var/lib/dpkg/status

3) What is expected to happen when one performs at the Terminal:

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/626755/+attachment/1869927/+files/SDL%20and%20HIPAA.docx && lowriter -nologo SDL\ and\ HIPAA.docx

*Original downloaded from http://www.microsoft.com/downloads/details.aspx?FamilyID=a471da91-dcbb-4e9a-8b6c-778a79038758&displaylang=en

Calc opens the file.

4) What happened instead is it consistently crashes.

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: libreoffice-core 1:3.3.0-1ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
Uname: Linux 2.6.38-5-generic i686
Architecture: i386
Date: Fri Feb 25 09:26:51 2011
EcryptfsInUse: Yes
ExecutablePath: /usr/lib/libreoffice/program/soffice.bin
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110202)
ProcCmdline: /usr/lib/libreoffice/program/soffice.bin -writer -nologo SDL\ and\ HIPAA.docx
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7239b6a <endLevel()+58>: lock xadd %eax,0x4(%edi)
 PC (0x07239b6a) ok
 source "%eax" ok
 destination "0x4(%edi)" (0x003c0e6d) in non-writable VMA region: 0x0033a000-0x00494000 r-xp /lib/libc-2.13.so
SegvReason: writing VMA /lib/libc-2.13.so
Signal: 11
SourcePackage: libreoffice
StacktraceTop:
 endLevel () from /usr/lib/libreoffice/program/../basis-link/program/libwriterfilterli.so
 endParagraphGroup () from /usr/lib/libreoffice/program/../basis-link/program/libwriterfilterli.so
 endParagraphGroup () from /usr/lib/libreoffice/program/../basis-link/program/libwriterfilterli.so
 endParagraphGroup () from /usr/lib/libreoffice/program/../basis-link/program/libwriterfilterli.so
 endAction () from /usr/lib/libreoffice/program/../basis-link/program/libwriterfilterli.so
Title: soffice.bin crashed with SIGSEGV in endLevel()
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
Comment 1 tester8 2011-03-01 10:32:44 UTC
LibreOffice 3.3.1 RC2 (1:3.3.0-1lucid1) - Ubuntu 10.04 x86 Linux 2.6.32-28-generic Russian UI

Reproduced.

libreoffice -writer -nologo SDL\ and\ HIPAA.docx
/home/fstrba/cvs/ooo-build/build/libreoffice-3.3.1.2/writerfilter/source/dmapper/GraphicImport.cxx:1727 failed. Message :GraphicCrop
/home/fstrba/cvs/ooo-build/build/libreoffice-3.3.1.2/writerfilter/source/dmapper/GraphicImport.cxx:1727 failed. Message :GraphicCrop

Of cource I haven't /home/fstrba directory.
Comment 2 Cédric Bosdonnat 2011-03-02 00:32:45 UTC
Can't reproduce in master build, but can reproduce in 3.3.1 build. The fix will be available in 3.4
Comment 3 NoOp 2011-07-01 14:26:46 UTC
Confirmed as working in LO 3.4.1 Final/rc3 - linux & Windows versions. There are considerable issues in what actually is rendered in the document, but I reckon that's for another bug report. Just as an FYI I've attached two PDF's of the document:

1. SDLandHIPAAx.pdf is a pdf of the document as opened in MS Word 2002 using the MS docx converter. Note that the MS docx converter is quite basic.

2. SDLandHIPAA.pdf is a pdf of the document as opened in LO 3.4.1.
Comment 4 NoOp 2011-07-01 14:27:57 UTC
Created attachment 48671 [details]
MS Word 2002 pdf
Comment 5 NoOp 2011-07-01 14:28:38 UTC
Created attachment 48672 [details]
LO 3.4.1 pdf
Comment 6 NoOp 2011-08-12 14:58:51 UTC
The document is crashing LO 3.3.3 Final:
LibreOffice 3.3.3
OOO330m19 (Build:301)
tag libreoffice-3.3.3.1
Tested in both Windows & linux.

LO 3.4.2 Final does open the doc without crashing.
Comment 7 Christopher M. Penalver 2011-08-30 23:46:51 UTC
Unreproducible in LibreOffice 3.4.2.

lsb_release -rd
 Description: Ubuntu oneiric (development branch)
 Release: 11.10

 apt-cache policy libreoffice-writer
 libreoffice-writer:
 Installed: 1:3.4.2-2ubuntu2
 Candidate: 1:3.4.2-2ubuntu2
 Version table:
 *** 1:3.4.2-2ubuntu2 0
 500 http://us.archive.ubuntu.com/ubuntu/ oneiric/main i386 Packages
 100 /var/lib/dpkg/status