Bug 35159 - Word import with password on all except fields
Summary: Word import with password on all except fields
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.1 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-09 13:24 UTC by Laurent BP
Modified: 2015-05-03 21:25 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Laurent BP 2011-03-09 13:24:20 UTC
Hello,

Let's consider a form built with Word:
http://www.inra.fr/drh/ce2011/docs/Dossier_AI.doc
It is read only except some fields. 
* If you open it with MS-Word, you can go through fields, and some fields are linked to avoid copy several times the same information.

* If you open it with LibO (3.3.1.2), the document is also read-only, but totally this time: you cannot fill any field. Click on "Edit file" button, ask for password (which I do not have). If you save file as a new name, document is read only, except fields (as expected), but links between fields are broken: you get a text "Error: Reference source not found" which cannot be removed.
It is impossible to fill the form.

* If you open it with OOo (3.3.0 RC10), the behavior is almost the same as LibO: totally read-only with no possible to fill fields. Click on "Edit file" is the same: ask for password. BUT, when saving it as a new name, the file is fully read-write accessible, and links between fields are kept. You may then open it with LibO and functionality will be the same. To go through fields, you may save it as template, and open it.
It is then possible to fill the form with OOo. 

Even if expected behavior is better respected with LibO than OOo, user cannot use LibO for such form :-(

Laurent BP
Comment 1 Yifan Jiang 2011-03-14 22:55:30 UTC
Hi Laurent, I could not download the doc you provided. Would you check the URL is still alive? Thanks~

Hi Cedric,

Any idea about this?
Comment 2 Laurent BP 2011-03-16 13:16:46 UTC
Hello,

Actually, the file may have been removed. I uploaded it on wiki:
http://wiki.documentfoundation.org/File:Dossier_AI.doc

I do not know how to build such files with MS-Word to make an example.
Comment 3 Yifan Jiang 2011-03-16 23:03:09 UTC
When I open the document in MSO 2007, it also asked me for a password when I tried to 'Stop Protect'.

So the issues considering here:

1. The fields, which are supposed to be editable, cannot be edited when the document is protected by password.

2. The reference link between fields are broken.
Comment 4 Björn Michaelsen 2011-12-23 11:52:16 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 5 Laurent BP 2011-12-26 23:57:10 UTC
Hello,

With LibO 3.5b2, the situation is worst than with LibO 3.4.5RC1.
* open document : all field are replaced by the type of the field: "FORMDROPDOWN", "FORMTEXT"
* save as a new document does not change anything: fields are lost and document is read only.
Comment 6 Cédric Bosdonnat 2014-01-20 08:57:02 UTC
Restricted my LibreOffice hacking area
Comment 7 Joel Madero 2015-05-02 15:43:50 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.2 or later)
   https://www.libreoffice.org/download/

   If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
 If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   Update the version field
   Reply via email (please reply directly on the bug tracker)
   Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 3. Leave a comment with your results. 4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-05-02
Comment 8 Laurent BP 2015-05-03 21:25:41 UTC
Hello,

With fresh master:
Version: 5.0.0.0.alpha1+
Build ID: 90273c05784f7b7e3cd4fe0beadd673b069f1296
Locale: fr-FR (fr_FR.UTF-8)

Bug#1 of comment 3 is fixed: fields are editable, while the document is read-only.
Bug#2 of comment 3 is not fixed:
On first page, you can enter data in fields: examination #, name, surname
But on pages 5 and next, these values are replaced by error message "Error: reference source not found"

As title of this bug report refers to bug#1, let's consider this bug as resolved.