Download it now!
Bug 35273 - Crash when insert listing text in outline view
Summary: Crash when insert listing text in outline view
Status: RESOLVED DUPLICATE of bug 33947
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.3.2 RC1
Hardware: x86-64 (AMD64) Linux (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-13 08:21 UTC by Andreas Mantke
Modified: 2011-12-23 13:45 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Mantke 2011-03-13 08:21:30 UTC
I get a crash with LibreOffice 3.3.2rc1 in the modul Impress if I create in my 
presentation a new slide (layout title and field with a listing). I change to the 
outline view and copy the outline from another presentation (beginning with the 
listing and ending with the title and the listing of a second slide) into the listing of my current presentation. Impress crashed short after this action.

I explored the situation a bit and tried again with a title in the new slide (of my current presentation) and every thing works. In my opinion the crash is caused from the missing title of the new slide.

My environment: openSuSE 11.3-x64, KDE 4.4.4, LibreOffice 3.3.2-x64-rc1.
Comment 1 Rainer Bielefeld Retired 2011-03-13 10:29:27 UTC
@Andreas Mantke:
Before we can think about a nomination as "blocker" of this bug we should at least know whether it's rially a LibO problem or only a problem with our personal build.
Generally a Bug should have been reproduced before it will be accpeted as a blocker:
<http://wiki.documentfoundation.org/Release_Criteria#Blocker_Bug_Nomination>

May I ask you to read  hints on <http://wiki.documentfoundation.org/BugReport> carefully?
Then please:
- Attach screenshots with comments (you can add information using LibO DRAW
  and then attach your screenshot with comments as PDF) 
- Attach all sample document required to reproduce the crash
- Contribute a step by step instruction containing every key press and every 
  mouse click how to reproduce your problem
- add information 
  -- concerning your PC (especially: video card)
  -- concerning your LibO localization
  –- Libo settings that might be related to your problems 
    (video hardware acceleration ...)
  -- everything else crossing your mind after you read a.m. URL

Please file Bug reports with status UNOCNFIRMED if your are not absolutely sure that the problem will be reproducible with information you can provide!

Thank you
Comment 2 Andreas Mantke 2011-03-13 11:17:43 UTC
@Rainer Bielefeld: I think my information about the steps how to produce the crash are clear enough. I can reproduce the crash several times. Please be cautious with your wording. I really know how to use Impress and to use the outline view.
Comment 3 Rainer Bielefeld Retired 2011-03-13 11:49:23 UTC
@Andreas Mantke:
I have no doubt that you know to use LibO presentation, but during the last 11 years doing QA for Mozilla, OOo, LibO I saw lots of bugs that only were reproducible for one user (and myself suffered from such ones). And other ones that were only reproducible under very particular circumstances. For such bugs no fix can be done, and because of that we have some guidelines.

If you want to get that bug fixed soon, you should ease our work if you can, for example contribute a sample document. 

Best regards

Rainer
Comment 4 Zack 2011-03-13 19:50:03 UTC
Not reproducible in 3.3.2 RC1 with the information provided.  Running Vista SP2 x86.
Comment 5 Caolán McNamara 2011-03-14 05:21:10 UTC
Can't reproduce from scratch, too much uncertainty to know if I'm reproducing the exact same steps. Best thing is to provide a source presentation and a destination presentation and e.g. write "start select here" "end select end here" "start paste here" etc, into them, i.e. minimize the burden of reproduction to such sufficiently silly levels that we can't deny the existence of the bug :-)
Comment 6 Yifan Jiang 2011-03-15 01:59:15 UTC
I felt the easy-to-crash situation with Impress in daily use :(

There's another bug I traced for this trouble (I'll keep my update there):

https://bugs.freedesktop.org/show_bug.cgi?id=33947

Of course, it might be another problem against this one.




@Andreas, Rather than my comments, please would you still provide more information of your situation here. Thanks!
Comment 7 Caolán McNamara 2011-03-18 01:51:01 UTC
I reckon Yifan has the right duplicate here, if not its hauntingly similar.

*** This bug has been marked as a duplicate of bug 33947 ***
Comment 8 Björn Michaelsen 2011-12-22 05:51:55 UTC
RESOLVED, FIXED or CLOSED bugs cant be KEYWORD NEEDINFO.