Download it now!
Bug 35316 - object rotation calculates incorrect pivot point
Summary: object rotation calculates incorrect pivot point
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.3.1 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-14 18:32 UTC by Joe Smith
Modified: 2017-03-18 21:33 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample document showing problem (8.81 KB, application/vnd.oasis.opendocument.graphics)
2011-03-14 18:32 UTC, Joe Smith
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Joe Smith 2011-03-14 18:32:23 UTC
Created attachment 44455 [details]
Sample document showing problem

Testing libO 3.3.1 on Fedora 13: LibreOffice 3.3  330m19(Build:8)

Rotating an object by the Format > Position and Size > Rotation dialog should set the default pivot point to the geometric center of the selection.

The pivot point is calculated correctly if the drawing scale is 1:1, but not if the drawing scale is large, for example 1:60 or 1:100.

Steps to reproduce:

1) Open the attached drawing
2) Click on the top rectangle to select it
3) Format > Position and Size > Rotation

Note that the geometric center for the object is (300,650) but Draw shows the pivot point at (197,197).

4) Angle: 90°; click OK

See that the rotated object is actually rotated around the incorrect pivot point.

This problem does not occur in OOo 3.3
Comment 1 Björn Michaelsen 2011-12-23 11:43:10 UTC Comment hidden (obsolete)
Comment 2 Dominik Kopp 2012-08-13 20:49:19 UTC
bug confirmed with version 3.5.4
Comment 3 Lars Krüger 2013-11-28 08:36:07 UTC
bug confirmed with version 4.1.1.2
Comment 4 Marc 2013-12-02 12:41:26 UTC
Bug confirmed on version 4.1.3.2
Build ID: 4.1.3.2-5.fc19

To reproduce :
Open impress
include any picture
rotate by 90 or 270 degrees
try to crop it using the left/right/top/bottom handle.
The result has nothing to do with the expected one :
- Picture is croped on the opposite side
- fraction of the picture is missing on some sides
- picture is streched in one or other direction
Comment 5 Marc 2013-12-02 12:43:16 UTC
(In reply to comment #4)
> Bug confirmed on version 4.1.3.2
> Build ID: 4.1.3.2-5.fc19
> 
> To reproduce :
> Open impress
> include any picture
> rotate by 90 or 270 degrees
> try to crop it using the left/right/top/bottom handle.
> The result has nothing to do with the expected one :
> - Picture is croped on the opposite side
> - fraction of the picture is missing on some sides
> - picture is streched in one or other direction

Sorry, comment should apply to bug 37905 !
Comment 6 QA Administrators 2015-04-19 03:20:02 UTC Comment hidden (obsolete)
Comment 7 Joe Smith 2015-04-19 04:17:09 UTC
I don't see the problem testing LO 4.4.1.2 on Fedora 21.

Looks like this should be closed.
Comment 8 QA Administrators 2016-09-20 09:24:30 UTC Comment hidden (obsolete)
Comment 9 Joe Smith 2016-09-20 12:01:45 UTC
Yes, it's fixed. The steps in the description with the test document (attachment #44455 [details]) give the correct result.

Tested with Fedora-packaged LibO 5.0.6.2 00(Build:2)

Please close.

Thanks for making great software better!
Comment 10 Johnny_M 2017-03-18 21:33:44 UTC
Closing per comment 9.